Issues Installing Servoy 8.2 On Mac OS 10.11.6

Questions and answers for all installation-related topics for Servoy products

Issues Installing Servoy 8.2 On Mac OS 10.11.6

Postby chris1503948870 » Fri Sep 01, 2017 2:05 am

Hi All.

I've installed 8.2 on my mac but when I launch it I get this error:

Screen Shot 2017-08-31 at 7.00.28 PM.png
Screen Shot 2017-08-31 at 7.00.28 PM.png (38.09 KiB) Viewed 1132 times

So if I check the log, I get:

!SESSION 2017-08-31 18:46:38.523 -----------------------------------------------
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -keyring /Users/chrispeterson/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/chrispeterson/.eclipse_keyring -showlocation

!ENTRY com.servoy.eclipse.core 4 0 2017-08-31 18:46:39.602
!MESSAGE FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: com.servoy.eclipse.core [5]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
org.eclipse.core.runtime [83]
Unresolved requirement: Require-Bundle:; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName:; bundle-version="3.7.0.v20150330-2103"; singleton:="true" [80]
Unresolved requirement: Require-Capability:; filter:="(&("

at org.eclipse.osgi.container.Module.start(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(
at org.eclipse.osgi.framework.eventmgr.EventManager$

This goes on and on btw

Any idea what I can do here?

Thank you.
Posts: 1
Joined: Mon Aug 28, 2017 9:34 pm

Re: Issues Installing Servoy 8.2 On Mac OS 10.11.6

Postby ROCLASI » Fri Sep 01, 2017 6:49 am

Hi Chris,


Unresolved requirement: Require-Capability:; filter:="(&("

Looks like you only have Java 1.6 installed. The new Servoy version requires at least Java 1.7 (Java 7).
Robert Ivens
ROCLASI Software Solutions / JBS Group, Partner
SAN Developer / Servoy Valued Professional / Servoy Certified Developer
Twitter: @roclasi / @servoyforge
ServoyForge - Building Open Source Software.
PostgreSQL - The world's most advanced open source database.
User avatar
Servoy Expert
Posts: 5249
Joined: Thu Oct 02, 2003 9:49 am
Location: Netherlands/Belgium

Return to Installation

Who is online

Users browsing this forum: No registered users and 4 guests