How to configure to use /render web components after deploym

Questions and answers for all installation-related topics for Servoy products

How to configure to use /render web components after deploym

Postby cristopher.cabrera » Sun Oct 01, 2017 3:25 am

Hi,

I've been trying for days.

I have an application that uses web components. Successfully deployed the war file and able to access the pages/forms. However, all the web components are not rendering correctly/properly. Is there any documentation of specific steps to do to make the web components work? Any configuration that I need to change or check?

I am using tomcat 8.5 and the latest version of chrome. The components load perfectly in the servoy developer, but when migrating to an application server using war deployment the web components does not display/render the way they render servoy developer.
cristopher.cabrera
 
Posts: 2
Joined: Sun Oct 01, 2017 3:21 am

Re: How to configure to use /render web components after dep

Postby cristopher.cabrera » Sun Oct 01, 2017 5:34 pm

Anybody can help. Really desperate for some ideas
cristopher.cabrera
 
Posts: 2
Joined: Sun Oct 01, 2017 3:21 am

Re: How to configure to use /render web components after dep

Postby emera » Mon Oct 02, 2017 9:23 am

Hi Cristopher,

When doing a war export we do some resource optimization by grouping the js and css files.
If you set the "servoy.ngclient.enableWebResourceOptimizer" to false on the servoy-admin page (war deployment), does it work?
If it works, then it's likely that you have some custom component that uses some library which cannot be grouped, such as font-awesome.css
You have to set the group property to false for that library. See more at https://wiki.servoy.com/pages/viewpage. ... Id=1869552

Regards,
Edit
emera
 
Posts: 21
Joined: Tue Jun 17, 2014 8:33 am

Re: How to configure to use /render web components after dep

Postby sjoerd1337768711 » Mon Oct 02, 2017 9:31 am

Sounds like that CSS-file is not working correct on Application Server. I think it has to do with the grouping of resource files. Try to put in Admin Page a FALSE on setting: servoy.ngclient.enableWebResourceOptimizer.

To solve you have to find the conflict and eliminate that. I have seen same problem and had a double CSS entry with webcomponent which conflicted.
When you have a library which is not working with grouping as CSS/JS you can put that group-option to false in the SPEC file:
"libraries": Array of js/css definitions (map with
'name'-the lib name, 'version'-the lib version, 'url'-the lib url,
'mimetype'-the lib mimetype, one of 'text/javascript' or 'text/css',
'group' - a false when this lib should not be grouped, default true) that needs to be included for this component,
Sjoerd Hannema
Muta Services B.V.
sjoerd1337768711
 
Posts: 17
Joined: Wed May 23, 2012 12:25 pm
Location: Leeuwarden, NL

Re: How to configure to use /render web components after dep

Postby paronne » Mon Oct 02, 2017 10:06 am

Hi,

have you implemented any custom web component ?
which version of Servoy are you using ?
Do you see any error log such as "cannot find *.css" in the Browser console log ?
As said from comments above the issue seems to be related to the grouping of CSS.
You can try to uncheck the "Minimize JS and CSS" option when generating the WAR file.

Regards,
Paolo
paronne
 
Posts: 107
Joined: Fri Nov 02, 2012 3:21 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 5 guests