After 8.2.1 Servoy is not working (also previous versions)

Questions and answers for all installation-related topics for Servoy products

After 8.2.1 Servoy is not working (also previous versions)

Postby rioba1401913570 » Wed Oct 25, 2017 4:34 pm

After installing version 8.2.1 on MacOS High Sierra Servoy is woking no more, also previous versions. I can start it, it loads the starting page but then it freezes and I have to force quit it. Suspecting a Java issue i completely removed the previous installation of Java and installed a new one. I tried both Java 8 and 9 with no success. Reinstalled also Servoy but the problem persisted. I really don't know what went wrong. In case someone wanted to look into the issue I also enclose the log file. Thanks.
Attachments
servoy_log.txt
(9.03 KiB) Downloaded 28 times
rioba1401913570
 
Posts: 19
Joined: Wed Jun 04, 2014 10:26 pm

Re: After 8.2.1 Servoy is not working (also previous version

Postby ROCLASI » Wed Oct 25, 2017 4:44 pm

Hi Rioba,

Upgrading macOS usually means it removes the Java 6 that you might had installed. Servoy used to still require it even though it reports it uses Java 7/8.
As far as I know Servoy fixed that issue but perhaps this is what is biting you.
You can download Java 6 from Apple here.

Hope this helps
Robert Ivens
ROCLASI Software Solutions / JBS Group, Partner
SAN Developer / Servoy Valued Professional / Servoy Certified Developer
Twitter: @roclasi / @servoyforge
--
ServoyForge - Building Open Source Software.
PostgreSQL - The world's most advanced open source database.
User avatar
ROCLASI
Servoy Expert
 
Posts: 5269
Joined: Thu Oct 02, 2003 9:49 am
Location: Netherlands/Belgium

Re: After 8.2.1 Servoy is not working (also previous version

Postby rioba1401913570 » Thu Oct 26, 2017 9:37 am

Thank you Robert for your reply. I also suspected the problem could be linked to Java 6 missing. But after installing JRE 8 if I checked the Java version using
Code: Select all
java -version
in terminal I could only detect this older Java while the preference pane listed version 8. Installing the Java sdk 8 solved the mismatch but not the Servoy problem. So I installed Servoy 8.2.1 on a new disk with only MacOS 10.13, MySql Db, Java 8 and 6 and the problem with Servoy disappeared. So the culprit is somewhere else, but I don't understand where sine I removed all previous Java installations and files.
rioba1401913570
 
Posts: 19
Joined: Wed Jun 04, 2014 10:26 pm

Re: After 8.2.1 Servoy is not working (also previous version

Postby rgansevles » Fri Oct 27, 2017 8:19 am

Hi Rioba,

When Servoy is frozen, is de admin page via the browser working?
If yes, please post the result of the thread dump here.

http://localhost:8080/servoy-admin/dumpstack

Rob
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1861
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL

Re: After 8.2.1 Servoy is not working (also previous version

Postby rioba1401913570 » Fri Oct 27, 2017 8:39 pm

Hi Rob,

thanks. The thread dump is attached
Attachments
Servoy 821 Dumpstack.txt
(27.75 KiB) Downloaded 30 times
rioba1401913570
 
Posts: 19
Joined: Wed Jun 04, 2014 10:26 pm

Re: After 8.2.1 Servoy is not working (also previous version

Postby hovw » Sat Oct 28, 2017 8:57 am

Same problem

Servoy server is running but can't connect to the admin page


'cannot decode raw data' (NSURLErrorDomain:-1015)


Also with a systems that use JDK 1.8, it works fine with osx sierra
OSX 10.9.5 - 10.13.1
hovw
 
Posts: 18
Joined: Wed Nov 04, 2009 10:41 pm

Re: After 8.2.1 Servoy is not working (also previous version

Postby rgansevles » Sat Oct 28, 2017 2:51 pm

This does seem to be a problem with the java version, it is hanging in a native apple java call.
Note that Servoy 8.2 requires java 7.

On the admin page you can see the jvm used
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1861
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL

Re: After 8.2.1 Servoy is not working (also previous version

Postby jcompagner » Fri Dec 08, 2017 4:52 pm

hovw wrote:Same problem

Servoy server is running but can't connect to the admin page


'cannot decode raw data' (NSURLErrorDomain:-1015)


Also with a systems that use JDK 1.8, it works fine with osx sierra



this is a problem with zlib native lib that was updated and that java uses.
you need to turn of compression in the server.xml of your application server.

I also mentioned this in other post, servoy doesn't need java6. that it ask for java6 is an installation problem of your java on your system
Servoy 8.x can't even run on java6 anymore at all.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8083
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests