Servoy 5.0.1

Servoy announcements

Servoy 5.0.1

Postby Jan Blok » Fri Dec 11, 2009 1:26 pm

We are pleased to announce the immediate availability of Servoy 5.0.1

This version is available through the download page on the Servoy website (developer section) and auto update.
Note: since the Eclipse.org has a problem with the update-site you have to disable the eclipse update-sites in: Window -> Preferences (update sites)

Make a backup of your current Servoy installation (directory and database) before installing.

Client changes:
[fix] 254981 Event parameter has null formname from List View forms
[fix] 255057 Setting value in dataset using the named column doesn't work
[fix] 255666 Bug with StringSerializer converter and arrays
[fix] 254971 onRecordSelection and onAction not firing during multi-selection
[fix] 254839 Several Webclient Drag N Drop / multiSelect issues
[fix] 256176 Relations based on UUID columns issue
[fix] 255942 Error in servoy.js in WC shown in browser
[fix] 255690 Valid JS code throws an error when used to instantiate a variable
[fix] 254952 Using fallback valuelist mechanism icw valuelists that return an id but display text, throws error
[fix] 257568 onRightClick events failing on labelFor fields
[fix] 254929 A media dataprovider attached to a label doesn't show the image in webclient.
[fix] 256618 "About" missing from Dutch help menu
[fix] 257198 The calculation which should be triggered doesn't seem to be triggered anymore.
[fix] 258326 error using foundset.duplicateRecord(false)
[fix] 259470 Calling the element method getAbsoluteFormLocationY() throws exception
[fix] 255028 exception when going into findmode when using linked relations
[fix] 260283 Exception com.servoy.j2db.dataprocessing cannot be cast during find

Developer changes:
[enh] 254598 IFoundSet.sort() and IFoundSet.getSort() API addition
[fix] 256246 formatter settings are not respected by auto-generated method stubs
[fix] 256957 occasional *.js file checkout problem
[fix] 247891 property labels 'disapear' when clicked on
[fix] 252286 Profiler view: display of arguments of the onsolutionstart method is odd
[fix] 254062 Link with editor-button in the solution explorer doesn't work for valuelists
[fix] 253976 Code is running in developer when smart client is idle
[fix] 255324 servoy team provider: Modules are not saved with SolutionType=2
[fix] 254951 Relation Editor: selecting a dataprovider through Control-click in cell doesn't actually set the dataprovider
[fix] 256808 I18n checkout problem
[fix] 252287,256211 Developer hangs when debugging some scripts
[fix] 255277 Uppercase table conversion issue when importing Servoy 3.x to 5.0 solution
[fix] 257024 Developer out of memory when viewing data in table definition
[fix] 256829 exception when debugging
[fix] 257064 Bug in autocompletion
[fix] 256477 Missing 'Math' functions in solution explorer tree
[fix] 259520 Servoy file extension missing after browse+rename for solution export
[fix] 258382 selecting solution export path fails from Mac when using 'browse'
[fix] 258390 Servoy5 creates a REAL (7) in Sybase 11 instead of of FLOAT
[fix] 258323 Using "new XML()" gives error: Error during evaluation

Application Server changes:
[fix] 255689 Cluster goes out of maintenance mode when restarting one of the Servoy App servers
[fix] 257258,256601 deep linking of solutions does not work when servoy.allowSolutionBrowsing = false
[fix] 255012,257756 escape characters in I18n messages on application server
[fix] 259928 HTTP Tunneling in Servoy 5.0 throws error on remote servers
[fix] 257443 exception when batchprocessor starts

Plugin changes:
[fix] 255654,257425 popupmenu plugin doesn't work right in WC
[fix] 258391 treeview needs a method to return it's name
[fix] 258383 missing 'binding' node in solution explorer tree for DBTreeView bean
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Re: Servoy 5.0.1 - updater (small) error

Postby olivier melet » Sat Dec 12, 2009 7:54 pm

After upgrading Servoy 5.0 developer to Servoy 5.0.1, on my Mac, with the update menu, the application refuse to start generating an error log file.

I had to correct the following line in the config.ini (/Applications/Servoy5.0/developer/configuration/config.ini):

from:
osgi.framework=file\:/Applications/Servoy5.0/developer/Servoy.app/Contents/MacOS/plugins/org.eclipse.osgi_3.5.0.v20090520.jar
to:
osgi.framework=file\:/Applications/Servoy5.0/developer/plugins/org.eclipse.osgi_3.5.0.v20090520.jar

The update incorrectly inserted "Servoy.app/Contents/MacOS/" in the path to plugins folder and then cannot found the "EclipseStarter" class.
olivier melet
 
Posts: 183
Joined: Mon Apr 19, 2004 3:33 pm
Location: Switzerland

Re: Servoy 5.0.1

Postby jcompagner » Mon Dec 14, 2009 11:16 am

You also installed the update of eclipse itself, in the update dialog you get 2 items Eclipe 3.5.x and servoy dont check eclipse 3.5.x, this cant be done because eclipse changes the installation itself

You have to do a clean install and point to your workspace.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 5.0.1

Postby Thomas Parry » Mon Dec 14, 2009 5:24 pm

Johan,
that advice is good.
However the advice given on screen is to go look at the software updates and there is no mention of do not upload eclipse. Maybe there could be something Servoy could add to make this more clear.
Thomas Parry
 
Posts: 498
Joined: Thu Jan 10, 2008 8:48 pm
Location: Ottawa, Canada

Re: Servoy 5.0.1 Solution not in Application Server

Postby Armin_kessler » Wed Dec 30, 2009 6:15 am

When importing my solution in Servoy 501 Developer , the solution
is loaded OK , and all works fine , but in the Application Server
my solution doesn't exist , why ?

Thanks Armin
Armin_kessler
 
Posts: 59
Joined: Sun Oct 28, 2007 6:12 am
Location: Venezuela

Re: Servoy 5.0.1

Postby jcompagner » Wed Dec 30, 2009 10:25 am

you are using the Developer import so File -> Import -> Servoy solution?

Then you have imported it straight into the developers workspace, not in the Application server for that you have to share and commit it with the servoy team repository
or also import it through the admin pages.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 5.0.1 Solution not in Application Server

Postby Armin_kessler » Wed Dec 30, 2009 2:00 pm

Johan:
Thanks for your reply and have a good day.

But in Servoy 500 when you import the solution , it appears in the Application Server,

How to : share and commit it with the servoy team repository ?

How to: or also import it through the admin pages ?

In Wiki I search "Share Project" and it explain nothing.

Thanks Armin
Armin_kessler
 
Posts: 59
Joined: Sun Oct 28, 2007 6:12 am
Location: Venezuela

Re: Servoy 5.0.1 Solution not in Application Server

Postby jcompagner » Wed Dec 30, 2009 3:07 pm

Armin_kessler wrote:But in Servoy 500 when you import the solution , it appears in the Application Server,


no it doesnt, it only does that if you import through the admin pages of the application server
Normally if you look at http://localhost:8080/servoy-admin/solutions
of a developer you will see 2 things,
1 > nothing with the remarkt that "team repository is not enabled" see http://localhost:8080/servoy-admin/ and then property servoy.application_server.startRepositoryAsTeamProvider
2> you see a solution list, this is the list thats inside the repository database of the team server (the committed solutions)
Not the solutions you see in the workspace of your servoy developer

Armin_kessler wrote:How to : share and commit it with the servoy team repository ?


In servoy developer Team->Share on a project.
And share it with the local (or remote) servoy team server (that has the servoy.application_server.startRepositoryAsTeamProvider enabled)

Armin_kessler wrote:
How to: or also import it through the admin pages ?


That only works in 5+ for application servers that are not in startRepositoryAsTeamProvider mode.
So this has to be a separate installation of the application server (or started separately) with startRepositoryAsTeamProvider = false.

The question is why do you want it in your local app server?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 5.0.1

Postby lesouef » Mon Feb 01, 2010 8:02 pm

just installed 5.01b3 on top of the regular 5.0
seems like the dragOver and onDrop are not sending any event anymore, onDrag is ok. Is it supposed to use the code for v5.0 (whihc was ok) with no change or not? tested on smart client...
lesouef
 
Posts: 420
Joined: Thu Oct 20, 2005 8:13 pm
Location: Strasbourg & Paris - France

Re: Servoy 5.0.1

Postby jcompagner » Mon Feb 01, 2010 9:05 pm

lesouef wrote:just installed 5.01b3 on top of the regular 5.0
seems like the dragOver and onDrop are not sending any event anymore, onDrag is ok. Is it supposed to use the code for v5.0 (whihc was ok) with no change or not? tested on smart client...


this should be fixed in the next release of 5.1
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 5.0.1

Postby lesouef » Mon Feb 01, 2010 10:21 pm

thanks. fyi, I have a post somewhere here
viewtopic.php?f=22&t=13507#p70614
reporting some missing aspects of this feature (no drop on empty tables), may be interesting to compare it with what you planned to do. was tested with 5.0.
lesouef
 
Posts: 420
Joined: Thu Oct 20, 2005 8:13 pm
Location: Strasbourg & Paris - France

Re: Servoy 5.0.1

Postby lesouef » Wed Feb 03, 2010 4:52 pm

file plug-in shipped with 5.01b3 does not load at startup.
Using the 5.01 jar instead works.
lesouef
 
Posts: 420
Joined: Thu Oct 20, 2005 8:13 pm
Location: Strasbourg & Paris - France

Re: Servoy 5.0.1

Postby jcompagner » Wed Feb 03, 2010 5:06 pm

lesouef wrote:file plug-in shipped with 5.01b3 does not load at startup.
Using the 5.01 jar instead works.



viewtopic.php?f=1&t=13588#p70423

or use RC1
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 5.0.1

Postby lesouef » Wed Feb 03, 2010 5:39 pm

works. thanks.
I have now subscribed to the right topic.
will update to rc1 soon anyway
lesouef
 
Posts: 420
Joined: Thu Oct 20, 2005 8:13 pm
Location: Strasbourg & Paris - France


Return to Announcements

Who is online

Users browsing this forum: No registered users and 2 guests