Servoy 7.4

Servoy announcements

Re: Servoy 7.4

Postby mmuntean » Tue Mar 25, 2014 9:46 am

david wrote:Web editor for mobile client is not showing anything. Fresh install, Mac 10.9.2, Java 1.6.0_65, Xul runner installed, and properties file addition.


The ..DefaultType=mozilla line needs to be added at the end of the servoy.ini file, not servoy.properties. Did you do this and still not working?
mmuntean
 
Posts: 2
Joined: Fri Jun 08, 2012 2:41 pm
Location: Timisoara

Re: Servoy 7.4

Postby [email protected] » Tue Mar 25, 2014 10:07 am

Today, suddenly after startup the properties came back myseriously... Neverthelesse the warningslist is huge: tens of thousands of warnings: about non existing variables than are in reality table fields of the foundset, column differences that should be resolved weeks ago, and lots more...
I'm sorry but I'am downgrading. This is just a lot work extra work that I did not count for. It is just not stable enough for big solutions like ours.
Jos Uitenbogaard
Devoon
User avatar
[email protected]
 
Posts: 56
Joined: Tue Oct 25, 2011 11:59 am
Location: Reeuwijk NL

Re: Servoy 7.4

Postby Harjo » Tue Mar 25, 2014 10:15 am

Hi Jos,

we also have a very big solution, and we only got 6 extra warnings.
The thing was, I got also in first place 2000 extra warnings, but somehow the property, that I only wanted to see warnings of the active solution (with modules) was lost.
After re-instating that property everything was fine again.

We upgraded from 7.3.1 to 7.4.

From which version are you comming?
Harjo Kompagnie
Direct ICT / Servoy Hosting / ServoyCamp
Servoy Certified Developer
Servoy Valued Professional
SAN Developer
User avatar
Harjo
 
Posts: 4271
Joined: Fri Apr 25, 2003 11:42 pm
Location: DEN HAM OV, The Netherlands

Re: Servoy 7.4

Postby Andrei Costescu » Tue Mar 25, 2014 10:21 am

[email protected] wrote:about non existing variables than are in reality table fields of the foundset, column differences that should be resolved weeks ago, and lots more...

Are you using the same workspace as before? Are you using the same database server? If you open the missing field's table in table editor, is the column there? (from what I can think of, you either are using different database content or the problem markers are somehow out-of-date in which case a Project -> Clean should fix it)

Or is it what Harjo just said? Are those problem markers from other solutions then the active one (and modules)?
Andrei Costescu
Servoy
Andrei Costescu
 
Posts: 905
Joined: Tue Jun 26, 2007 3:14 pm

Re: Servoy 7.4

Postby mmuntean » Tue Mar 25, 2014 10:57 am

I reproduced something related, that occurs after checkout from SVN. Many warnings like this one: The method getSelectedIndex() is undefined for object foundset
A case is created for this: https://support.servoy.com/browse/SVY-6287
mmuntean
 
Posts: 2
Joined: Fri Jun 08, 2012 2:41 pm
Location: Timisoara

Re: Servoy 7.4

Postby Andrei Costescu » Tue Mar 25, 2014 11:18 am

Case SVY-6024 is about properties not showing when opening a form editor until you click on a free space inside it.
You can add more info to it if necessary (if something more then this doesn't work in 7.4 related to showing form/element properties).
Andrei Costescu
Servoy
Andrei Costescu
 
Posts: 905
Joined: Tue Jun 26, 2007 3:14 pm

Re: Servoy 7.4

Postby [email protected] » Tue Mar 25, 2014 12:02 pm

Harjo wrote:Hi Jos,

we also have a very big solution, and we only got 6 extra warnings.
The thing was, I got also in first place 2000 extra warnings, but somehow the property, that I only wanted to see warnings of the active solution (with modules) was lost.
After re-instating that property everything was fine again.

We upgraded from 7.3.1 to 7.4.

From which version are you comming?


We updated also from 7.3.1
Jos Uitenbogaard
Devoon
User avatar
[email protected]
 
Posts: 56
Joined: Tue Oct 25, 2011 11:59 am
Location: Reeuwijk NL

Re: Servoy 7.4

Postby [email protected] » Tue Mar 25, 2014 12:14 pm

Harjo wrote:Hi Jos,

we don't have that problem, not seeing the properties. It simply works. Maybe something is broken... Did you try a fresh install?
And about typecast two different types, it is still possible to do that, but the reason is that you now have to explicitly tell it, that you you can return two different types.
If you don't do that, you'll get a warning indeed...


We also typecast explicitly some variables as 2 types like this @type{tupe1|type2} but it gives nevertheless a warning as if this kind of type is something different i.e. @type{type1|type2} equals not @type{type1} or vice versa.
Jos Uitenbogaard
Devoon
User avatar
[email protected]
 
Posts: 56
Joined: Tue Oct 25, 2011 11:59 am
Location: Reeuwijk NL

Re: Servoy 7.4

Postby [email protected] » Tue Mar 25, 2014 12:16 pm

Andrei Costescu wrote:
[email protected] wrote:about non existing variables than are in reality table fields of the foundset, column differences that should be resolved weeks ago, and lots more...

Are you using the same workspace as before? Are you using the same database server? If you open the missing field's table in table editor, is the column there? (from what I can think of, you either are using different database content or the problem markers are somehow out-of-date in which case a Project -> Clean should fix it)

Or is it what Harjo just said? Are those problem markers from other solutions then the active one (and modules)?


All i did was upgrading by clicking the small yellow box in the right hand corner. No db changes, no missing fields, no missing tables. clean does not fix it.
Jos Uitenbogaard
Devoon
User avatar
[email protected]
 
Posts: 56
Joined: Tue Oct 25, 2011 11:59 am
Location: Reeuwijk NL

Re: Servoy 7.4

Postby Harjo » Tue Mar 25, 2014 12:29 pm

[email protected] wrote:We also typecast explicitly some variables as 2 types like this @type{tupe1|type2} but it gives nevertheless a warning as if this kind of type is something different i.e. @type{type1|type2} equals not @type{type1} or vice versa.


yes we had 6 of those, and we thought it was wrong also, but after closely looking, it was us, doing it wrong! :)
Maybe you can post a complete method? for example?
Harjo Kompagnie
Direct ICT / Servoy Hosting / ServoyCamp
Servoy Certified Developer
Servoy Valued Professional
SAN Developer
User avatar
Harjo
 
Posts: 4271
Joined: Fri Apr 25, 2003 11:42 pm
Location: DEN HAM OV, The Netherlands

Re: Servoy 7.4

Postby jcompagner » Tue Mar 25, 2014 1:41 pm

[email protected] wrote:
We also typecast explicitly some variables as 2 types like this @type{tupe1|type2} but it gives nevertheless a warning as if this kind of type is something different i.e. @type{type1|type2} equals not @type{type1} or vice versa.


what are you exactly doing?

it is correct that a type that is of type1|type2 doesn't fit into a type1 only

so:

Code: Select all
/**
  * @param {type1} a
  */
function test(a) {}

/** @type {type1|type2}
var x = something;
test(a)


that test function will result in a warning.. because x can also be of type2 and the test function doesn't accept that.

This is also just bad code.. You should never have variable declarations that are typed like that
a union type should only be used for params.. To reflect overloaded method. But variables inside methods and so on should always be just of one type.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7977
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 7.4

Postby jcompagner » Tue Mar 25, 2014 2:02 pm

for people that has those property view is empty problems
What does your log say in your workspace (.metadata/.log) are there errors there?

If you come from 7.3.1 and you have installed subclipse fully (so including mylyn, first deinstall that mylyn part of subclipse, that is really behaving funny)
Just as a remark, if you install subclipse, don't install the optional mylyn part that only gives you loads of more stuff and extra plugins that you very likely not use anyway.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7977
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 7.4

Postby Andrei Costescu » Tue Mar 25, 2014 2:02 pm

[email protected] wrote:clean does not fix it.

One developer restart followed by one clean - that should fix it if it's only a JS compile cache problem.
All those wrong markers were related to scripting right?

Edit: hmm you also mentioned column differences... are those wrong as well? I mean if you look at one of them - what's in the table and what's in the .dbi file for that column - does the warning make sense (is in sync with table and dbi content) or not? If not could you post info of table editor for that column, info from .dbi and warning message.
Andrei Costescu
Servoy
Andrei Costescu
 
Posts: 905
Joined: Tue Jun 26, 2007 3:14 pm

Re: Servoy 7.4

Postby david » Tue Mar 25, 2014 4:38 pm

mmuntean wrote:
david wrote:Web editor for mobile client is not showing anything. Fresh install, Mac 10.9.2, Java 1.6.0_65, Xul runner installed, and properties file addition.


The ..DefaultType=mozilla line needs to be added at the end of the servoy.ini file, not servoy.properties. Did you do this and still not working?


Nice catch and ... still not working. Getting a black editor now instead of a white editor though :)
David Workman, Kabootit

Image
Everything you need to build great apps with Servoy
User avatar
david
 
Posts: 1724
Joined: Thu Apr 24, 2003 4:18 pm
Location: Washington, D.C.

Re: Servoy 7.4

Postby david » Tue Mar 25, 2014 4:44 pm

jcompagner wrote:(.metadata/.log)


Clean install here. My workspace log attached.
You do not have the required permissions to view the files attached to this post.
David Workman, Kabootit

Image
Everything you need to build great apps with Servoy
User avatar
david
 
Posts: 1724
Joined: Thu Apr 24, 2003 4:18 pm
Location: Washington, D.C.

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests