Servoy 7.4.5

Servoy announcements

Re: Servoy 7.4.5

Postby rgansevles » Fri Dec 04, 2015 1:02 pm

Lambert,

I just tried a clean install of Servoy 7.4.5, imported a solution file with some big media (14MB), worked fine, also using the file plugin.

I guess something else than the size is the problem.
Do you have anything in the logs of server 2?

Rob
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1841
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL

Re: Servoy 7.4.5

Postby lwjwillemsen » Fri Dec 04, 2015 3:42 pm

You mean the http plugin ?

In the Servoy log : nothing.
In the Tomcat log :
127.0.0.1 - - [04/Dec/2015:14:20:37 +0100] "POST /servoy-admin/solutions/import HTTP/1.1" 401 951
127.0.0.1 - - [04/Dec/2015:14:20:37 +0100] "POST /servoy-admin/solutions/import HTTP/1.1" 401 951
127.0.0.1 - - [04/Dec/2015:14:20:37 +0100] "POST /servoy-admin/solutions/import HTTP/1.1" 401 951
127.0.0.1 - - [04/Dec/2015:14:20:37 +0100] "POST /servoy-admin/solutions/import HTTP/1.1" 401 951

Strange that the POST is fired 4 times.
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 571
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Re: Servoy 7.4.5

Postby lwjwillemsen » Fri Dec 04, 2015 4:00 pm

I just tried a clean install of Servoy 7.4.5, imported a solution file with some big media (14MB), worked fine


Can there be some kind of difference in tomcat or other config between a clean install 7.4.5 and a
7.4.4 to 7.4.5 upgraded server ?
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 571
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Re: Servoy 7.4.5

Postby jcompagner » Tue Dec 22, 2015 11:26 am

if you do a clean install of a app server of 7.4.5
and you connect to that locally do you still have the same problem?

but the weird thing is a 401 is a "Unauthorized"
That is what we throw when the username/pw is not correct and an admin user...
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 7.4.5

Postby lwjwillemsen » Tue Dec 22, 2015 10:52 pm

and an admin user...


and an admin user what?
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 571
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Re: Servoy 7.4.5

Postby jcompagner » Wed Dec 23, 2015 10:43 am

only Admin users (belonging to the 'Administrators' group) are allowed to access the admin pages.

So if you log in with a user that is not known to the system at all, or not an admin user or the user/password combination is incorrect we throw that 401
Weird thing is that i guess the same user works for you in a smaller solution but not a big one. So i don't fully understand where then the 401 comes from..
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7978
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 7.4.5

Postby tgs » Wed Dec 30, 2015 12:00 am

Servoy 7.4.5 releaseNumber 2041 is out since two month, but I don't get the Servoy application server 7.4.4 (2039) updated by: java -jar servoy_updater.jar!

I always get:
$ java -jar servoy_updater.jar
Current Servoy version 2039
Checking for new Servoy version
Working in directory: /Applications/Servoy74
Loading version info...
No update found, if you want beta versions start with option: -beta
Done, Servoy can be started

What's wrong?

Regards Thomas
Thomas Schnaus
SAN Developer
yomotec GmbH
User avatar
tgs
 
Posts: 833
Joined: Wed Oct 04, 2006 12:05 pm
Location: Germany

Re: Servoy 7.4.5

Postby grahamg » Wed Dec 30, 2015 1:51 am

Hi Thomas

You need to force the actual release number:

java -jar servoy_updater.jar -releaseNumber 2041
Graham Greensall
Worxinfo Ltd
www.worxinfo.com
grahamg
 
Posts: 723
Joined: Fri Oct 03, 2003 3:15 pm
Location: Midlands UK

Re: Servoy 7.4.5

Postby rgansevles » Fri May 20, 2016 1:55 pm

lwjwillemsen wrote:We are using the http-plugin to post new solutions (through admin page) into Servoy Application Server.
That works fine in Servoy 5 and Servoy 7.4.4
In 7.4.5 this is broken (Tomcat upgrade ?).
We use this code :
// _solution is file-object

var _client = plugins.http.createNewHttpClient()
_client.setTimeout(0)
_poster = _client.createPostRequest(_url)
_poster.addFile('if', 'file', _solution.getAbsolutePath())
_poster.addParameter('ac','on') // Activate new release of imported solution and modules
// and more parameters

var _response = _poster.executeRequest(_admin_user, _admin_password) // _httpCode 200 is ok

The executeRequest returns immediately and _response has no value.
Strange thing is that smaller solution files import just fine!

Help!


We found out that this issue is related to the tomcat upgrade.
In Servoy 8 (yet another Tomcat version) this issue does not occur.

As a workaround, you can set the Authorization header before executing the POST:
Code: Select all
poster.addHeader('Authorization', 'Basic ' + encodeBase64(user + ':'+password));

With helper function encodeBase64() as shown By Robert Ivens in viewtopic.php?f=22&t=21288

Rob
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1841
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL

Re: Servoy 7.4.5

Postby lwjwillemsen » Fri May 20, 2016 6:18 pm

So the size of the solution did play a role!

With the Authorization header the solution import runs fine.

Regards and also thanks to Rob and Johan,
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 571
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Previous

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest