Servoy 3.0.1

Servoy announcements

Servoy 3.0.1

Postby Jan Blok » Thu Nov 02, 2006 11:01 pm

We announce the immediate availability of Servoy 3.0.1

Make a backup of your current Servoy installation (directory and database) before installing.

This version will also be available through auto update shortly (via help menu -> check for new version)

Changes:
[enh]-performance improvement in 2way socket handling
[enh]-less connection closes when client network disconnects happens
[enh]-better modules caching on client host
[enh]-media:///blobloader usage is working in webclient
[enh]-onAction is fired when non editable media field is clicked
[enh]-bundled latest docs
[fix]-prevent duplicate user/group creation
[fix]-exception in 2.2.x solution import via admin page
[fix]-F6 now working in debugger (step over)
[fix]-statefull use of multiple date/time displays on same dataprovider in web client
[fix]-moved elements before printing not visible in printout from webclient
[fix]-runtime builder startup
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Postby john.allen » Fri Nov 03, 2006 3:33 am

[enh]-onAction is fired when non editable media field is clicked


That's great, Jan! I was starting to wonder if it was just me doing something wrong. I really wanted to be able to 'click' thumbnail pictures to see the full-size without messing around. I'll wait for the 'auto-update' and check it out.

Thanks!
John Allen
Stanford University
john.allen
 
Posts: 515
Joined: Wed Jul 02, 2003 10:07 pm
Location: Stanford CA USA

Postby rioba » Fri Nov 03, 2006 8:44 am

Thanks, now the help system works correctly on "my" MacOS X and v. 3.0 documents are correctly downloaded (before I always got v 2.2.4)
rioba
 
Posts: 242
Joined: Mon Aug 08, 2005 4:26 pm

Re: Servoy 3.0.1

Postby Karel Broer » Fri Nov 03, 2006 9:59 am

Jan Blok wrote:[enh]-media:///blobloader usage is working in webclient

Perfect! Thanks, Jan! :D
[fix]-exception in 2.2.x solution import via admin page

Still get the '[error] java.lang.NullPointerException' with importing 2.2.5 solution(s). :(
Karel Broer
ServoyCamp - http://www.servoycamp.com
User avatar
Karel Broer
 
Posts: 779
Joined: Mon May 03, 2004 12:49 am
Location: Doetinchem

Postby Jan Blok » Fri Nov 03, 2006 10:21 am

There must be something strange with that solution, is it possible you sent the file to us?
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Postby hpmxxx » Fri Nov 03, 2006 10:58 am

[enh]-onAction is fired when non editable media field is clicked


Should this be working, too on "Table view"?
Hans-Peter Minnig
MGT AG
hpmxxx
 
Posts: 82
Joined: Wed Sep 10, 2003 5:50 pm
Location: Switzerland

Postby Jan Blok » Fri Nov 03, 2006 11:28 am

yes, is it not?
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Postby elyod_72 » Fri Nov 03, 2006 8:15 pm

I was disappointed to learn that Case ID 52568 (multiline portal malfunction in printing) had not been addressed in this release. I was hoping that a relatively easy fix would be possible. Any status on this bug?
- Jim Tittle

Servoy Developer Version 3.5.5
Java version 1.6.0_03-b05 (Windows XP)
Java version 1.5.0_13-121 (Mac OS X)
Java version 1.5.0_06-b05(Linux)
elyod_72
 
Posts: 198
Joined: Tue Dec 28, 2004 12:45 am
Location: Hollywood, CA.

Postby hpmxxx » Sat Nov 04, 2006 7:52 pm

yes, is it not?

No, it working only with a double click. Is the "double click" a new feature in 3.0.1? If yes, how can I control it?

If I'm using a tooltip on the element, the double click doesn't work neither.
Hans-Peter Minnig
MGT AG
hpmxxx
 
Posts: 82
Joined: Wed Sep 10, 2003 5:50 pm
Location: Switzerland

Postby Jan Blok » Mon Nov 06, 2006 11:40 am

both issues will be corrected in the next release
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Re: Servoy 3.0.1

Postby Karel Broer » Wed Nov 08, 2006 4:11 pm

Jan Blok wrote:[enh]-media:///blobloader usage is working in webclient

Can't get the blobloader working in the webclient. Also used this solution to test, but no results :(
http://forum.servoy.com/viewtopic.php?t=7229

Servoy Developer
Version 3.0.1-build 372
Java version 1.5.0_06-64 (Mac OS X)
Karel Broer
ServoyCamp - http://www.servoycamp.com
User avatar
Karel Broer
 
Posts: 779
Joined: Mon May 03, 2004 12:49 am
Location: Doetinchem

Postby pbakker » Thu Nov 09, 2006 9:52 am

Can you tell some more about what you're doing? Sample olution? code?

Because it works fine overhere...

Paul
pbakker
 
Posts: 2821
Joined: Wed Oct 01, 2003 8:12 pm
Location: Amsterdam, the Netherlands

Postby Karel Broer » Thu Nov 09, 2006 10:04 am

pbakker wrote:Can you tell some more about what you're doing? Sample olution? code?

Because it works fine overhere...

Paul


Hi Paul!
Weird that blobloader works fine -in the web client- on your side...
I use this as sample solution. Code is included:
http://forum.servoy.com/viewtopic.php?t=7229
Karel Broer
ServoyCamp - http://www.servoycamp.com
User avatar
Karel Broer
 
Posts: 779
Joined: Mon May 03, 2004 12:49 am
Location: Doetinchem

Postby pbakker » Fri Nov 10, 2006 12:35 pm

Karel, it's being checked.

Paul
pbakker
 
Posts: 2821
Joined: Wed Oct 01, 2003 8:12 pm
Location: Amsterdam, the Netherlands

Postby pbakker » Mon Nov 13, 2006 2:25 pm

Karel,

Issue confirmed. Will be fixed in 3.02.

Paul
pbakker
 
Posts: 2821
Joined: Wed Oct 01, 2003 8:12 pm
Location: Amsterdam, the Netherlands


Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests