form palete

Questions and answers for designing and implementing forms in Servoy

form palete

Postby imarti » Sat Mar 26, 2016 5:55 pm

Hi,

I'm new in servoy. I looking for the palette with the element. I don't now where is in the menu, anyone can help me?

I upload the screen of my servoy, it's the 8.0 version.
Attachments
Sin título.jpg
Sin título.jpg (333.63 KiB) Viewed 4001 times
Last edited by imarti on Tue Mar 29, 2016 5:22 pm, edited 1 time in total.
imarti
 
Posts: 7
Joined: Sat Mar 26, 2016 5:52 pm

Re: form palete

Postby Jan Aleman » Mon Mar 28, 2016 9:39 pm

have you tried to reset your perspective?
Jan Aleman
Servoy
Jan Aleman
Site Admin
 
Posts: 2075
Joined: Wed Apr 23, 2003 9:49 pm
Location: Planet Earth

Re: form palete

Postby imarti » Tue Mar 29, 2016 1:17 pm

Jan Aleman wrote:have you tried to reset your perspective?


Hi jan,

It's the first installation. When I anstall it, it's like the photo, I don't know what's the problem.

If I install the 6.0, it's ok, with palette, or if I install in ios, it's ok to.

thanks for your help, but I don't understand where is the problem
imarti
 
Posts: 7
Joined: Sat Mar 26, 2016 5:52 pm

Re: form palete

Postby Andrei Costescu » Tue Mar 29, 2016 1:38 pm

It might be something special with your solution or form. If you create a new solution and a new form does it show? (it should be there in the editor)

You should check the log files. (one is "application_server/servoy_log.txt" and the other is in your workspace dir/.metadata/.log)
If you see nothing of use there, when you open the form editor, in your workspace log file you will see an URL. Open your OS's browser, open the browser's console and access that URL.

See if you get any errors in the browser console. Some enhancements in this area were made for 8.0.3 so that more of the errors that happen in the browser end up in the log files.
Andrei Costescu
Servoy
Andrei Costescu
 
Posts: 943
Joined: Tue Jun 26, 2007 3:14 pm

Re: form palete

Postby imarti » Tue Mar 29, 2016 3:45 pm

Andrei Costescu wrote:It might be something special with your solution or form. If you create a new solution and a new form does it show? (it should be there in the editor)

You should check the log files. (one is "application_server/servoy_log.txt" and the other is in your workspace dir/.metadata/.log)
If you see nothing of use there, when you open the form editor, in your workspace log file you will see an URL. Open your OS's browser, open the browser's console and access that URL.

See if you get any errors in the browser console. Some enhancements in this area were made for 8.0.3 so that more of the errors that happen in the browser end up in the log files.


Hi Andrei,

My server_log.txt file it's empty and in the metadata folder I don't have any log file.

When I execute, it's works well, but I can't edit nothing but I can't see the palette and the form editor it's all in white. I don't know whats happend.
imarti
 
Posts: 7
Joined: Sat Mar 26, 2016 5:52 pm

Re: form palete

Postby Andrei Costescu » Tue Mar 29, 2016 4:05 pm

You should have a file named ".log" in your ".metadata" folder. Make sure you look at hidden files as well.
Did you try with a new solution/form?
Andrei Costescu
Servoy
Andrei Costescu
 
Posts: 943
Joined: Tue Jun 26, 2007 3:14 pm

Re: form palete

Postby imarti » Tue Mar 29, 2016 4:47 pm

Andrei Costescu wrote:You should have a file named ".log" in your ".metadata" folder. Make sure you look at hidden files as well.
Did you try with a new solution/form?



Hi Andrei,

thanks for you reply.

This is my log file. I think it's all fine. Maybe I don't know how I looking for.

!SESSION 2016-03-29 13:11:46.493 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_80
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=es_ES
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.jface 2 0 2016-03-29 13:12:00.718
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2016-03-29 13:12:00.718
!MESSAGE A conflict occurred for ALT+SHIFT+M:
Binding(ALT+SHIFT+M,
ParameterizedCommand(Command(com.servoy.eclipse.ui.StartMobileClient,Start Mobile Client,
Start Mobile Client,
Category(com.servoy.eclipse.ui,Servoy,Other Servoy Commands,true),
[email protected],
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(ALT+SHIFT+M,
ParameterizedCommand(Command(org.eclipse.jdt.ui.edit.text.java.extract.method,Extract Method,
Extract a set of statements or an expression into a new method and use the new method,
Category(org.eclipse.jdt.ui.category.refactoring,Refactor - Java,Java Refactoring Actions,true),
[email protected],
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:12:20.605
!MESSAGE Time taken to read in the solution import_placeholder: 15

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:12:25.021
!MESSAGE Time taken to read in the solution import_placeholder: 0

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:12:26.066
!MESSAGE Time taken to read in the solution servoy_sample_crm: 764

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:12:26.144
!MESSAGE Time taken to read in the solution svyCore: 78

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:12:27.486
!MESSAGE Browser url for editor: http://localhost:8080/rfb/angular/index ... devsession

!ENTRY org.eclipse.ui 4 4 2016-03-29 13:13:53.325
!MESSAGE Plug-in 'com.servoy.eclipse.exporter.mobile' contributed an invalid Menu Extension (Path: 'org.eclipse.ui.run' is invalid): com.servoy.eclipse.ui.StartMobileClient

!ENTRY org.eclipse.ui 4 4 2016-03-29 13:13:53.369
!MESSAGE Plug-in 'org.eclipse.dltk.ui' contributed an invalid Menu Extension (Path: 'org.eclipse.dltk.ui.refactoring.menu' is invalid): org.eclipse.dltk.ui.actions.Move

!ENTRY org.eclipse.ui 4 4 2016-03-29 13:13:53.370
!MESSAGE Plug-in 'org.eclipse.dltk.ui' contributed an invalid Menu Extension (Path: 'org.eclipse.dltk.ui.refactoring.menu' is invalid): org.eclipse.dltk.ui.actions.Rename

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:25:33.558
!MESSAGE Time taken to read in the solution import_placeholder: 1

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:25:38.278
!MESSAGE Time taken to read in the solution import_placeholder: 1

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:25:39.221
!MESSAGE Time taken to read in the solution servoy_sample_ng_basic: 611

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:25:39.279
!MESSAGE Time taken to read in the solution svyCore: 55

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:25:39.351
!MESSAGE Time taken to read in the solution mod_dialog: 70

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:25:40.347
!MESSAGE Browser url for editor: http://localhost:8080/rfb/angular/index ... devsession
!SESSION 2016-03-29 13:46:27.923 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_77
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:46:45.886
!MESSAGE Time taken to read in the solution servoy_sample_ng_basic: 3182

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:46:46.214
!MESSAGE Time taken to read in the solution svyCore: 156

!ENTRY com.servoy.eclipse.model 1 0 2016-03-29 13:46:46.354
imarti
 
Posts: 7
Joined: Sat Mar 26, 2016 5:52 pm

Re: form palete

Postby imarti » Tue Mar 29, 2016 5:22 pm

Andrei, I think I repare the bug, thnks for the help.
imarti
 
Posts: 7
Joined: Sat Mar 26, 2016 5:52 pm

Re: form palete

Postby Andrei Costescu » Tue Mar 29, 2016 5:25 pm

Try what I suggested in the first post:
  • new solution & form
  • with the form that does not work try what I described (with the browser & URL from .log)

Edit: :) yw.
Andrei Costescu
Servoy
Andrei Costescu
 
Posts: 943
Joined: Tue Jun 26, 2007 3:14 pm

Re: form palete

Postby imarti » Mon May 23, 2016 11:54 am

Andrei Costescu wrote:Try what I suggested in the first post:
  • new solution & form
  • with the form that does not work try what I described (with the browser & URL from .log)

Edit: :) yw.



Hi Andrei.

I change the preferences.
In windows-preferences-servoy-form editor.
I active the standar form editor.
imarti
 
Posts: 7
Joined: Sat Mar 26, 2016 5:52 pm


Return to Forms

Who is online

Users browsing this forum: No registered users and 1 guest