security.getUserUID() Returns 'null' for Valid User

Questions, tips and tricks and techniques for scripting in Servoy

security.getUserUID() Returns 'null' for Valid User

Postby kwpsd » Fri Jul 06, 2012 2:48 am

Version: 6.1.0 - build 1418

We recently moved our developement from version 6.0.6 to 6.1.0.

When we attempt to run our application, we get a failure on the login. We determined that the following line of code in the our 'authentication' module is the problem as it returns 'null' instead of the user UID value:

Code: Select all
var userUID = security.getUserUID( userName )

Using the SAS:Users page, we verified that the userName exists and has a UID. We deleted the userName and re-created it, but the problem persists.

The same code works in 6.0.6. Has anyone else come across this behavior in 6.1? Bug?
Kim W. Premuda
San Diego, CA USA
User avatar
kwpsd
 
Posts: 609
Joined: Sat Jul 28, 2007 6:59 pm
Location: San Diego, CA USA

Re: security.getUserUID() Returns 'null' for Valid User

Postby wvitpr » Wed Oct 10, 2012 11:42 am

Hi Kim,
Make sure you have the loginForm value set to DEFAULT in the solution Properties, that was it was for me.
Regards,
Phillip Routley

Worldview IT
Sydney, Australia
User avatar
wvitpr
 
Posts: 165
Joined: Tue Apr 24, 2007 1:38 am

Re: security.getUserUID() Returns 'null' for Valid User

Postby kwpsd » Thu Oct 11, 2012 11:35 pm

Thanks for responding, Phillip.

The property loginForm in our custom login form is set to DEFAULT.
Kim W. Premuda
San Diego, CA USA
User avatar
kwpsd
 
Posts: 609
Joined: Sat Jul 28, 2007 6:59 pm
Location: San Diego, CA USA

Re: security.getUserUID() Returns 'null' for Valid User

Postby rgansevles » Mon Oct 15, 2012 9:55 am

Kim,

Please try with the latest 6.1 release.

Rob
Rob Gansevles
Servoy
User avatar
rgansevles
 
Posts: 1871
Joined: Wed Nov 15, 2006 6:17 pm
Location: Amersfoort, NL


Return to Methods

Who is online

Users browsing this forum: No registered users and 3 guests