With latest windows update causing problem in IE 9,10,11

Forum to discuss the Web client version of Servoy.

With latest windows update causing problem in IE 9,10,11

Postby sovanm » Wed Sep 24, 2014 9:31 am

Hello,

We have a servoy solution hosted in a windows server 2008 RT datacenter. Everything was working fine till the server installed the latest updates about a fortnight ago.

Problems :

Opened the solution and everything working as fine on the Login page. After login when I try to execute any methods that involves a tab change, solutions hangs. The "loading.." appears for some fraction of seconds and goes away with no effects in UI. It seems to be freezing on the first page itself.

This happens only in Internet explorer 9/10/11 only not in Chrome, Firefox.

The same solutions is loading up correctly from the staging server where we still have the old windows update(Same server configuration). Is something in this latest update responsible for this behavior.

Update version on IE with the problematic Server: http://support.microsoft.com/kb/2977629 (This update is installed with the latest update of windows not from browser update, as I have checked in another machine with IE 9 with same update. Here problem happens only in IE).

Update version on IE with the staging Server : http://support.microsoft.com/kb/2925418 (Solution hosted on this server works fine in all browsers)

Anybody here experiencing the same issues ?

Please help me on this. I am getting no logs to trace any errors. Is there any place where I can look to get what exactly is happening here? Or something is happening in servoy with the updates?

Thanks in advance for the helps..
You do not have the required permissions to view the files attached to this post.
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Wed Sep 24, 2014 10:39 am

Update :

Video shows what exactly happens when I open the solution.
- I have added a main form and make it as first form to land upon successful login.
- Placed a tab panel and added 3 other forms to that.
- When I try to navigate between the tabs, by setting the tab index it is not working in IE while in chrome it worked as expected.

https://db.tt/5NDO8lmq

My system info :
Windows 7
Same "version update " of IE as shown above.
Same "Windows update" as shown in the list above(installed on 10th September).

Thanks
Sovan
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby Harjo » Wed Sep 24, 2014 4:30 pm

So you say, that an update on the server, breaks your Internet Explorer on the client, which don't have the update?

or is it just an update of Windows on the client, that breaks now Internet Explorer?
Harjo Kompagnie
Direct ICT / Servoy Hosting / ServoyCamp
Servoy Certified Developer
Servoy Valued Professional
SAN Developer
User avatar
Harjo
 
Posts: 4269
Joined: Fri Apr 25, 2003 11:42 pm
Location: DEN HAM OV, The Netherlands

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Wed Sep 24, 2014 4:59 pm

Windows Update on the server breaks the client on Internet explorer only. It do not depend upon what version or updates client has in their system where they are accessing the solution.

It breaks only in IE..but works fine in chrome and firefox.
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby Harjo » Wed Sep 24, 2014 5:03 pm

ok, I can't reproduce this, so I suggest you file a bug request....
Harjo Kompagnie
Direct ICT / Servoy Hosting / ServoyCamp
Servoy Certified Developer
Servoy Valued Professional
SAN Developer
User avatar
Harjo
 
Posts: 4269
Joined: Fri Apr 25, 2003 11:42 pm
Location: DEN HAM OV, The Netherlands

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Mon Sep 29, 2014 8:18 am

Thanks, I will file a report in support.


Along with this I am attaching a screen shot of an error I am getting on IE console, but I have no idea from where is coming from as there is no link to any file.

All internal servoy functionality is working fine, like record creation etc, but just it is not getting reflected on the screen. Once I refresh the page it is getting reflected.

Is IE is that much strict with parsing HTML/XML tags in comparison to other browsers ? Nothing has been updated in server with respect to servoy. It started to happen suddenly. Only difference we noticed is windows update.

Please suggest something..

Thanks,
Sovan
You do not have the required permissions to view the files attached to this post.
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby jcompagner » Mon Sep 29, 2014 11:55 am

for me it is very weird that nothing changed on the client side and then the client suddenly starts failing because of a server IE update? (IE on the server doesn't have anything todo with the java server process)

I guess there must be some other change (server or client) that is causing that error (that one could be the problem why you don't see anything)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7974
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Tue Sep 30, 2014 8:48 am

Thanks Johan,

I am looking into other aspects as well. But could not able to trace out, as you can see in the console, it is not point to any file just giving line and column number.

I completely agree with you that, something had happened which started breaking of the clients.

client suddenly starts failing because of a server IE update? (IE on the server doesn't have anything todo with the java server process)


It is the server's windows update, not IE update on the server. And servoy web client breaks irrespective of any version of IE on client side. So it has to do something with the server only. I am not sure what it might be, because the web client running from the same server on other browsers works just fine but not in IE.

Even the same servoy solution hosted on a different instance of windows(WITHOUT the latest windows updates) works fine in all browsers including IE.

I debugged through each line of code in IE to see where exactly it is breaking..

Cursor is moving into a function "stateChangeCallback" in wicket-ajax.js then towards the end of this function in goes through the "t.abort(); this.transport = null;" and then it executes a eval code and shows up the error on console.

Eval text content:
Code: Select all
setTimeout("var wcall=wicketAjaxGet('?x=iwOsv0WhVZAmraISVrgsuw&ignoremp=true&pvs=1',function() { }.bind(this),function() { onAjaxError();restartTimer();}.bind(this), function() {onAjaxCall(); if(Servoy.DD.isDragging) Servoy.DD.isRestartTimerNeeded=true; return !Servoy.DD.isDragging && !Servoy.redirectingOnSolutionClose;}.bind(this));", 5000);


I know I am asking too much here..Sorry.
But I really need to find out and fix it because many users are using IE.

I have attached the call stack if anybody from their experience can help me on this.

Thanks
Sovan
You do not have the required permissions to view the files attached to this post.
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby jcompagner » Tue Sep 30, 2014 12:40 pm

what is the difference that you now get in the traffic (wireshark for example) between a server that does work with IE and a server that doesn't work?
for exactly the same page/data
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7974
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: With latest windows update causing problem in IE 9,10,11

Postby jcompagner » Tue Sep 30, 2014 12:43 pm

also the code that you show doesn't have much to do with the actual form stuff
thats just the databroadcast poller every 5 seconds

For example if you disable databroadcast for a moment on that server on the admin page (set it to 0) what do you see then in the browser?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7974
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Fri Oct 03, 2014 1:26 pm

Hello,

After some investigation with the IE debugging tools and with Johan's suggestion I got something with is creating the problem in my case.

Explanation :

Reason for the issue:
First of all, the issue I am getting on IE's console "XML5608: Expected semicolon", usually appears when we try to load an XML file onto IE with "&". To load "&" into the browser it must be escaped as "&". Other browsers are bit forgiving to this and renders it without reporting any error.

Reason of why I am getting this issue:
In our solution, we are adding an external CSS file. It has been kept in a folder (say CSS) inside media directory and loading it into browser onSolutionOpen of the login module using web client utils plugin. So this makes CSS file available to browser.

On every request, servoy response with an XML file with reference to all the files required. XML response coming from the server with latest updates do NOT have "&" escaped where as the server without the latest windows updates has the "&" escaped as &.(Please see the screenshots of responses from the server with the latest windows updates and with old updates to figure out the difference).

Response from production : https://db.tt/kC7bkqZj (Here we have the problem)
Response from staging : https://db.tt/8FVQfHct (Here we do not as & is escaped)

[See line number 3 of both images just before "id=js/" to mark out the difference how the & is rendered.]
Both the server hosting the same solutions and the has been working fine with the CSS files added from media. I suppose, we have not done anything that would modify the response from server. Please correct me if I am wrong here.

Hope I made my explanation clear enough to get any suggestion.
To fix this, I have moved the CSS file to ROOT folder and pass the reference URL from there using the web client utils plugin.

Question : Is it okay to refer/add CSS or JS files from media folder or the second approach from ROOT folder is good?

Thanks,
Sovan
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby jcompagner » Mon Oct 06, 2014 4:47 pm

i still can't understand if that is the exact same servoy and tomcat version that is running on the server
where that none escaping difference comes from. because that is handles inside java code mostly even also in wicket code (the base lib that we use)
So how can that be suddenly different? Is there not something in the middle? Like a proxy or IIS that does suddenly some conversion?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7974
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Tue Oct 07, 2014 9:43 am

Yes Johan,
That is the same server and the same tomcat that has been running in the server. Nothing has been done on the server side. Only the windows updates installed (configured to be done automatically).

I am also not sure why suddenly this has happened.

To see that, we do not have the problem in our server only, I just imported a test solution (attached) in my colleague's server and we have the same problem(servoy 7.4.1 and he also has the latest window's update installed).

To reproduce :
Please upload the attached solution in some test server on windows machine which has the latest updates (esp after September 9th). Open the solution in Internet explorer and try to navigate the between the tabs. Hopefully you will get to see the problem. [Make sure to add the web client plugin in the test server as I am using it to add the external CSS file from media.]

Johan, do you want me to see into any specific area which might be causing this escaping difference that might help us ?

Thanks for your suggestions.
Sovan
You do not have the required permissions to view the files attached to this post.
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India

Re: With latest windows update causing problem in IE 9,10,11

Postby jcompagner » Tue Oct 07, 2014 9:48 am

please attach that to a case with some info of this thread (and point to this thread)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7974
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: With latest windows update causing problem in IE 9,10,11

Postby sovanm » Tue Oct 07, 2014 10:44 am

Thanks Johan,

Added a case SVY-7296.


Thanks
Sovan
sovanm
 
Posts: 99
Joined: Fri Oct 28, 2011 1:55 pm
Location: Bhubaneswar, India


Return to Servoy Web Client

Who is online

Users browsing this forum: No registered users and 4 guests