Page With HTML Reports Fails Display - Until Refresh

Forum to discuss the Web client version of Servoy.

Page With HTML Reports Fails Display - Until Refresh

Postby bcusick » Mon Nov 21, 2016 8:12 pm

Hey Guys,

I have a very, very strange problem - and I can't duplicate it in a simple solution - so I just wanted to hear if anyone has any suggestions.

I have a report module that takes a query (stored in a table), executes it, and renders the result in a HTML field.

I open this report form in a window (modal).

The reports run fine - and displays fine - EXCEPT THE FIRST TIME. The report runs (correctly) but nothing is displayed - unless you do a REFRESH - and it all displays. From that point on - every report runs and displays just fine.

STRANGE. Anyone have any thoughts??

Thanks!

Bob
Bob Cusick
bcusick
 
Posts: 1183
Joined: Wed Apr 23, 2003 11:27 pm
Location: Thousand Oaks, CA USA

Re: Page With HTML Reports Fails Display - Until Refresh

Postby Jan Aleman » Mon Nov 21, 2016 8:45 pm

What happens if you hook the actual rendering/display part up to the onshow of the form that is being popped up?
Jan Aleman
Servoy
Jan Aleman
Site Admin
 
Posts: 2071
Joined: Wed Apr 23, 2003 9:49 pm
Location: Planet Earth

Re: Page With HTML Reports Fails Display - Until Refresh

Postby bcusick » Tue Nov 22, 2016 12:15 am

The user has to pick the report from a dropdown and then click "Run Report".

So it's not really onShow on the form...
Bob Cusick
bcusick
 
Posts: 1183
Joined: Wed Apr 23, 2003 11:27 pm
Location: Thousand Oaks, CA USA

Re: Page With HTML Reports Fails Display - Until Refresh

Postby marco.rossi » Tue Nov 22, 2016 11:43 am

Usually I force the User Interface refresh using:

Code: Select all
application.updateUI()

Sometime I specify the milliseconds as arguments that is the max time that the update procedure can takes.
Code: Select all
application.updateUI(50)
Marco Rossi
Senior Analyst Developer
Freelance Consultant

IT Manager @Mantho
Webmaster @Sitoliquido
marco.rossi
 
Posts: 36
Joined: Sun Apr 12, 2015 9:33 pm

Re: Page With HTML Reports Fails Display - Until Refresh

Postby bcusick » Tue Nov 22, 2016 6:21 pm

Thanks, Marco - but unfortunately the updateUI() does not work in the Web Client... :D
Bob Cusick
bcusick
 
Posts: 1183
Joined: Wed Apr 23, 2003 11:27 pm
Location: Thousand Oaks, CA USA

Re: Page With HTML Reports Fails Display - Until Refresh

Postby jcompagner » Wed Nov 23, 2016 10:38 am

This report is not about printing right? You just display the results of a query in the webclient in a webclients html area?

If you inspect into in the browser then really nothing is there? maybe when using the wicket ajax debug console you could see what does go over the line when you click the run button
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7971
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Page With HTML Reports Fails Display - Until Refresh

Postby bcusick » Mon Nov 28, 2016 10:13 pm

Hey Johan,

I'll have to look into it further... but it must be there - because after 1 refresh - it will work every time. It's like it only happens the first time it's run.

Bob
Bob Cusick
bcusick
 
Posts: 1183
Joined: Wed Apr 23, 2003 11:27 pm
Location: Thousand Oaks, CA USA


Return to Servoy Web Client

Who is online

Users browsing this forum: No registered users and 3 guests