globals.js weird behaviour in debug

Questions and answers regarding the use of eclipse environment as seen in Servoy Developer

globals.js weird behaviour in debug

Postby drookwood » Thu Apr 30, 2015 5:35 pm

I'd love a solution to this: when I run in debug with breakpoints in recently added methods in my globals.js the breakpoint takes me to somewhere entirely different though the method executes perfectly OK! For example if the breakpoint is set at line 18856 I might actually be taken to line 580 when it hits the breakpoint. Seems like a refresh issue but refresh has not fixed this not has a clean, nor even an import to a new workspace.

I have seen this once or twice in the past and it generally seems to sort itself out - is there a way to force an update that gets it to behave?
David Rookwood

SAN Developer
drookwood
 
Posts: 256
Joined: Tue Nov 11, 2003 7:08 pm
Location: Somerset, UK

Re: globals.js weird behaviour in debug

Postby mboegem » Thu Apr 30, 2015 7:09 pm

In case you want the Servoy dev-team to have a look at this: file a case at support.servoy.com

Which version of Servoy is this?
_____________________
Marc Boegem
Solutiative / JBS Group, Partner
• Servoy Certified Developer
• Servoy Valued Professional
• Freelance SAN Developer

Image
User avatar
mboegem
 
Posts: 1384
Joined: Sun Oct 14, 2007 1:34 pm
Location: Hoofddorp, The Netherlands

Re: globals.js weird behaviour in debug

Postby drookwood » Thu Apr 30, 2015 8:34 pm

still on 5.2.17 so probably not going to see any fixes if this is a Servoy issue!
David Rookwood

SAN Developer
drookwood
 
Posts: 256
Joined: Tue Nov 11, 2003 7:08 pm
Location: Somerset, UK

Re: globals.js weird behaviour in debug

Postby jcompagner » Mon May 04, 2015 10:29 am

but after a restart of a client (or restart of the whole developer) the breakpoints do work on the right location?

or if you really reset the breakpoints once? (remove and add them 1 or 2 lines below/above back in)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7977
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet


Return to Eclipse Environment

Who is online

Users browsing this forum: No registered users and 2 guests