[ANNOUNCE] PostgreSQL 9.6.5, 9.5.9, 9.4.14, 9.3.19, 9.2.23

Questions and answers regarding general SQL and backend databases

[ANNOUNCE] PostgreSQL 9.6.5, 9.5.9, 9.4.14, 9.3.19, 9.2.23

Postby ROCLASI » Fri Sep 01, 2017 11:34 pm

PostgreSQL 9.6.5, 9.5.9, 9.4.14, 9.3.19 and 9.2.23 released!

The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 9.6.5, 9.5.9, 9.4.14, 9.3.19, and 9.2.23.

This release includes fixes that prevent a crash in pg_restore when using parallel mode. It also patches over a few other bugs reported since the last releases in August.

Additionally, in 9.4.14 only, there is a fix to an issue with walsenders preventing primary-server shutdown unless immediate shutdown mode is used.

Users should plan to update at the next convenient downtime.

Bug Fixes and Improvements

This update also fixes a number of bugs reported in the last few weeks. Some of these issues affect only version 9.6, but many affect all supported versions:

  • Show foreign tables in information_schema.table_privileges view. This fix applies to new databases, see the release notes for the procedure to apply the fix to an existing database.
  • Correctly identify columns that are of a range type or domain type over a composite type or domain type being searched for
  • Prevent crash when passing fixed-length pass-by-reference data types to parallel worker processes
  • Change ecpg’s parser to allow RETURNING clauses without attached C variables
  • Change ecpg’s parser to recognize backslash continuation of C preprocessor command lines
  • Improve selection of compiler flags for PL/Perl on Windows
EOL Warning for Version 9.2

PostgreSQL version 9.2 will be End-of-Life in September, 2017. The project expects to only release one more update for that version. We urge users to start planning an upgrade to a later version of PostgreSQL as soon as possible. See our Versioning Policy for more information.

Updating

All PostgreSQL update releases are cumulative. As with other minor releases, users are not required to dump and reload their database or use pg_upgrade in order to apply this update release; you may simply shut down PostgreSQL and update its binaries.

Links

Robert Ivens
ROCLASI Software Solutions / JBS Group, Partner
SAN Developer / Servoy Valued Professional / Servoy Certified Developer
Twitter: @roclasi / @servoyforge
--
ServoyForge - Building Open Source Software.
PostgreSQL - The world's most advanced open source database.
User avatar
ROCLASI
Servoy Expert
 
Posts: 5203
Joined: Thu Oct 02, 2003 9:49 am
Location: Netherlands/Belgium

Return to SQL Databases

Who is online

Users browsing this forum: No registered users and 2 guests