build_installer_properties.xml missing

Discuss everything related to development on the open source projects that relate to Servoy Clients.

build_installer_properties.xml missing

Postby ptalbot » Thu Jun 10, 2010 4:40 am

This evening I was implementing the "stream file to server" function in the file plugin as discussed on other threads.

But I was not able to build the plugins using the build.xml of the com.servoy.extension project because it references an "../eclipse_build/build_installer_properties.xml" file which is not part of the open source deal.

I ended up creating my own build but is there any chance to get the missing piece (or even an abridged/sample version) to ease testing plugins at least?

Thanks!
Patrick Talbot
Freelance - Open Source - Servoy Valued Professional
http://www.servoy-stuff.net
https://www.servoyforge.net
--------------------------------------------
Servoy 5.2.16 / 6.0.9 / 6.1.6 / 7.3.1
All OSes / Java 5 & 6 & 7
User avatar
ptalbot
 
Posts: 1612
Joined: Wed Mar 11, 2009 5:13 am
Location: Montreal, QC

Re: build_installer_properties.xml missing

Postby Jan Blok » Thu Jun 10, 2010 6:48 pm

Corrected in 52x code base
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Re: build_installer_properties.xml missing

Postby ptalbot » Thu Jun 10, 2010 7:09 pm

Thanks Jan, it works a lot better!

BTW, I was wondering if there was a way to grab the Eclipse target location to actually use it in the ant file to automatically deploy the plugins in the related /application_server/ folder?
Patrick Talbot
Freelance - Open Source - Servoy Valued Professional
http://www.servoy-stuff.net
https://www.servoyforge.net
--------------------------------------------
Servoy 5.2.16 / 6.0.9 / 6.1.6 / 7.3.1
All OSes / Java 5 & 6 & 7
User avatar
ptalbot
 
Posts: 1612
Joined: Wed Mar 11, 2009 5:13 am
Location: Montreal, QC

Re: build_installer_properties.xml missing

Postby Jan Blok » Thu Jun 10, 2010 7:54 pm

Not sure, but you might be able to use ${servoy_install} as prefix when ant build is started from within eclipse
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Re: build_installer_properties.xml missing

Postby ptalbot » Thu Jun 10, 2010 8:19 pm

Jan Blok wrote:Not sure, but you might be able to use ${servoy_install} as prefix when ant build is started from within eclipse

Not working :{
I guess I will add a property in the ant file.

Thanks!
Patrick Talbot
Freelance - Open Source - Servoy Valued Professional
http://www.servoy-stuff.net
https://www.servoyforge.net
--------------------------------------------
Servoy 5.2.16 / 6.0.9 / 6.1.6 / 7.3.1
All OSes / Java 5 & 6 & 7
User avatar
ptalbot
 
Posts: 1612
Joined: Wed Mar 11, 2009 5:13 am
Location: Montreal, QC


Return to Servoy Client related projects

Who is online

Users browsing this forum: No registered users and 3 guests

cron