Warnings about bootstrapcomponents in Servoy Developer

Forum to discuss the new web client version of Servoy.

Warnings about bootstrapcomponents in Servoy Developer

Postby tgs » Sat Oct 28, 2017 3:23 pm

Hi,

I get warnings in the Debug Console of Servoy 8.2.1 developer and have unfortunately no idea how I can fix this:

Code: Select all
WARN org.sablo.IndexPageEnhancer - same lib with lower version found: {"name":"moment","mimetype":"text/javascript","version":"2.11.1","url":"bootstrapcomponents/calendar/bootstrap-datetimepicker/js/moment-with-locales.min.js"} using lib: {"name":"moment","mimetype":"text/javascript","version":"3.0.0","url":"fullcalendarcomponent/fullcalendar/lib/moment.min.js"}
WARN org.sablo.IndexPageEnhancer - same lib with lower version found: {"name":"moment","mimetype":"text/javascript","version":"2.11.1","url":"servoydefault/calendar/bootstrap-datetimepicker/js/moment-with-locales.min.js"} using lib: {"name":"moment","mimetype":"text/javascript","version":"3.0.0","url":"fullcalendarcomponent/fullcalendar/lib/moment.min.js"}
WARN org.sablo.IndexPageEnhancer - Unknown mimetype {"name":"viewer.html","mimetype":"text/html","version":"1","url":"pdfviewer/pdfViewer/web/viewer.html"}


Java version is 1.8.0.151
macOS 10.12.6
Thomas Schnaus
SAN Developer
yomotec GmbH
User avatar
tgs
 
Posts: 845
Joined: Wed Oct 04, 2006 12:05 pm
Location: Germany

Re: Warnings about bootstrapcomponents in Servoy Developer

Postby steve1376656734 » Sun Oct 29, 2017 5:23 pm

This error is saying that the Servoy Default calendar and the Bootstrap calendar components are using a different version of the javascript moment-with locales.js library. The only way to remove these warnings is to make sure that all components use the same version of the library. This should be done by Servoy but you can do a temporary fix by checking out the components from Github, making the changes yourself and then using your copy of them.

If you don't want to do that then you need to wait for Servoy to update the components (or turn off warnings in your log file).

Steve
Steve
SAN Developer
There are 10 types of people in the world - those that understand binary and those that don't
steve1376656734
 
Posts: 199
Joined: Fri Aug 16, 2013 2:38 pm
Location: Lanzarote

Re: Warnings about bootstrapcomponents in Servoy Developer

Postby lvostinar » Mon Oct 30, 2017 1:48 pm

This conflict is between Bootstrap Components Calendar and FullCalendar momentjs library. We will update momentjs in Servoy 8.3 . Do you use full calendar and bootstrap components in same solution ? If not you could remove one dependency in order not to get this warning.
Laurian Vostinar
Servoy
lvostinar
 
Posts: 1049
Joined: Tue Feb 19, 2008 10:53 am

Re: Warnings about bootstrapcomponents in Servoy Developer

Postby tgs » Tue Oct 31, 2017 10:56 am

Ok, thank you!
I will remove the full calendar component and wait for Servoy 8.3.
For the near future I need both in one solution.
Thomas Schnaus
SAN Developer
yomotec GmbH
User avatar
tgs
 
Posts: 845
Joined: Wed Oct 04, 2006 12:05 pm
Location: Germany


Return to Servoy NGClient

Who is online

Users browsing this forum: No registered users and 4 guests