Fonts issue after deployment

Forum to discuss the new web client version of Servoy.

Fonts issue after deployment

Postby jay.rao » Tue Oct 31, 2017 1:17 pm

Hello,

We have used some font awesome and other fonts into our custom created components folder (customcomponents/lib/css/fontawesome.css).So into that file we have the css mentioned below.

@font-face{font-family:'FontAwesome';src:url('../fonts/fontawesome-webfont.eot?v=4.7.0')
but now after deployment if I try to run the application its throws the error related to fonts in the console because it tries to search for the fonts in my deployed application for e.g after deployment we have the application in webapps and inside the application we have folders like customcomponents,wro etc. so due to ..fonts/fontawesome which is in the css file which is grouped togther into wro folder it tries to look for fonts folder in root directory of the applications. Hence we have to manually add the fonts folder in the location where we have custom components,wro etc
jay.rao
 
Posts: 52
Joined: Mon Apr 10, 2017 1:32 pm

Re: Fonts issue after deployment

Postby emera » Tue Oct 31, 2017 1:38 pm

Hi,

Fontawesome css must be ungrouped in the component spec file.
See the specification docs https://wiki.servoy.com/pages/viewpage. ... Id=1869552 for more details about the group property and the fontawesome component from https://github.com/Servoy/servoy-extra- ... esome.spec as an example.

Regards,
Edit
emera
 
Posts: 21
Joined: Tue Jun 17, 2014 8:33 am


Return to Servoy NGClient

Who is online

Users browsing this forum: No registered users and 3 guests