Very weird smart client connection problem

Discuss all problems you have with Servoy here. It might help to mention the Servoy version and Operating System version you are using

Very weird smart client connection problem

Postby bevil » Fri Feb 13, 2015 12:44 am

In a first, I am seeing a problem with one of our customers, who is having a very slow, and very painful rollout of a new Servoy solution / migration from Filemaker (they use Filemaker as a big stick to beat me with)

One of the users (out of three) has been working fine for a month and a half, and on Monday, had a Servoy smart client crash. She force quit it, tried to restart, and was left with the 'Servoy Next Generation Platform' splash logo, for ages, until an error saying connection to server is invalid. I remotely logged in and could see Servoy doing the same thing over and over. I reinstalled latest Java 7, deleted java apps, cleared java cache, reinstalled, absolutely nothing I did helped.

I then checked the server log and found a bunch of these:

SocketAcceptor failure for socket: 39a31339[SSL_NULL_WITH_NULL_NULL: Socket[addr=/,port=49412,localport=1099]]

On a whim, I tried changing her IP address, and it worked immediately and perfectly again.

Today, this problem has come back again, and the user has had to go and work on another computer.

No other users have been affected by this, and I haven't seen the problem anywhere else. It is very frustrating because the migration from Filemaker to Servoy has been very bumpy (hugely dirty data out of Filemaker, which I have been cleaning, and which the customer doesn't recognise should be a problem since it worked 'okay in Filemaker')

Has anyone seen this behaviour before, or know where I need to look for the problem? I suspected something was funny about their network, but we have switched parts of it out, and it has not helped.

I don't know whether this is a server problem or a client problem (although I suspect client as it doesn't affect either of the other two users). I don't know what I should be looking for...

Java prefs on client machine are set to Direct for network connection...
Posts: 144
Joined: Thu Oct 18, 2012 7:31 pm

Re: Very weird smart client connection problem

Postby jcompagner » Tue Feb 17, 2015 12:05 pm

what is exactly the exception that is logged with that SocketAccept failure message?

problem is really in the network, that is a special piece of code that only sets up the initial connection, and somehow it bombs already out of that...

What you could do is move over to Http&Socket type of tunneling. Then you can try of that Socket (the default) or else tunnel him over http.

Maybe there is something in between that just closes or doesn't really allow plain sockets?
Johan Compagner
User avatar
Posts: 8084
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Very weird smart client connection problem

Postby rafig » Wed Feb 18, 2015 4:57 pm

I don't know if it is of any help, but when you are trying to clear away all old remnants of an install, don't forget the hidden/invisible '.servoy' folder that is usually in the user's home directory and stores various settings and prefs.
I've found that sometimes deleting that as well as caches etc., sometimes helps weird problems...

Servoy Certified Developer
Posts: 497
Joined: Mon Dec 22, 2003 12:58 pm
Location: Watford, UK

Re: Very weird smart client connection problem

Postby swingman » Thu Feb 19, 2015 6:14 pm

I would try Rafi's suggestion, it has helped me out a few times. See ... java_cache
Christian Batchelor
Certified Servoy Developer
Batchelor Associates Ltd, London, UK - The world's most advanced open source database.
User avatar
Posts: 1207
Joined: Wed Oct 01, 2003 10:20 am
Location: London

Return to Discuss possible Issues and Bugs

Who is online

Users browsing this forum: No registered users and 2 guests