Display issues when using UI Converter in portal

Discuss all problems you have with Servoy here. It might help to mention the Servoy version and Operating System version you are using

Display issues when using UI Converter in portal

Postby mwiedemann » Fri Jun 16, 2017 7:58 pm

Hello everyone,

I'm pretty sure we have a bug here, but thought I'd post here first just to make sure.

I have a form with a portal that contains a couple of date fields. I'm using SQLITE as my datasource and since sqlite doesn't have a native DATE datatype, I'm storing dates as TEXT in the following format. yyyyMMdd My UI Converter is working just fine outside the portal on another date field in the same form. When I activate the UI Converter on a date field in the portal, most of the form elements just disappear from the form when it's displayed. See attached image.... The portal field in question is "Date Rcvd." and the same thing happens when putting the UI Converter on the "Date Ordered" field which is currently displaying the date in it's native TEXT format.
Picture.png
Picture.png (18.48 KiB) Viewed 507 times


As soon as the UI Converter is removed from the portal date field, all form the elements return to normal. I'm not using any on Render methods or anything else that would tweak the look of the form.

Thanks!
Marty
mwiedemann
 
Posts: 7
Joined: Wed Aug 05, 2015 7:05 pm

Re: Display issues when using UI Converter in portal

Postby jcompagner » Tue Jun 20, 2017 10:55 am

why are you not using a column converter for this?
so that the dates are really dates throughout the code (also in scripting) instead of converting it purely for the ui?


But do you have any errors in the log files when you do this? If you can make a simple sample and attach this to a jira issue we can have a look
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 7974
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Display issues when using UI Converter in portal

Postby mwiedemann » Thu Jun 22, 2017 12:24 am

Thanks for having a look.

Column conversion didn't even occur to me, so thanks for pointing that out. I'll give that a try and will report back on my findings.

Thanks again!
Marty
mwiedemann
 
Posts: 7
Joined: Wed Aug 05, 2015 7:05 pm

Re: Display issues when using UI Converter in portal

Postby mwiedemann » Thu Jun 22, 2017 12:39 am

Column conversion did the trick.

The issue must have something to with the way the screen is redrawn each time one of the 'date' fields in the portal is calculated upon refresh.

Thanks!!!
mwiedemann
 
Posts: 7
Joined: Wed Aug 05, 2015 7:05 pm


Return to Discuss possible Issues and Bugs

Who is online

Users browsing this forum: No registered users and 4 guests