DBTreeView bean having unwanted dots in Browser

Using Servoy to administrate the content of your website? Discuss all webrelated Servoy topics on this forum!

DBTreeView bean having unwanted dots in Browser

Postby huber » Tue Jul 23, 2013 3:51 pm

Using the DBTreeView bean, I get in the browser unwanted dots displayed (between each menu), see attachment. This does not happen in the Smart Client. Anyone seen this or I am the lonely one having this phenomena ;-)
Attachments
menu.png
menu.png (16.88 KiB) Viewed 2090 times
Robert Huber
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
huber
 
Posts: 312
Joined: Mon May 14, 2012 11:31 pm

Re: DBTreeView bean having unwanted dots in Browser

Postby Gabi Boros » Fri Jul 26, 2013 3:40 pm

can you check it with Chrome's Developer Tools who adds those dots ?
Gabi Boros
Servoy
Gabi Boros
 
Posts: 334
Joined: Tue Jun 26, 2007 4:03 pm
Location: Timisoara, Romania

Re: DBTreeView bean having unwanted dots in Browser

Postby huber » Fri Jul 26, 2013 3:58 pm

I debugged it in Safari if that's also accepted ;-)
All these [email protected] are the dots which are displayed in the browser. See attachment please.

Gabi Boros wrote:can you check it with Chrome's Developer Tools who adds those dots ?
Attachments
dots in DBTreeView.png
dots in DBTreeView.png (187.63 KiB) Viewed 2038 times
Robert Huber
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
huber
 
Posts: 312
Joined: Mon May 14, 2012 11:31 pm

Re: DBTreeView bean having unwanted dots in Browser

Postby Gabi Boros » Fri Jul 26, 2013 4:30 pm

so, the icons on the tree are set via media dataprovider;
how does those images look in safari if you just export them from the db into a file, & open it ?
Gabi Boros
Servoy
Gabi Boros
 
Posts: 334
Joined: Tue Jun 26, 2007 4:03 pm
Location: Timisoara, Romania

Re: DBTreeView bean having unwanted dots in Browser

Postby huber » Sat Jul 27, 2013 5:21 pm

Gabi

If I let generate an SQL statement (SybaseCentral) from one row content, I get the following result, which is ecactly what I write into the the row with my own SQL statement (not a surprise :-)

The code looks like:
Code: Select all
INSERT INTO "hades"."menus" ("creation_date","creation_user","detail_form","font","icon","id","menu_id","modification_date","modification_user","name","selection_form","sort_order","tooltip") VALUES('2011-12-27 00:00:00.000','7r',NULL,'LucidaGrande,1,11',,1,NULL,NULL,NULL,'hades.dom.lbl.enrolments.ucl','EnrCandidatesL',1,'')


The icon column ist the "nothing" column, i. e. ,, after the font column, i. e. 'LucidaGrande,1,11'

In the browser, it says the 0x, see attachment. Is the dot may be representation of 0x in the browser? And causes no problem in the Smart Client? Could that be? An then the question would be what to enter for an "empty" icon for both, the Web and the Smart Client

Gabi Boros wrote:so, the icons on the tree are set via media dataprovider;
how does those images look in safari if you just export them from the db into a file, & open it ?
Attachments
icon.png
icon.png (31.08 KiB) Viewed 2015 times
Robert Huber
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
huber
 
Posts: 312
Joined: Mon May 14, 2012 11:31 pm

Re: DBTreeView bean having unwanted dots in Browser

Postby Gabi Boros » Mon Jul 29, 2013 9:31 am

it seems to be an issue in the bean, can you create a case for that ? (and link this thread to it)
Gabi Boros
Servoy
Gabi Boros
 
Posts: 334
Joined: Tue Jun 26, 2007 4:03 pm
Location: Timisoara, Romania


Return to Web Development

Who is online

Users browsing this forum: No registered users and 2 guests