Server shows different layouts

Using Servoy to administrate the content of your website? Discuss all webrelated Servoy topics on this forum!

Server shows different layouts

Postby Peter de Groot » Tue Feb 25, 2014 11:44 am

Hi all,

We are developing a web application using Servoy 7.3.1, if we run the application from developer using Internet Explorer 11 we see this
startedFromDevScrollbar.png
startedFromDevScrollbar.png (22.35 KiB) Viewed 1611 times


as you can see there is a scroll bar visible, but the same list looks like this when started from the application server using the same browser
startedFromAppServerNoScrollbar.png
startedFromAppServerNoScrollbar.png (19.53 KiB) Viewed 1611 times

no scroll bar.

Does anyone has an idea whats causing this behavior?

When the application is started using Firefox everything looks as designed...

The application server uses JAVA and OS version as stated below
JVM Information
java.vm.name=Java HotSpot(TM) Client VM
java.version=1.6.0_18
java.vm.info=mixed mode
java.vm.vendor=Sun Microsystems Inc.

Operating System Information
os.name=Windows 2003
os.version=5.2
os.arch=x86

The development computer uses
JVM Information
java.vm.name=Java HotSpot(TM) Client VM
java.version=1.7.0_21
java.vm.info=mixed mode, sharing
java.vm.vendor=Oracle Corporation

Operating System Information
os.name=Windows 7
os.version=6.1
os.arch=x86

TIA,
Peter
Servoy 7.3.x || 7.4.x

NEM ENERGY BV
Peter de Groot
 
Posts: 207
Joined: Thu Jan 10, 2008 8:38 pm
Location: Has been compromised :-/

Re: Server shows different layouts

Postby Harjo » Tue Feb 25, 2014 1:36 pm

on the server you use pagination? and in your developer not??

and btw, the list in developer and server is not the same (different data)
Even you font-type is not the same!
Harjo Kompagnie
Direct ICT / Servoy Hosting / ServoyCamp
Servoy Certified Developer
Servoy Valued Professional
SAN Developer
User avatar
Harjo
 
Posts: 4269
Joined: Fri Apr 25, 2003 11:42 pm
Location: DEN HAM OV, The Netherlands

Re: Server shows different layouts

Postby kwpsd » Tue Feb 25, 2014 8:35 pm

In addition to Harjo's suggestion, you can also accomplish the same thing programmatically (in onSolutionOpen()):

Code: Select all
    // Activate the table view scroll bars in web client.
   
    application.putClientProperty( APP_UI_PROPERTY.TABLEVIEW_WC_DEFAULT_SCROLLABLE, true )


I hope this helps!
Kim W. Premuda
San Diego, CA USA
User avatar
kwpsd
 
Posts: 566
Joined: Sat Jul 28, 2007 6:59 pm
Location: San Diego, CA USA

Re: Server shows different layouts

Postby Peter de Groot » Wed Feb 26, 2014 4:26 am

kwpsd wrote:In addition to Harjo's suggestion, you can also accomplish the same thing programmatically (in onSolutionOpen()):

Code: Select all
    // Activate the table view scroll bars in web client.
   
    application.putClientProperty( APP_UI_PROPERTY.TABLEVIEW_WC_DEFAULT_SCROLLABLE, true )


I hope this helps!



Hi,

That's what I already do in the onSolutionOpen, the strange thing is when I start the web application from the application server using Firefox everything is fine, scroll bars are shown, but IE 11 (in our case) shows page numbers.

When I start the web application from developer IE 11 and firefox both show the scroll bars..

Regards,

Peter
Servoy 7.3.x || 7.4.x

NEM ENERGY BV
Peter de Groot
 
Posts: 207
Joined: Thu Jan 10, 2008 8:38 pm
Location: Has been compromised :-/

Re: Server shows different layouts

Postby kwpsd » Wed Feb 26, 2014 8:40 pm

We use that code in a web application we are developing using Servoy Developer version 6.1.6 - build 1439, and test it on a Servoy Server running 7.3.1 - build 2022, and it shows the scroll bars when displayed in Internet Explorer 11 running in Windows 8.1, Firefox 27.0.1 running in Windows 7, and an Android-based tablet browser (Chrome?).

Have you searched your code to see if you turn off the scroll bars?

Code: Select all
application.putClientProperty( APP_UI_PROPERTY.TABLEVIEW_WC_DEFAULT_SCROLLABLE, false )


Are you able to reproduce the no-scrollbars scenario in a simple test solution? If so, it may be a bug and should be reported.

Other than the above, I am out of ideas. I would interested to know what the solution is. Good luck.
Kim W. Premuda
San Diego, CA USA
User avatar
kwpsd
 
Posts: 566
Joined: Sat Jul 28, 2007 6:59 pm
Location: San Diego, CA USA

Re: Server shows different layouts

Postby Yeroc » Thu Feb 27, 2014 10:44 pm

Peter,

Check to make sure IE11 isn't in compatibility mode (under Compatibility View settings) when connecting to your app server. Depending on the compatibility mode setting it could be emulating IE7. With IE7 Servoy automatically falls back to using pagination.

Corey
Yeroc
 
Posts: 109
Joined: Tue Aug 12, 2008 1:12 am
Location: Calgary, AB, Canada

Re: Server shows different layouts

Postby Peter de Groot » Mon Mar 03, 2014 9:21 am

Yeroc wrote:Peter,

Check to make sure IE11 isn't in compatibility mode (under Compatibility View settings) when connecting to your app server. Depending on the compatibility mode setting it could be emulating IE7. With IE7 Servoy automatically falls back to using pagination.

Corey


Disabling the compatibility solved the problem, thank you very much.

Regards,

Peter
Servoy 7.3.x || 7.4.x

NEM ENERGY BV
Peter de Groot
 
Posts: 207
Joined: Thu Jan 10, 2008 8:38 pm
Location: Has been compromised :-/


Return to Web Development

Who is online

Users browsing this forum: Bing [Bot] and 2 guests