sometimes strange behavior after foundsetfiltering

Using Servoy to administrate the content of your website? Discuss all webrelated Servoy topics on this forum!

sometimes strange behavior after foundsetfiltering

Postby ina.wels » Tue Apr 15, 2014 1:34 pm

Hey,
I have a locked Table View Form (Webclient) showing a Foundset with calculations. Users are allowed to generate filters. Filtering the foundset sometimes causes an error.
I really don't know exactly when this error does occur. Then the error page is shown. On the admin page i get the attached errormessages.

This seems to happen after filtering and removing the filter (ie standig on the first record, filtering for just the last record (indes 138), removing the filter). The foundset is shown, then the records are not shown for a few milliseconds. Filtering the foundset again would not work anymore.
Attachments
fehler.JPG
fehler.JPG (217.91 KiB) Viewed 858 times
ina.wels
 
Posts: 16
Joined: Fri Jan 27, 2012 10:51 am

Re: sometimes strange behavior after foundsetfiltering

Postby ina.wels » Wed Apr 16, 2014 9:49 am

I just figured out, when this behaviour does happen.
I set a filter on the foundset the first time (ie there is just one more record in the filtered foundset with the pk = 55)
I remove the filter
The selected record is furthermore the record with the pk 55, but it is no more in the visible area.
The foundset seems no reload and the record with pk 55 is now in the visible area (I don't use Servoy Paging)
Setting another filter or the same again and the program will crash.

So, after removing the foundset filter I am now selecting the first record. Then the programm is going on. But I don't want to select the first record, just because it's in the visible area. I would like to have the record selected as it was.
ina.wels
 
Posts: 16
Joined: Fri Jan 27, 2012 10:51 am


Return to Web Development

Who is online

Users browsing this forum: No registered users and 4 guests