# Cannot start smart client

**URL:** <https://forum.servoy.com/t/cannot-start-smart-client/9121>\
**Category:** Classic Servoy\
**Created:** [May 24, 2008, 7:02pm UTC](https://forum.servoy.com/t/cannot-start-smart-client/9121 "2008-05-24T19:02:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hans\_Nieuwenhuis](https://avatars.discourse-cdn.com/v4/letter/h/87869e/32.png) [@Hans\_Nieuwenhuis](https://forum.servoy.com/u/Hans_Nieuwenhuis)\
**Post date:** [May 24, 2008, 7:02pm UTC](https://forum.servoy.com/t/cannot-start-smart-client/9121/1 "2008-05-24T19:02:12Z")

</div>

When i start smart client on server it works, but on other pc’s the client starts, but there is no list with solutions to start.  
I see the folowing error in java console :

```auto
SEVERE: Error getting the service servoy.IRepository from host ibis_app:1099
java.net.MalformedURLException: invalid authority: //ibis_app:1099/servoy.IRepository
	at java.rmi.Naming.intParseURL(Unknown Source)
	at java.rmi.Naming.parseURL(Unknown Source)
	at java.rmi.Naming.lookup(Unknown Source)
	at com.servoy.j2db.J2DBClient.getServerService(Unknown Source)
	at com.servoy.j2db.J2DBClient.goto(Unknown Source)
	at com.servoy.j2db.ClientState.dataBaseInit(Unknown Source)
	at com.servoy.j2db.J2DBClient.dataBaseInit(Unknown Source)
	at com.servoy.j2db.J2DBClient.a(Unknown Source)
	at com.servoy.j2db.J2DBClient.main(Unknown Source)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.sun.javaws.Launcher.executeApplication(Unknown Source)
	at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
	at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
	at com.sun.javaws.Launcher.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
May 24, 2008 8:55:16 PM com.servoy.j2db.util.Debug error
SEVERE: Error getting the service servoy.IDataServer from host ibis_app:1099
java.net.MalformedURLException: invalid authority: //ibis_app:1099/servoy.IDataServer
	at java.rmi.Naming.intParseURL(Unknown Source)
	at java.rmi.Naming.parseURL(Unknown Source)
	at java.rmi.Naming.lookup(Unknown Source)
	at com.servoy.j2db.J2DBClient.getServerService(Unknown Source)
	at com.servoy.j2db.J2DBClient.e(Unknown Source)
	at com.servoy.j2db.ClientState.new(Unknown Source)
	at com.servoy.j2db.J2DBClient.new(Unknown Source)
	at com.servoy.j2db.J2DBClient.a(Unknown Source)
	at com.servoy.j2db.J2DBClient.main(Unknown Source)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.sun.javaws.Launcher.executeApplication(Unknown Source)
	at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
	at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
	at com.sun.javaws.Launcher.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
May 24, 2008 8:55:21 PM com.servoy.j2db.util.Debug error
SEVERE: Fatal Exception
May 24, 2008 8:55:21 PM com.servoy.j2db.util.Debug error
SEVERE: Throwable
java.lang.NullPointerException
	at com.servoy.j2db.ClientState.a(Unknown Source)
	at com.servoy.j2db.J2DBClient.a(Unknown Source)
	at com.servoy.j2db.ClientState.new(Unknown Source)
	at com.servoy.j2db.J2DBClient.new(Unknown Source)
	at com.servoy.j2db.J2DBClient.a(Unknown Source)
	at com.servoy.j2db.J2DBClient.main(Unknown Source)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.sun.javaws.Launcher.executeApplication(Unknown Source)
	at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
	at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
	at com.sun.javaws.Launcher.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

```

any ideas ??

---

<div class="post-metadata">

**Author:** ![IT2Be](https://avatars.discourse-cdn.com/v4/letter/i/dc4da7/32.png) [@IT2Be](https://forum.servoy.com/u/IT2Be)\
**Post date:** [May 24, 2008, 7:11pm UTC](https://forum.servoy.com/t/cannot-start-smart-client/9121/2 "2008-05-24T19:11:30Z")

</div>

Hans,

A quick scan showed me this bug description for J6:

> FULL PRODUCT VERSION :  
> 1.6.0\_02-b05
> 
> ADDITIONAL OS VERSION INFORMATION :  
> reproduced with different windows systems
> 
> A DESCRIPTION OF THE PROBLEM :  
> Connecting Problems if char ‘\_’ in hostname

---

<div class="post-metadata">

**Author:** ![IT2Be](https://avatars.discourse-cdn.com/v4/letter/i/dc4da7/32.png) [@IT2Be](https://forum.servoy.com/u/IT2Be)\
**Post date:** [May 24, 2008, 7:13pm UTC](https://forum.servoy.com/t/cannot-start-smart-client/9121/3 "2008-05-24T19:13:38Z")

</div>

I noticed you are at J10 already so maybe that bug should have been solved for you already ![;)]( "Wink")

---

<div class="post-metadata">

**Author:** ![Hans\_Nieuwenhuis](https://avatars.discourse-cdn.com/v4/letter/h/87869e/32.png) [@Hans\_Nieuwenhuis](https://forum.servoy.com/u/Hans_Nieuwenhuis)\
**Post date:** [May 24, 2008, 8:48pm UTC](https://forum.servoy.com/t/cannot-start-smart-client/9121/4 "2008-05-24T20:48:43Z")

</div>

Marcel,

This was the problem.

Java version 10.0-b19 (Windows XP) = 1.6

I removed 1.6 and installed 1.5 and it works .

Thanks,

Hans
