# java.util.zip.ZipException when importing solution

**URL:** <https://forum.servoy.com/t/java-util-zip-zipexception-when-importing-solution/10484>\
**Category:** Classic Servoy\
**Created:** [March 30, 2009, 3:53pm UTC](https://forum.servoy.com/t/java-util-zip-zipexception-when-importing-solution/10484 "2009-03-30T15:53:35Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Demondave](https://avatars.discourse-cdn.com/v4/letter/d/8491ac/32.png) [@Demondave](https://forum.servoy.com/u/Demondave)\
**Post date:** [March 30, 2009, 3:53pm UTC](https://forum.servoy.com/t/java-util-zip-zipexception-when-importing-solution/10484/1 "2009-03-30T15:53:35Z")

</div>

I have just installed Servoy 4.1 and am having trouble importing some of the solutions from version 2.2. Of the 12 solutions developed in 2.2 two are getting ‘java.util.zip.ZipException: error in opening zip file’ errors when importing them via the web admin screen.

Here’s the log file:

com.servoy.j2db.persistence.RepositoryException: java.util.zip.ZipException: error in opening zip file  
at com.servoy.j2db.persistence.XMLImporter.importFromJarFile(XMLImporter.java:11)  
at com.servoy.j2db.server.servlets.ConfigServlet.Zk(ConfigServlet.java:2214)  
at com.servoy.j2db.server.servlets.ConfigServlet.service(ConfigServlet.java:984)  
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)  
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)  
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)  
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)  
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)  
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)  
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)  
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:563)  
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)  
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)  
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)  
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:581)  
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)  
at java.lang.Thread.run(Unknown Source)  
Caused by: java.util.zip.ZipException: error in opening zip file  
at java.util.zip.ZipFile.open(Native Method)  
at java.util.zip.ZipFile.(Unknown Source)  
at java.util.jar.JarFile.(Unknown Source)  
at java.util.jar.JarFile.(Unknown Source)  
at com.servoy.j2db.persistence.XMLImporter.importFromJarFile(XMLImporter.java:27)  
… 16 more

I’m very new to Servoy so any help would be greatly appreciated.

---

<div class="post-metadata">

**Author:** ![Jan\_Blok](https://avatars.discourse-cdn.com/v4/letter/j/41988e/32.png) [@Jan\_Blok](https://forum.servoy.com/u/Jan_Blok)\
**Post date:** [April 3, 2009, 7:43am UTC](https://forum.servoy.com/t/java-util-zip-zipexception-when-importing-solution/10484/2 "2009-04-03T07:43:53Z")

</div>

check of the solution files are not zipped again (zip in a zip), try to open with normal zip archive viewer
