# OS X 10.4.8 startup error

**URL:** https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156
**Category:** Classic Servoy
**Created:** [February 27, 2007, 6:16pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156 "2007-02-27T18:16:32Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![stephengray](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@stephengray](https://forum.servoy.com/u/stephengray)
#### Post date: [February 27, 2007, 6:16pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/1 "2007-02-27T18:16:32Z")

</div>

After running Servoy for month, I updated out server to OS X Server 10.4.8 (dual G5) today, including Apple’s latest security and Java updates.

When I went to restart Servoy server after the update, I got the following error spew.

Any ideas?

=============

ci06:/Applications/Servoy stephengray$ ./servoy\_server.sh &  
[1] 469  
ci06:/Applications/Servoy stephengray$ dyld: Library not loaded: libdbserv9\_r.dylib  
Referenced from: /Applications/Servoy/sybase\_db/dbsrv9  
Reason: image not found  
./servoy\_server.sh: line 2: 470 Trace/BPT trap /Applications/Servoy/sybase\_db/dbsrv9  
./servoy\_server.sh: line 2: @/Applications/Seervoy/sybase\_db/sybase.config: No such file or directory  
Loading servoy.properties from /Applications/Servoy/servoy.properties  
Loading - Done  
Exception in thread “main” org.apache.commons.dbcp.DbcpException: java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused  
at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:85)  
at com.servoy.j2db.persistence.datasource.n.createConnection(Unknown Source)  
at com.servoy.j2db.persistence.datasource.r.makeObject(Unknown Source)  
at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:816)  
at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:110)  
at com.servoy.j2db.persistence.datasource.i.getConnection(Unknown Source)  
at com.servoy.j2db.persistence.Server.getConnection(Unknown Source)  
at com.servoy.j2db.persistence.Server.checkIfTableExistsInDatabase(Unknown Source)  
at com.servoy.j2db.persistence.Repository.int(Unknown Source)  
at com.servoy.j2db.persistence.Repository.(Unknown Source)  
at com.servoy.j2db.persistence.Repository.(Unknown Source)  
at com.servoy.j2db.persistence.Server.getRepository(Unknown Source)  
at com.servoy.j2db.server.ApplicationServer.main(Unknown Source)  
Caused by: java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused  
at com.sybase.jdbc2.jdbc.ErrorMessage.raiseError(ErrorMessage.java:487)  
at com.sybase.jdbc2.jdbc.ErrorMessage.raiseErrorCheckDead(ErrorMessage.java:723)  
at com.sybase.jdbc2.tds.Tds.handleIOE(Tds.java:3071)  
at com.sybase.jdbc2.tds.Tds.login(Tds.java:394)  
at com.sybase.jdbc2.jdbc.SybConnection.tryLogin(SybConnection.java:218)  
at com.sybase.jdbc2.jdbc.SybConnection.regularConnect(SybConnection.java:195)  
at com.sybase.jdbc2.jdbc.SybConnection.(SybConnection.java:174)  
at com.sybase.jdbc2.jdbc.SybConnection.(SybConnection.java:126)  
at com.sybase.jdbc2.jdbc.SybDriver.connect(SybDriver.java:179)  
at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:83)  
… 12 more

[1]+ Exit 1 ./servoy\_server.sh  
ci06:/Applications/Servoy stephengray$

---

<div class="post-metadata">

### Author: ![bcusick](https://avatars.discourse-cdn.com/v4/letter/b/ed8c4c/32.png) [@bcusick](https://forum.servoy.com/u/bcusick)
#### Post date: [February 27, 2007, 6:21pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/2 "2007-02-27T18:21:02Z")

</div>

It can’t find the Sybase database:

Library not loaded: libdbserv9\_r.dylib  
Referenced from: /Applications/Servoy/sybase\_db/dbsrv9  
Reason: image not found  
./servoy\_server.sh: line 2: 470 Trace/BPT trap /Applications/Servoy/sybase\_db/dbsrv9  
./servoy\_server.sh: line 2: @/Applications/Seervoy/sybase\_db/sybase.config: No such file or directory

---

<div class="post-metadata">

### Author: ![stephengray](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@stephengray](https://forum.servoy.com/u/stephengray)
#### Post date: [February 27, 2007, 6:35pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/3 "2007-02-27T18:35:56Z")

</div>

> bcusick:  
> It can’t find the Sybase database:
> 
> Library not loaded: libdbserv9\_r.dylib  
> Referenced from: /Applications/Servoy/sybase\_db/dbsrv9  
> Reason: image not found  
> ./servoy\_server.sh: line 2: 470 Trace/BPT trap /Applications/Servoy/sybase\_db/dbsrv9  
> ./servoy\_server.sh: line 2: @/Applications/Seervoy/sybase\_db/sybase.config: No such file or directory

Yeah, that’s the trick. They don’t seem to be missing.

I compared my remote directory structure to my local and can’t find any missing files.

---

<div class="post-metadata">

### Author: ![stephengray](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@stephengray](https://forum.servoy.com/u/stephengray)
#### Post date: [February 27, 2007, 7:04pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/4 "2007-02-27T19:04:19Z")

</div>

I just rechecked my config files against Servoy’s documentation.

I did have my system setup correctly to run Sybase as a service, so why didn’t it start? Are there any new issues with OS 10.4.8?

Also – How do I start it manually from the command line?

I think this would solve the problem.

---

<div class="post-metadata">

### Author: ![stephengray](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@stephengray](https://forum.servoy.com/u/stephengray)
#### Post date: [February 27, 2007, 7:36pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/5 "2007-02-27T19:36:59Z")

</div>

I went back and started “from scratch”.

Started Servoy Developer to get dbsrv9 going again.

This still doesn’t answer the question of why it failed to start as a service.

---

<div class="post-metadata">

### Author: ![faheemhameed](https://avatars.discourse-cdn.com/v4/letter/f/7ea924/32.png) [@faheemhameed](https://forum.servoy.com/u/faheemhameed)
#### Post date: [June 26, 2007, 12:01pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/6 "2007-06-26T12:01:35Z")

</div>

I am getting the same problem.

I got the following issue when starting up the server:

> 0 [main] INFO com.servoy.j2db.util.Debug - Loading servoy.properties from /Applications/Servoy/servoy.properties  
> 835 [main] INFO com.servoy.j2db.util.Debug - Loading - Done  
> Exception in thread “main” org.apache.commons.dbcp.DbcpException: java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused  
> at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:85)  
> at com.servoy.j2db.persistence.datasource.n.createConnection(Unknown Source)  
> at com.servoy.j2db.persistence.datasource.r.makeObject(Unknown Source)  
> at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:816)  
> at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:110)  
> at com.servoy.j2db.persistence.datasource.i.getConnection(Unknown Source)  
> at com.servoy.j2db.persistence.Server.getConnection(Unknown Source)  
> at com.servoy.j2db.persistence.Server.checkIfTableExistsInDatabase(Unknown Source)  
> at com.servoy.j2db.persistence.Repository.for(Unknown Source)  
> at com.servoy.j2db.persistence.Repository.(Unknown Source)  
> at com.servoy.j2db.persistence.Repository.(Unknown Source)  
> at com.servoy.j2db.persistence.Server.getRepository(Unknown Source)  
> at com.servoy.j2db.server.ApplicationServer.main(Unknown Source)  
> Caused by: java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused  
> at com.sybase.jdbc3.jdbc.ErrorMessage.raiseError(Unknown Source)  
> at com.sybase.jdbc3.jdbc.ErrorMessage.raiseErrorCheckDead(Unknown Source)  
> at com.sybase.jdbc3.tds.Tds.a(Unknown Source)  
> at com.sybase.jdbc3.tds.Tds.a(Unknown Source)  
> at com.sybase.jdbc3.tds.Tds.login(Unknown Source)  
> at com.sybase.jdbc3.jdbc.SybConnection.a(Unknown Source)  
> at com.sybase.jdbc3.jdbc.SybConnection.a(Unknown Source)  
> at com.sybase.jdbc3.jdbc.SybConnection.(Unknown Source)  
> at com.sybase.jdbc3.jdbc.SybConnection.(Unknown Source)  
> at com.sybase.jdbc3.jdbc.SybDriver.connect(Unknown Source)  
> at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:83)  
> … 12 more

I got in to the terminal and ran the following:

/Applications/Servoy/sybase\_db/dbsrv9|@/Applications/Servoy/sybase\_db/sybase.config

I got the following issue

> /Applications/Servoy/sybase\_db/dbsrv9|@/Applications/Servoy/sybase\_db/sybase.config  
> dyld: Library not loaded: libdbserv9\_r.dylib  
> Referenced from: /Applications/Servoy/sybase\_db/dbsrv9  
> Reason: image not found  
> -bash: @/Applications/Servoy/sybase\_db/sybase.config: No such file or directory

Any idea please?

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [June 26, 2007, 12:24pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/7 "2007-06-26T12:24:00Z")

</div>

Hi All

I can’t start the iAnywhere daemon anymore as a Mac OS X service since upgrading to 3.5rc2. I did not change anything in the startup code. Are there any changes between 3.1.6 and 3.5rcx?

Best regards, Robert

PS: I can manually start the db daemon.

> faheemhameed:  
> I am getting the same problem.
> 
> I got the following issue when starting up the server:
> 
> > 0 [main] INFO com.servoy.j2db.util.Debug - Loading servoy.properties from /Applications/Servoy/servoy.properties  
> > 835 [main] INFO com.servoy.j2db.util.Debug - Loading - Done  
> > Exception in thread “main” org.apache.commons.dbcp.DbcpException: java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused  
> > at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:85)  
> > at com.servoy.j2db.persistence.datasource.n.createConnection(Unknown Source)  
> > at com.servoy.j2db.persistence.datasource.r.makeObject(Unknown Source)  
> > at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:816)  
> > at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:110)  
> > at com.servoy.j2db.persistence.datasource.i.getConnection(Unknown Source)  
> > at com.servoy.j2db.persistence.Server.getConnection(Unknown Source)  
> > at com.servoy.j2db.persistence.Server.checkIfTableExistsInDatabase(Unknown Source)  
> > at com.servoy.j2db.persistence.Repository.for(Unknown Source)  
> > at com.servoy.j2db.persistence.Repository.(Unknown Source)  
> > at com.servoy.j2db.persistence.Repository.(Unknown Source)  
> > at com.servoy.j2db.persistence.Server.getRepository(Unknown Source)  
> > at com.servoy.j2db.server.ApplicationServer.main(Unknown Source)  
> > Caused by: java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused  
> > at com.sybase.jdbc3.jdbc.ErrorMessage.raiseError(Unknown Source)  
> > at com.sybase.jdbc3.jdbc.ErrorMessage.raiseErrorCheckDead(Unknown Source)  
> > at com.sybase.jdbc3.tds.Tds.a(Unknown Source)  
> > at com.sybase.jdbc3.tds.Tds.a(Unknown Source)  
> > at com.sybase.jdbc3.tds.Tds.login(Unknown Source)  
> > at com.sybase.jdbc3.jdbc.SybConnection.a(Unknown Source)  
> > at com.sybase.jdbc3.jdbc.SybConnection.a(Unknown Source)  
> > at com.sybase.jdbc3.jdbc.SybConnection.(Unknown Source)  
> > at com.sybase.jdbc3.jdbc.SybConnection.(Unknown Source)  
> > at com.sybase.jdbc3.jdbc.SybDriver.connect(Unknown Source)  
> > at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:83)  
> > … 12 more
> 
> I got in to the terminal and ran the following:
> 
> /Applications/Servoy/sybase\_db/dbsrv9|@/Applications/Servoy/sybase\_db/sybase.config
> 
> I got the following issue
> 
> > /Applications/Servoy/sybase\_db/dbsrv9|@/Applications/Servoy/sybase\_db/sybase.config  
> > dyld: Library not loaded: libdbserv9\_r.dylib  
> > Referenced from: /Applications/Servoy/sybase\_db/dbsrv9  
> > Reason: image not found  
> > -bash: @/Applications/Servoy/sybase\_db/sybase.config: No such file or directory
> 
> Any idea please?

---

<div class="post-metadata">

### Author: ![faheemhameed](https://avatars.discourse-cdn.com/v4/letter/f/7ea924/32.png) [@faheemhameed](https://forum.servoy.com/u/faheemhameed)
#### Post date: [June 26, 2007, 12:29pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/8 "2007-06-26T12:29:28Z")

</div>

Hi Robert,

what is the command to manually start the db daemon?

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [June 28, 2007, 2:38pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/9 "2007-06-28T14:38:58Z")

</div>

Hi Faheem

I normally just start the developer which itself then starts the db daemon (on Macs at least). You can stop it form the Activity Monitor (use only Quit (UNIX signal 15) not Force Quit) You can also do it from the terminal (on Macs or UNIX, of course):

export PATH=$PATH:/Applications/Servoy/sybase\_db  
cd /Applications/Servoy/  
sybase\_db/dbsrv9 @sybase\_db/sybase.config

Hope that helps, Robert

> faheemhameed:  
> Hi Robert,
> 
> what is the command to manually start the db daemon?

---

<div class="post-metadata">

### Author: ![faheemhameed](https://avatars.discourse-cdn.com/v4/letter/f/7ea924/32.png) [@faheemhameed](https://forum.servoy.com/u/faheemhameed)
#### Post date: [June 29, 2007, 3:00am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/10 "2007-06-29T03:00:29Z")

</div>

Thanks Robert,

I have managed to solve my issue.

Thanks!

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [July 3, 2007, 8:47am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/11 "2007-07-03T08:47:39Z")

</div>

Hi Faheem

I still have the above error, i. e. autostarting the dbsrv9 process doesn’t work any more (since 3.5rc2).

How did you solve the problem?

Thanks for postinng the solution to your problem which seems excactly the same as I have.

Best regards, Robert

> faheemhameed:  
> Thanks Robert,
> 
> I have managed to solve my issue.
> 
> Thanks!

---

<div class="post-metadata">

### Author: ![faheemhameed](https://avatars.discourse-cdn.com/v4/letter/f/7ea924/32.png) [@faheemhameed](https://forum.servoy.com/u/faheemhameed)
#### Post date: [July 3, 2007, 9:09am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/12 "2007-07-03T09:09:10Z")

</div>

my servoy servoy\_server.sh file looks like this. Is this helpful?

```auto
#!/bin/sh  
cd /Applications/Servoy 

while true
do
            java -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Xmx256m -Xms64m -XX:MaxPermSize=128m -classpath .:lib/ohj-jewt.jar:lib/MRJAdapter.jar:lib/compat141.jar:lib/commons-codec.jar:lib/commons-httpclient.jar:lib/activation.jar:lib/antlr.jar:lib/commons-collections.jar:lib/commons-dbcp.jar:lib/commons-fileupload-1.0.jar:lib/commons-logging.jar:lib/commons-pool.jar:lib/concurrent.jar:lib/dom4j.jar:lib/help.jar:lib/hibernate3.jar:lib/j2db.jar:lib/j2dbdev.jar:lib/jdbc2_0-stdext.jar:lib/jmx.jar:lib/jndi.jar:lib/js.jar:lib/jta.jar:lib/BrowserLauncher2.jar:lib/jug.jar:lib/log4j.jar:lib/mail.jar:lib/naming-factory.jar:lib/naming-resources.jar:lib/ohj-jewt.jar:lib/oracle_ice.jar:lib/server-bootstrap.jar:lib/servlet-api.jar:lib/wicket-extentions.jar:lib/wicket.jar:lib/wicket-calendar.jar:lib/xerces.jar:lib/concurrent.jar:lib/slf4j-api.jar:lib/slf4j-log4j.jar:lib/joda-time.jar com.servoy.j2db.server.ApplicationServer "$@" 1>> server.log 2>> server.log
            EXITCODE=$?
            if ["$EXITCODE" != 99]; then exit $EXITCODE; fi
done

```

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [July 3, 2007, 10:42am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/13 "2007-07-03T10:42:12Z")

</div>

Hi Faheem

Now Servoy Server gets started when I manually start the developer and therefor the dbsrv9 process gets started.  
How do you get the dbsrv9 process automatically started?

My config:

Servoy Developer  
Version 3.5 rc3-build 508  
Java version 1.5.0\_07-87 (Mac OS X)

Thanks and best regards, Robert

> faheemhameed:  
> my servoy servoy\_server.sh file looks like this. Is this helpful?
> 
> ```auto
> #!/bin/sh  
> 
> ```

cd /Applications/Servoy

while true  
do  
java -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Xmx256m -Xms64m -XX:MaxPermSize=128m -classpath .:lib/ohj-jewt.jar:lib/MRJAdapter.jar:lib/compat141.jar:lib/commons-codec.jar:lib/commons-httpclient.jar:lib/activation.jar:lib/antlr.jar:lib/commons-collections.jar:lib/commons-dbcp.jar:lib/commons-fileupload-1.0.jar:lib/commons-logging.jar:lib/commons-pool.jar:lib/concurrent.jar:lib/dom4j.jar:lib/help.jar:lib/hibernate3.jar:lib/j2db.jar:lib/j2dbdev.jar:lib/jdbc2\_0-stdext.jar:lib/jmx.jar:lib/jndi.jar:lib/js.jar:lib/jta.jar:lib/BrowserLauncher2.jar:lib/jug.jar:lib/log4j.jar:lib/mail.jar:lib/naming-factory.jar:lib/naming-resources.jar:lib/ohj-jewt.jar:lib/oracle\_ice.jar:lib/server-bootstrap.jar:lib/servlet-api.jar:lib/wicket-extentions.jar:lib/wicket.jar:lib/wicket-calendar.jar:lib/xerces.jar:lib/concurrent.jar:lib/slf4j-api.jar:lib/slf4j-log4j.jar:lib/joda-time.jar com.servoy.j2db.server.ApplicationServer “$@” 1\>\> server.log 2\>\> server.log  
EXITCODE=$?  
if [“$EXITCODE” != 99]; then exit $EXITCODE; fi  
done

> ```auto
> 
> ```

---

<div class="post-metadata">

### Author: ![ROCLASI](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/roclasi/32/4371_2.png) [@ROCLASI](https://forum.servoy.com/u/ROCLASI)
#### Post date: [July 3, 2007, 10:47am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/14 "2007-07-03T10:47:07Z")

</div>

I believe [this thread](http://forum.servoy.com/viewtopic.php?t=5914) covers this.

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [July 3, 2007, 11:12am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/15 "2007-07-03T11:12:15Z")

</div>

Hi Robert

I couldn’t find a useful hint in this tread for my situation. Everything used to work until 3.1.6, but then I installed version 3.5rc2 and now it doesn’t start automatically my dbsrv9 any more.

I did the setup as described in the Server Admin manual, installing a file in the LaunchAgent folder under the user.

I assume it works in your environment?

Best regards, Robert

> ROCLASI:  
> I believe [this thread](http://forum.servoy.com/viewtopic.php?t=5914) covers this.

---

<div class="post-metadata">

### Author: ![ROCLASI](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/roclasi/32/4371_2.png) [@ROCLASI](https://forum.servoy.com/u/ROCLASI)
#### Post date: [July 3, 2007, 11:51am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/16 "2007-07-03T11:51:01Z")

</div>

Maybe it does get started but errors out.  
Do you see any errors in the sybase log or in the system log ?

> Robert Huber:  
> I assume it works in your environment?

Well I don’t use Sybase in my server environment. I think you can guess what I use. ![;)]( "Wink")

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [July 3, 2007, 11:58am UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/17 "2007-07-03T11:58:15Z")

</div>

Hi Robert

Yeah, I know what db you use ![:-)]( "Smile") I may have the chance to use that db as well in the future ![:-)]( "Smile")

In the server.log file it says the following

0 [main] INFO com.servoy.j2db.util.Debug - Loading servoy.properties from /Applications/Servoy/servoy.properties  
509 [main] INFO com.servoy.j2db.util.Debug - Loading - Done  
2007-07-03 11:17:20,850 WARN [main] com.servoy.j2db.persistence.Server - Table name teaching\_allotment\_class\_course\_positions from server hades is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:20,851 WARN [main] com.servoy.j2db.persistence.Server - Table name intermediate\_rating\_requirements from server hades is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:20,852 WARN [main] com.servoy.j2db.persistence.Server - Table name intermediate\_report\_requirements from server hades is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:20,852 WARN [main] com.servoy.j2db.persistence.Server - Table name persons\_particular\_capabilities from server hades is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:22,333 WARN [main] com.servoy.j2db.persistence.Server - Column name ‘admin\_allowuser\_enterservername’ from table ‘main’ is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:24,044 WARN [main] com.servoy.j2db.persistence.Server - Column name ‘profile\_positions\_exist\_next\_period’ from table ‘courses’ is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:24,046 WARN [main] com.servoy.j2db.persistence.Server - Column name ‘teaching\_allotments\_exist\_next\_period’ from table ‘courses’ is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:24,567 WARN [main] com.servoy.j2db.persistence.Server - Column name ‘class\_teacher\_exists\_next\_period’ from table ‘classes’ is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:24,573 WARN [main] com.servoy.j2db.persistence.Server - Column name ‘person\_id\_vicarious\_class\_teacher’ from table ‘classes’ is too long (\>30 chars) – this is not supported by all databases  
2007-07-03 11:17:24,573 WARN [main] com.servoy.j2db.persistence.Server - Column name ‘vicarious\_class\_teacher\_exists\_next\_period’ from table ‘classes’ is too long (\>30 chars) – this is not supported by all databases  
Exception in thread “main” java.lang.NoClassDefFoundError: org/hibernate/mapping/KeyValue  
at com.servoy.j2db.persistence.Server.a(Unknown Source)  
at com.servoy.j2db.persistence.Server.g(Unknown Source)  
at com.servoy.j2db.persistence.Column.(Unknown Source)  
at com.servoy.j2db.persistence.Server.int(Unknown Source)  
at com.servoy.j2db.persistence.Server.for(Unknown Source)  
at com.servoy.j2db.persistence.Server.getTable(Unknown Source)  
at com.servoy.j2db.persistence.Repository.a(Unknown Source)  
at com.servoy.j2db.persistence.Repository.a(Unknown Source)  
at com.servoy.j2db.persistence.Repository.a(Unknown Source)  
at com.servoy.j2db.persistence.Repository.a(Unknown Source)  
at com.servoy.j2db.persistence.s.a(Unknown Source)  
at com.servoy.j2db.persistence.s.if(Unknown Source)  
at com.servoy.j2db.persistence.Repository.getActiveRootObject(Unknown Source)  
at com.servoy.j2db.persistence.Repository.getActiveSolution(Unknown Source)  
at com.servoy.j2db.server.ApplicationServer.a(Unknown Source)  
at com.servoy.j2db.server.ApplicationServer.main(Unknown Source)

The critcal line is (the above messages are ok and because of our db, too long table and column names for some db’s):

Exception in thread “main” java.lang.NoClassDefFoundError: org/hibernate/mapping/KeyValue

as I don’t know why this is here and what it means?

Best regards, Robert

> ROCLASI:  
> Maybe it does get started but errors out.  
> Do you see any errors in the sybase log or in the system log ?
> 
> > Robert Huber:  
> > I assume it works in your environment?
> 
> Well I don’t use Sybase in my server environment. I think you can guess what I use. ![;)]( "Wink")

---

<div class="post-metadata">

### Author: ![ROCLASI](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/roclasi/32/4371_2.png) [@ROCLASI](https://forum.servoy.com/u/ROCLASI)
#### Post date: [July 3, 2007, 12:17pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/18 "2007-07-03T12:17:15Z")

</div>

Hi Robert,

I googled for it and it seems the interface KeyValue ‘represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table’.

But I doubt this has anything to do with Sybase not starting.  
Can you check for a sybase log file in the sybase folder. If Sybase has any errors it will show up in there.

---

<div class="post-metadata">

### Author: ![faheemhameed](https://avatars.discourse-cdn.com/v4/letter/f/7ea924/32.png) [@faheemhameed](https://forum.servoy.com/u/faheemhameed)
#### Post date: [July 3, 2007, 12:56pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/19 "2007-07-03T12:56:13Z")

</div>

Hi Robert,

I am using mysql for the repository now. So I was not trying with sybase.

```auto
Exception in thread "main" java.lang.NoClassDefFoundError: org/hibernate/mapping/KeyValue 

```

In my understanding the above error occurs when there is no jar file which contains the particular class is not in the class path. Or even the jar file is there and it is a bit old (so the class file may be missing from the jar file)

Can you check that you have the called /lib/hibernate3.jar?

I think that file should be in the class path.

---

<div class="post-metadata">

### Author: ![Robert\_Huber](https://avatars.discourse-cdn.com/v4/letter/r/da6949/32.png) [@Robert\_Huber](https://forum.servoy.com/u/Robert_Huber)
#### Post date: [July 3, 2007, 2:26pm UTC](https://forum.servoy.com/t/os-x-10-4-8-startup-error/7156/20 "2007-07-03T14:26:18Z")

</div>

Hi All

I used to auto starting Servoy Server as described in Servoy31ServerAdminGuide.pdf in chapter 9.2.2 Auto starting Servoy Server as a service on Mac OS X.  
That used to work with 3.1.6 - but no more with 3.5rcx

Now I tried the method described by Marcel in Servoy Magazine putting a Servoy folder in Startup items with the Servoy and StartupParameters.plist files in it.

Now Servoy Server and dbsrv9 process start (automatically) when I login in as a user.

My questions: Doesn’t the method described in chapter 9.2.2 not work anymore and what to do if I’d like to start Servoy Server and Repository Server (dbsrv9) without login in as a user?

Thanks to all for help, Robi

PS: As said above it works now (again and differently) but I don’t understand it ![:-o]( "Surprised")

> ROCLASI:  
> Hi Robert,
> 
> I googled for it and it seems the interface KeyValue ‘represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table’.
> 
> But I doubt this has anything to do with Sybase not starting.  
> Can you check for a sybase log file in the sybase folder. If Sybase has any errors it will show up in there.
