# Relation Error in Server not Developer

**URL:** <https://forum.servoy.com/t/relation-error-in-server-not-developer/11012>\
**Category:** Classic Servoy\
**Created:** [August 5, 2009, 9:10am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012 "2009-08-05T09:10:41Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![4xjbh](https://avatars.discourse-cdn.com/v4/letter/4/ea666f/32.png) [@4xjbh](https://forum.servoy.com/u/4xjbh)\
**Post date:** [August 5, 2009, 9:10am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/1 "2009-08-05T09:10:41Z")

</div>

When accessing server version of app my activity\_distribution related tab is throwing a “Error in relation” dialog.

The servoy log is as follows:

2009-08-05 18:59:02,421 ERROR [RMI TCP Connection(30)-192.168.0.6] com.servoy.j2db.util.Debug -  
java.lang.IllegalStateException: Could not resolve column aec\_crm:activity\_distributon#activitydistributon1348.1032=?  
at com.servoy.j2db.persistence.ServerManager.updateColumnInfo(ServerManager.java:97)  
at com.servoy.j2db.dataprocessing.SQLEngine.performQuery(SQLEngine.java:896)  
at com.servoy.j2db.dataprocessing.SQLEngine.performQuery(SQLEngine.java:630)  
at com.servoy.j2db.dataprocessing.SQLEngine.performQuery(SQLEngine.java:1018)  
at sun.reflect.GeneratedMethodAccessor320.invoke(Unknown Source)  
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)  
at java.lang.reflect.Method.invoke(Unknown Source)  
at sun.rmi.server.UnicastServerRef.dispatch(Unknown Source)  
at sun.rmi.transport.Transport$1.run(Unknown Source)  
at java.security.AccessController.doPrivileged(Native Method)  
at sun.rmi.transport.Transport.serviceCall(Unknown Source)  
at sun.rmi.transport.tcp.TCPTransport.handleMessages(Unknown Source)  
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(Unknown Source)  
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
at java.lang.Thread.run(Unknown Source)

I have checked columns, relationships etc on both local & sever instance of mysql and all looks OK. I have pointed developer to run from server instance of mysql with no problems.

Any idea what this is would be appreciated. Thx

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [August 5, 2009, 9:34am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/2 "2009-08-05T09:34:09Z")

</div>

This issue seems to be on table: activity\_distributon, also the column name is null, so I guess there is a relation based on a column that no longer exists ?( this situation also generates an error from the builder)

---

<div class="post-metadata">

**Author:** ![4xjbh](https://avatars.discourse-cdn.com/v4/letter/4/ea666f/32.png) [@4xjbh](https://forum.servoy.com/u/4xjbh)\
**Post date:** [August 5, 2009, 12:32pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/3 "2009-08-05T12:32:38Z")

</div>

You would think so, this is the first thing I checked. But all columns have been verified and all dataproviders have been checked. Refer PM link

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [August 6, 2009, 10:12am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/4 "2009-08-06T10:12:48Z")

</div>

Can you check the database with some external tool to make sure the column(s) exist ? Maybe delete and recreate the relation ? Also you can add a case about this if sample/steps to reproduce are available.

---

<div class="post-metadata">

**Author:** ![4xjbh](https://avatars.discourse-cdn.com/v4/letter/4/ea666f/32.png) [@4xjbh](https://forum.servoy.com/u/4xjbh)\
**Post date:** [August 7, 2009, 10:17am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/5 "2009-08-07T10:17:22Z")

</div>

[http://bowtell-harris.com/servoyapptest.wmv](http://bowtell-harris.com/servoyapptest.wmv) is a 4:14 min demo of my problem

I have check “All” of my columns, deleted the relationships, created a new tables and relinked it and it has got me stumped. I have looked at it for so long I am probably blind to the problem which may seem so obvious to everyone else.

I use a 3rd part tool to “sync” database structure from the developer instance of mysql to the testing server instance of mysql all error free. I also sync’d the data also from one to the other.

When I run theapp from developer ther are no errors alerted, run from the server there is.

_I have even pointed my developer to the testing servers mysql instance and **no** errors occur._ I only get an error when the app is being accessed from the testing erver when viewing an activity/task and the related distribution table in a tab.

Head in my hands and hairless…

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [August 7, 2009, 11:01am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/6 "2009-08-07T11:01:42Z")

</div>

What happens if you export from developer and clean import to the test server ? Still have this issue ? If so, you can open a case and attach the sample. What value you have for: startRepositoryAsTeamProvider. Are you sure the server version is the same as developer version (structure and data; tring a clean import will make this clear) ?

---

<div class="post-metadata">

**Author:** ![4xjbh](https://avatars.discourse-cdn.com/v4/letter/4/ea666f/32.png) [@4xjbh](https://forum.servoy.com/u/4xjbh)\
**Post date:** [August 7, 2009, 9:00pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/7 "2009-08-07T21:00:29Z")

</div>

Clean install on test server has the same problem. startRepositoryAsTeamProvider = true

The dev and server are both 4.13 build 672

---

<div class="post-metadata">

**Author:** ![keenkenny](https://avatars.discourse-cdn.com/v4/letter/k/df788c/32.png) [@keenkenny](https://forum.servoy.com/u/keenkenny)\
**Post date:** [August 7, 2009, 9:46pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/8 "2009-08-07T21:46:07Z")

</div>

For the Servoy guys, I logged a case in the support system a couple of weeks ago that looks very similar to this one. Case #229819

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [August 10, 2009, 7:34am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/9 "2009-08-10T07:34:42Z")

</div>

> 4xjbh:  
> Clean install on test server has the same problem. startRepositoryAsTeamProvider = true
> 
> The dev and server are both 4.13 build 672

Can you open a case then in our support system ? (with sample attached)

---

<div class="post-metadata">

**Author:** ![4xjbh](https://avatars.discourse-cdn.com/v4/letter/4/ea666f/32.png) [@4xjbh](https://forum.servoy.com/u/4xjbh)\
**Post date:** [August 11, 2009, 11:06am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/10 "2009-08-11T11:06:03Z")

</div>

Case has been opened: SVA:233058

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [August 14, 2009, 7:42am UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/11 "2009-08-14T07:42:37Z")

</div>

I tried the sample in the case, however I cannot reproduce the issue. I import in a 4.1.3 install (using sybase) and everything works ok. Are you sure it doesn’t work if you import the sample in a “clean” repository ?

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [August 14, 2009, 12:18pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/12 "2009-08-14T12:18:25Z")

</div>

Ok, I think I figured out this one. Managed to reproduce in Servoy 4.1.3 with Mysql 5.1 . However, is already fixed in latest code, so it should work in next release (4.1.4 - planned for next week).

---

<div class="post-metadata">

**Author:** ![marcelb](https://avatars.discourse-cdn.com/v4/letter/m/e95f7d/32.png) [@marcelb](https://forum.servoy.com/u/marcelb)\
**Post date:** [February 10, 2010, 12:56pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/13 "2010-02-10T12:56:54Z")

</div>

We have exactly this same issue in Servoy 5.01, was is solved in 4.1.4? What can we do to get this running?

Thanks.

---

<div class="post-metadata">

**Author:** ![lvostinar](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/lvostinar/32/5248_2.png) [@lvostinar](https://forum.servoy.com/u/lvostinar)\
**Post date:** [February 10, 2010, 1:01pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/14 "2010-02-10T13:01:54Z")

</div>

> marcelb:  
> We have exactly this same issue in Servoy 5.01, was is solved in 4.1.4? What can we do to get this running?
> 
> Thanks.

Do you have a sample ? How to reproduce it ?

---

<div class="post-metadata">

**Author:** ![marcelb](https://avatars.discourse-cdn.com/v4/letter/m/e95f7d/32.png) [@marcelb](https://forum.servoy.com/u/marcelb)\
**Post date:** [February 10, 2010, 2:37pm UTC](https://forum.servoy.com/t/relation-error-in-server-not-developer/11012/15 "2010-02-10T14:37:57Z")

</div>

Importing the solution again and clear the client Java-cache solved this issue for me now.

Thanks.
