# Servoy 2.2rc2

**URL:** <https://forum.servoy.com/t/servoy-2-2rc2/3682>\
**Category:** Classic Servoy\
**Created:** [February 15, 2005, 7:47pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682 "2005-02-15T19:47:16Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jan\_Blok](https://avatars.discourse-cdn.com/v4/letter/j/41988e/32.png) [@Jan\_Blok](https://forum.servoy.com/u/Jan_Blok)\
**Post date:** [February 15, 2005, 7:47pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/1 "2005-02-15T19:47:16Z")

</div>

We announce the immediate availability of Servoy 2.2rc2

NOTE: this is PRE-RELEASE SOFTWARE, use with caution and make BACKUPS before you start.

This version is available through auto update (if you have beta update notify enabled, meaning having the line ‘wantsBetaCodeNotifies=true’ in your servoy.properties file)

[Previous beta build info](http://forum.servoy.com/viewtopic.php?t=3815)

Enhances:  
[enh]-made tooltip dismiss delay larger  
[enh]-various tooltip/sample code improvements  
[enh]-support for postgress bit/boolean/inet column types

Fixes:  
[fix]-some small modules related issues  
[fix]-dataset “get by index” somethimes failed to retrieve correct data  
[fix]-datafield display problem when going from find to edit  
[fix]-combobox doesn’t show the realvalue anymore if it can’t find the displayvalue for the given real (real value isn’t there anymore)  
[fix]-combobox readonly fix, horizontal alligment wasn’t followed correctly  
[fix]-better support for on the fly custom valuelist changes (when elements showing that valuelist)  
[fix]-various small headless client related issues

---

<div class="post-metadata">

**Author:** ![sabeenah](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@sabeenah](https://forum.servoy.com/u/sabeenah)\
**Post date:** [February 24, 2005, 11:32pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/2 "2005-02-24T23:32:46Z")

</div>

I just updated Servoy to R2 2.2rc2-build 320, repository version 25.

When I try to open the client, I get the following error:

An error occured while launching/running the application. Category: Launch File Error Could not parse launch file. Error at line 0.

It is a JNLParse Exception and the wrapped exception is java.io.EOFException: encoding.error.not.xml

When I try to open a specific solution (the full URL), I get another error, saying: Could not verify signing in resource: ([http://localhost:8080/lib/j2db.jar](http://localhost:8080/lib/j2db.jar), 1109284742593). This is a JNLPException(category: download error: java.lang.securiyException:SHA1 digest error for com/servoy/j2db/persistence/Relation.class)

Could you give me a suggestion on how to get the client started?

Thank you.

---

<div class="post-metadata">

**Author:** ![sabeenah](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@sabeenah](https://forum.servoy.com/u/sabeenah)\
**Post date:** [February 25, 2005, 9:15am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/3 "2005-02-25T09:15:22Z")

</div>

I do not think that this behavior has anything to do with the new update of Servoy.  
Digging more on the server where Servoy Server is installed, I noticed that an update to JRE 1.5 was installed there. I unistalled it, restarted the server, and now the client is started with JRE1.4.1\_02, but the same error appears. Reading the logs, I found out that the file WEB-INF/web.xml cannot be found. But the file is there, in the server/webapps.ROOT/WEB-INF folder.

Do you think you have a solution after these new information?

Thank you.

---

<div class="post-metadata">

**Author:** ![jcompagner](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/jcompagner/32/4889_2.png) [@jcompagner](https://forum.servoy.com/u/jcompagner)\
**Post date:** [February 25, 2005, 10:04am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/4 "2005-02-25T10:04:29Z")

</div>

yes that signing error you get when the server and the client are both in 1.5. This is a know bug.  
What is strange is that:  
server/webapps.ROOT/WEB-INF

should be:

server/webapps/ROOT/WEB-INF

---

<div class="post-metadata">

**Author:** ![sabeenah](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@sabeenah](https://forum.servoy.com/u/sabeenah)\
**Post date:** [February 25, 2005, 10:10am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/5 "2005-02-25T10:10:40Z")

</div>

My mistake: it is server/webapps/ROOT/WEB-INF

My only concern is that I have to have the clients running asap. What I did: I went back to release 319, JRE 1.4.x, but the client would not start.

How can I get it to work? What strategy do you suggest?

---

<div class="post-metadata">

**Author:** ![Jan\_Blok](https://avatars.discourse-cdn.com/v4/letter/j/41988e/32.png) [@Jan\_Blok](https://forum.servoy.com/u/Jan_Blok)\
**Post date:** [February 25, 2005, 10:53pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/6 "2005-02-25T22:53:54Z")

</div>

There is currently a known issue when running both server and clients on Java 1.5 so can only use Java 1.5 on one of them.  
Normally an uninstall of Java on the server and reinstalling 1.4.2 should not be a problem…no need to uninstall/reinstall Servoy (when changing JVMs)

---

<div class="post-metadata">

**Author:** ![sabeenah](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@sabeenah](https://forum.servoy.com/u/sabeenah)\
**Post date:** [February 28, 2005, 6:36am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/7 "2005-02-28T06:36:45Z")

</div>

I reinstalled Servoy after changing the JVM, but it also required unistalling the Servoy Application Server service. Now it works.

---

<div class="post-metadata">

**Author:** ![LOGIsoft](https://avatars.discourse-cdn.com/v4/letter/l/e36b37/32.png) [@LOGIsoft](https://forum.servoy.com/u/LOGIsoft)\
**Post date:** [June 11, 2007, 7:57pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/8 "2007-06-11T19:57:42Z")

</div>

I’m using JRE 1.6.0\_01 and I get sensibly the same error when I try to launch my solution using **[IPaddress]:[port]/servoy-client/solutions/solution/[SolutionName]**:

> Unable to launch application
> 
> Exception  
> JNLParseException[Could not parse launch file. Error at line 0.]  
> at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)  
> at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)  
> at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)  
> at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)  
> at com.sun.javaws.Main.launchApp(Unknown Source)  
> at com.sun.javaws.Main.continueInSecureThread(Unknown Source)  
> at com.sun.javaws.Main$1.run(Unknown Source)  
> at java.lang.Thread.run(Unknown Source)
> 
> Wrapped exception  
> java.io.EOFException: encoding.error.not.xml  
> at com.sun.deploy.xml.XMLEncoding.decodeXML(Unknown Source)  
> at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)  
> at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)  
> at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)  
> at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)  
> at com.sun.javaws.Main.launchApp(Unknown Source)  
> at com.sun.javaws.Main.continueInSecureThread(Unknown Source)  
> at com.sun.javaws.Main$1.run(Unknown Source)  
> at java.lang.Thread.run(Unknown Source)

However, everything works fine if I use **http://[IPaddress]:[port]/servoy-client/servoy\_client.jnlp?solution=[SolutionName]** instead. Can anyone explain the difference in behavior and also a way to get rid of this error please?

Many thanks,

Ben

---

<div class="post-metadata">

**Author:** ![Jan\_Blok](https://avatars.discourse-cdn.com/v4/letter/j/41988e/32.png) [@Jan\_Blok](https://forum.servoy.com/u/Jan_Blok)\
**Post date:** [June 12, 2007, 7:39am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/9 "2007-06-12T07:39:35Z")

</div>

typical urls look like:  
richclient - [http://localhost:8080/servoy-client/ser … t/crm.jnlp](http://localhost:8080/servoy-client/servoy_client/crm.jnlp)  
webclient - [http://crm.servoy.com/servoy-webclient/ … oy\_support](http://crm.servoy.com/servoy-webclient/solutions/solution/servoy_support)

Its seems to me you mixing urls.

---

<div class="post-metadata">

**Author:** ![Harjo](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/harjo/32/4873_2.png) [@Harjo](https://forum.servoy.com/u/Harjo)\
**Post date:** [June 12, 2007, 8:45am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/10 "2007-06-12T08:45:14Z")

</div>

HI Jan, is this somewhere in the docs?

Johan had a topic on this forum and said to do it this way:

```auto
http://localhost:8080/servoy-client/servoy_client_YourSolution.jnlp 

```

Is this exactly the same?

---

<div class="post-metadata">

**Author:** ![Jan\_Blok](https://avatars.discourse-cdn.com/v4/letter/j/41988e/32.png) [@Jan\_Blok](https://forum.servoy.com/u/Jan_Blok)\
**Post date:** [June 12, 2007, 8:52am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/11 "2007-06-12T08:52:49Z")

</div>

That the old syntax (which is still supported)

---

<div class="post-metadata">

**Author:** ![svroemisse](https://avatars.discourse-cdn.com/v4/letter/s/da6949/32.png) [@svroemisse](https://forum.servoy.com/u/svroemisse)\
**Post date:** [June 12, 2007, 9:41am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/12 "2007-06-12T09:41:22Z")

</div>

> HJK:  
> HI Jan, is this somewhere in the docs?

The docs only explain the old-style urls. That will be updated for the 3.5 release of the manual.

In case anyone is wondering what the urls should look like for executing methods, this is the definition:

rich client: http://[:]/servoy-client/servoy\_client/.jnlp[?method=[&argument=]]  
web client: http://[:]/servoy-webclient/solutions/solution/[/method/[/argument/]]

There can be only one argument. But of course you can concatenate several values separated by pipe symbols and pull them apart in your method.

---

<div class="post-metadata">

**Author:** ![LOGIsoft](https://avatars.discourse-cdn.com/v4/letter/l/e36b37/32.png) [@LOGIsoft](https://forum.servoy.com/u/LOGIsoft)\
**Post date:** [June 12, 2007, 12:15pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/13 "2007-06-12T12:15:07Z")

</div>

Thanks for this information, guys - time for me to put my mental ducks all in a row… ![:)]( "Smile")

Cheers,

Ben

---

<div class="post-metadata">

**Author:** ![netweaver](https://avatars.discourse-cdn.com/v4/letter/n/b9e5f3/32.png) [@netweaver](https://forum.servoy.com/u/netweaver)\
**Post date:** [September 17, 2007, 1:13pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/14 "2007-09-17T13:13:20Z")

</div>

Hi Jan  
My client uses intel mac to run a local version of servoy.  
I have now made their server available remotely, but when they try to launch the client they get the followinig error:

Could not verify signing in resource: ([http://www.freightsoft.co.za:8080/lib/j2db.jar](http://www.freightsoft.co.za:8080/lib/j2db.jar), 1189762087812)

The local server is not running at all, so their should not be any conflict.  
The client launches fine on windows XP.

not: i installed the latest release on friday, and since then i have had this problem . The prior update was working fine

Please help.  
Thanks  
Marcus Raath  
South Africa

> Jan Blok:  
> There is currently a known issue when running both server and clients on Java 1.5 so can only use Java 1.5 on one of them.  
> Normally an uninstall of Java on the server and reinstalling 1.4.2 should not be a problem…no need to uninstall/reinstall Servoy (when changing JVMs)

---

<div class="post-metadata">

**Author:** ![IT2Be](https://avatars.discourse-cdn.com/v4/letter/i/dc4da7/32.png) [@IT2Be](https://forum.servoy.com/u/IT2Be)\
**Post date:** [September 17, 2007, 1:19pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/15 "2007-09-17T13:19:10Z")

</div>

Have you tried to empty java cache?

---

<div class="post-metadata">

**Author:** ![netweaver](https://avatars.discourse-cdn.com/v4/letter/n/b9e5f3/32.png) [@netweaver](https://forum.servoy.com/u/netweaver)\
**Post date:** [September 17, 2007, 1:30pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/16 "2007-09-17T13:30:33Z")

</div>

Hi Marcell  
Yes i have done that with no success as well.  
I was able to launch the client on friday, but this was before i installed the latest update.

Thanks  
Marcus

> IT2Be:  
> Have you tried to empty java cache?

---

<div class="post-metadata">

**Author:** ![IT2Be](https://avatars.discourse-cdn.com/v4/letter/i/dc4da7/32.png) [@IT2Be](https://forum.servoy.com/u/IT2Be)\
**Post date:** [September 17, 2007, 1:34pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/17 "2007-09-17T13:34:22Z")

</div>

Anything in the log?

---

<div class="post-metadata">

**Author:** ![netweaver](https://avatars.discourse-cdn.com/v4/letter/n/b9e5f3/32.png) [@netweaver](https://forum.servoy.com/u/netweaver)\
**Post date:** [September 17, 2007, 1:48pm UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/18 "2007-09-17T13:48:06Z")

</div>

> IT2Be:  
> Anything in the log?

2007-09-17 15:16 http-8080-1 ERROR com.servoy.j2db.util.Debug Throwable  
java.lang.NullPointerException  
at com.servoy.j2db.scripting.k.get(Unknown Source)  
at com.servoy.j2db.dataprocessing.FoundSet.getCalculationValue(Unknown Source)  
at com.servoy.j2db.dataprocessing.aw.getValue(Unknown Source)  
at com.servoy.j2db.dataprocessing.e$a.getStringValue(Unknown Source)  
at com.servoy.j2db.util.Text.processTags(Unknown Source)  
at com.servoy.j2db.server.headlessclient.dataui.az.onBeforeRender(Unknown Source)  
at org.apache.wicket.Component.beforeRender(Component.java:846)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.MarkupContainer.onBeforeRenderChildren(MarkupContainer.java:1472)  
at org.apache.wicket.Component.beforeRender(Component.java:856)  
at org.apache.wicket.Page.renderPage(Page.java:885)  
at org.apache.wicket.protocol.http.WebRequestCycle.redirectTo(WebRequestCycle.java:164)  
at org.apache.wicket.request.target.component.PageRequestTarget.respond(PageRequestTarget.java:59)  
at org.apache.wicket.request.AbstractRequestCycleProcessor.respond(AbstractRequestCycleProcessor.java:103)  
at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1037)  
at org.apache.wicket.RequestCycle.step(RequestCycle.java:1107)  
at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1176)  
at org.apache.wicket.RequestCycle.request(RequestCycle.java:499)  
at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:257)  
at org.apache.wicket.protocol.http.WicketServlet.doGet(WicketServlet.java:126)  
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)  
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)  
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)  
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)  
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)  
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)  
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)  
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)  
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:563)  
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)  
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)  
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)  
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:581)  
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)  
at java.lang.Thread.run(Unknown Source)  
2007-09-17 15:16 http-8080-1 ERROR com.servoy.j2db.util.Debug null

---

<div class="post-metadata">

**Author:** ![IT2Be](https://avatars.discourse-cdn.com/v4/letter/i/dc4da7/32.png) [@IT2Be](https://forum.servoy.com/u/IT2Be)\
**Post date:** [September 20, 2007, 6:57am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/19 "2007-09-20T06:57:37Z")

</div>

This log shows an issue with a headless client? A calculation?

Can you give an idea of your setup?

---

<div class="post-metadata">

**Author:** ![netweaver](https://avatars.discourse-cdn.com/v4/letter/n/b9e5f3/32.png) [@netweaver](https://forum.servoy.com/u/netweaver)\
**Post date:** [September 20, 2007, 7:12am UTC](https://forum.servoy.com/t/servoy-2-2rc2/3682/20 "2007-09-20T07:12:09Z")

</div>

I have installed 3.5 b14 on a windows 2003 server.  
My clients need to access the smart client via intel mac.  
Database is mysql 5.

I remember now that i selected the option to install the headless client, although i am not using it at all.

Thanks

> IT2Be:  
> This log shows an issue with a headless client? A calculation?
> 
> Can you give an idea of your setup?

[Next page](https://forum.servoy.com/t/servoy-2-2rc2/3682.md?page=2)
