# SQL error on solution import

**URL:** <https://forum.servoy.com/t/sql-error-on-solution-import/8571>\
**Category:** Classic Servoy\
**Created:** [January 3, 2008, 12:47am UTC](https://forum.servoy.com/t/sql-error-on-solution-import/8571 "2008-01-03T00:47:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rodneysieb](https://avatars.discourse-cdn.com/v4/letter/r/87869e/32.png) [@rodneysieb](https://forum.servoy.com/u/rodneysieb)\
**Post date:** [January 3, 2008, 12:47am UTC](https://forum.servoy.com/t/sql-error-on-solution-import/8571/1 "2008-01-03T00:47:39Z")

</div>

Hi

I am getting the following error when importing a solution into the admin server which i haven’t seen before.

[info]Import contains XML version 10 and repository version 27.  
[info]Imported style ‘newaerotrack’.  
[info]Imported style ‘aerotrack’.  
[error]com.servoy.j2db.persistence.RepositoryException:java.sql.SQLException: Can’t create/write to file C:\WINDOWS\TEMP#sql\_1764\_0.MYD’ (Errcode: 13)

This does not occur on the first import into a “empty” repository , the solution imports and works fine. It only happens on importing a second release which always fails.

i have imported this version of my vertical app in other servers OK. This server installation is kept identical (versions) to other installations which are running fine.

Is there a permission that needs to be set on the server?

Any advice would be appreciated.

Servoy 2.2.7  
MySQL 5.027  
Java 1.5.06

---

<div class="post-metadata">

**Author:** ![rodneysieb](https://avatars.discourse-cdn.com/v4/letter/r/87869e/32.png) [@rodneysieb](https://forum.servoy.com/u/rodneysieb)\
**Post date:** [February 26, 2008, 1:57am UTC](https://forum.servoy.com/t/sql-error-on-solution-import/8571/2 "2008-02-26T01:57:19Z")

</div>

Hi

Thought i would let you know this problem has been resolved.

There was an issue with a McAfee Enterprise antivirus software and MySQL running on the server. Excluding the temp directory that MySQL writes to from the antivirus scanner has resolved this.
