# Web client problem with Ajax in Servoy 3.5.5

**URL:** https://forum.servoy.com/t/web-client-problem-with-ajax-in-servoy-3-5-5/8867
**Category:** Classic Servoy
**Created:** [March 13, 2008, 7:57pm UTC](https://forum.servoy.com/t/web-client-problem-with-ajax-in-servoy-3-5-5/8867 "2008-03-13T19:57:00Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![adamk](https://avatars.discourse-cdn.com/v4/letter/a/3bc359/32.png) [@adamk](https://forum.servoy.com/u/adamk)
#### Post date: [March 13, 2008, 7:57pm UTC](https://forum.servoy.com/t/web-client-problem-with-ajax-in-servoy-3-5-5/8867/1 "2008-03-13T19:57:00Z")

</div>

My company recently upgraded our hosted web client solution from Servoy 3.0 to Servoy 3.5.5. It works fine for most people, but a handful of users have reported certain functions not working. Some users with Norton Internet Security installed can’t even access our web page, unless they disable Norton. The web page is also hosted by Servoy.  
I think the problems the users are reporting are caused by Ajax. Unfortunately, no one can log into the solution at all if Ajax is disabled. I’ve looked through the log files with and without Ajax enabled, and it seems as though I’m just trading certain errors for other errors when I disable or enable Ajax.

Here is an excerpt from .service\_log with Ajax enabled:

> INFO | jvm 2 | 2008/03/10 17:00:14 | Mar 10, 2008 5:00:14 PM org.apache.tomcat.util.net.NioEndpoint setSocketOptions  
> INFO | jvm 2 | 2008/03/10 17:00:14 | SEVERE:  
> INFO | jvm 2 | 2008/03/10 17:00:14 | java.lang.NullPointerException  
> INFO | jvm 2 | 2008/03/10 17:00:14 | at org.apache.tomcat.util.net.NioEndpoint.setSocketOptions(NioEndpoint.java:998)  
> INFO | jvm 2 | 2008/03/10 17:00:14 | at org.apache.tomcat.util.net.NioEndpoint$Acceptor.run(NioEndpoint.java:1183)  
> INFO | jvm 2 | 2008/03/10 17:00:14 | at java.lang.Thread.run(Unknown Source)  
> INFO | jvm 2 | 2008/03/10 17:00:14 | Mar 10, 2008 5:00:14 PM org.apache.coyote.http11.Http11NioProtocol start  
> INFO | jvm 2 | 2008/03/10 17:00:14 | INFO: Starting Coyote HTTP/1.1 on http-80  
> INFO | jvm 2 | 2008/03/10 17:00:14 | Mar 10, 2008 5:00:14 PM org.apache.catalina.startup.Catalina start  
> INFO | jvm 2 | 2008/03/10 17:00:14 | INFO: Server startup in 4740 ms  
> INFO | jvm 2 | 2008/03/10 17:00:18 | Mar 10, 2008 5:00:18 PM org.apache.tomcat.util.net.NioSelectorPool getSharedSelector  
> INFO | jvm 2 | 2008/03/10 17:00:18 | INFO: Using a shared selector for servlet write/read  
> STATUS | wrapper | 2008/03/10 17:01:11 | ← Wrapper Stopped

And here is the same excerpt from .service\_log with Ajax disabled:

> INFO | jvm 2 | 2008/03/10 16:51:45 | 1844 [WrapperSimpleAppMain] INFO com.servoy.j2db.util.Debug - Loading - Done  
> INFO | jvm 2 | 2008/03/10 16:52:09 | Mar 10, 2008 4:52:09 PM org.apache.coyote.http11.Http11NioProtocol init  
> INFO | jvm 2 | 2008/03/10 16:52:09 | INFO: Initializing Coyote HTTP/1.1 on http-80  
> INFO | jvm 2 | 2008/03/10 16:52:09 | Mar 10, 2008 4:52:09 PM org.apache.catalina.startup.Catalina load  
> INFO | jvm 2 | 2008/03/10 16:52:09 | INFO: Initialization processed in 1428 ms  
> INFO | jvm 2 | 2008/03/10 16:52:09 | Mar 10, 2008 4:52:09 PM org.apache.catalina.core.StandardService start  
> INFO | jvm 2 | 2008/03/10 16:52:09 | INFO: Starting service Catalina  
> INFO | jvm 2 | 2008/03/10 16:52:09 | Mar 10, 2008 4:52:09 PM org.apache.catalina.core.StandardEngine start  
> INFO | jvm 2 | 2008/03/10 16:52:09 | INFO: Starting Servlet Engine: Apache Tomcat/6.0-snapshot  
> INFO | jvm 2 | 2008/03/10 16:52:10 | Mar 10, 2008 4:52:10 PM org.apache.catalina.startup.DigesterFactory register  
> INFO | jvm 2 | 2008/03/10 16:52:10 | WARNING: Could not get url for /javax/servlet/resources/web-app\_2\_5.xsd  
> INFO | jvm 2 | 2008/03/10 16:52:13 | Mar 10, 2008 4:52:13 PM org.apache.coyote.http11.Http11NioProtocol start  
> INFO | jvm 2 | 2008/03/10 16:52:13 | INFO: Starting Coyote HTTP/1.1 on http-80  
> INFO | jvm 2 | 2008/03/10 16:52:13 | Mar 10, 2008 4:52:13 PM org.apache.catalina.startup.Catalina start  
> INFO | jvm 2 | 2008/03/10 16:52:13 | INFO: Server startup in 4315 ms  
> INFO | jvm 2 | 2008/03/10 16:52:27 | Mar 10, 2008 4:52:27 PM org.apache.tomcat.util.net.NioSelectorPool getSharedSelector  
> INFO | jvm 2 | 2008/03/10 16:52:27 | INFO: Using a shared selector for servlet write/read  
> STATUS | wrapper | 2008/03/10 16:55:00 | ← Wrapper Stopped

Is there a bug with Ajax? If not, how can I find out where the problem lies?

---

<div class="post-metadata">

### Author: ![Harjo](https://yyz2.discourse-cdn.com/flex010/user_avatar/forum.servoy.com/harjo/32/4873_2.png) [@Harjo](https://forum.servoy.com/u/Harjo)
#### Post date: [March 13, 2008, 8:53pm UTC](https://forum.servoy.com/t/web-client-problem-with-ajax-in-servoy-3-5-5/8867/2 "2008-03-13T20:53:23Z")

</div>

We are experience the same ajax enable/disable issues.

with ajax ON there are no errors, but with ajax off, we get an internal error with every page., after that we return to the solutoin choice page, and if choose the websolution, the webclient DOES go to the next form.  
If we than navigate to a new form we get:  
internal error.

- click the websolution

- we arrive at the new form

navigate to new form:  
internal error.

- click the websolution

- we arrive at the new form

and so on, and so on…

The problem is that I tried to make a reproducable case, by exporting it to another machine, but most of the times, there it works! (you have to click hundreds of times, before it’s gonna behave as above…)
