Servoy 2022.09 release candidate 2

Release notes for Servoy betas

Servoy 2022.09 release candidate 2

Postby jcompagner » Mon Sep 19, 2022 7:02 pm

We are pleased to announce the availability of Servoy 2022.09 release candidate 2 (release number 3801)

this included tweaks to the new theme, some export fixes and a few TiNG fixes.

For Windows the installer: exe
and for the MacOSX_86_64 we have an native dmg
and for the MacOSX_Aarch64 (M1) we have an native m1 dmg
for linux it is tar.gz

For windows we also still have just the zip

An installation (coming from the normal installer or from a platform specific archive) is shipping with with a Java VM (Java 17.0.4)

So for the platform specific archives you don't need to install or have java on your system.

The developer can be updated by the https://download.servoy.com/developer/l ... ecandidate update site url.
This is in our "latest" release stream (03,06,09,12) if you want to stick the LTS release then disable that releasecandidate url and stick to the urls with "lts" in the name
If you update to this release you have to do a new install of 2022.03.2_lts to go back to an the LTS release branch

See whats new for the global changes

See the issues list for a complete overview of all the cases including the list that are fixed for this RC2

Make sure you use all the latest webpackages that also have the 2022.09.x version
Older versions won't work in combination with Servoy 2022.09
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8691
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 2022.09 release candidate 2

Postby d.wanscheid » Tue Sep 20, 2022 12:19 pm

After updating Servoy Developer from 2022.6 to 2022.9 via Help -> Check for Updates, the Form Editor doesn't work anymore... what should we do here? All Modules are up to date.

Image
d.wanscheid
 
Posts: 8
Joined: Tue Sep 20, 2022 12:05 pm

Re: Servoy 2022.09 release candidate 2

Postby lvostinar » Tue Sep 20, 2022 1:18 pm

d.wanscheid wrote:After updating Servoy Developer from 2022.6 to 2022.9 via Help -> Check for Updates, the Form Editor doesn't work anymore... what should we do here? All Modules are up to date.

Image


Hi, did you see this info:

Make sure you use all the latest webpackages that also have the 2022.09.x version
Older versions won't work in combination with Servoy 2022.09


I guess you didn't update the libraries? If you still have the error after all libraries are up to date please give us the error from Titanium Client Build Console.
Laurian Vostinar
Servoy
lvostinar
 
Posts: 1059
Joined: Tue Feb 19, 2008 10:53 am

Re: Servoy 2022.09 release candidate 2

Postby d.wanscheid » Tue Sep 20, 2022 1:53 pm

Make sure you use all the latest webpackages that also have the 2022.09.x version
Older versions won't work in combination with Servoy 2022.09


Yes, all modules, packages and services have version 2022.9.x. Some that don't have the version (e.g. Fullcalendar 2) I can't update, of course.

Image


As i can see, the Fullcalendar 2 is making trouble i think. Is there not an 2022.9.x?

Code: Select all
---- Start to check to copy the Titanium NG sources
Total time to copy done 0s

---- Starting Titanium NGClient source check (13:48:30.0017447)
No generated files, build will be triggered
Updated SPM target folder: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\packages\@servoy\fullcalendarcomponent2 from source package dir: C:\workspaces\GIT\HVO2go TI\fullcalendarcomponent2\projects\fullcalendarcomponent2

---- Running npm command:
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node.exe"
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node_modules\npm\bin\npm-cli.js"
install --legacy-peer-deps
In dir: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go

added 33 packages, and audited 182 packages in 38s

6 packages are looking for funding
run `npm fund` for details

found 0 vulnerabilities
Finished running 'install --legacy-peer-deps ' time: 43s


---- Running npm command:
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node.exe"
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node_modules\npm\bin\npm-cli.js"
update --legacy-peer-deps
In dir: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go

added 2 packages, removed 1 package, changed 1 package, and audited 183 packages in 52s

6 packages are looking for funding
run `npm fund` for details

found 0 vulnerabilities
Finished running 'update --legacy-peer-deps ' time: 54s


---- Running npm command:
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node.exe"
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node_modules\npm\bin\npm-cli.js"
dedup
In dir: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go

added 1 package, removed 2 packages, changed 1 package, and audited 182 packages in 2s

6 packages are looking for funding
run `npm fund` for details

found 0 vulnerabilities
Finished running 'dedup ' time: 4s

None NPM dedup time (root node_modules/solution node_modules): 17s

---- Running npm command:
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node.exe"
"C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\node-v16.17.0-win-x64\node_modules\npm\bin\npm-cli.js"
run build_debug_nowatch
In dir: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go

> ngclient2@2022.9.0 build_debug_nowatch
> ng build ngclient2 --watch=false

- Generating browser application bundles (phase: setup)...

- ngx-filesaver [es2015/esm2015] (git+https://github.com/cipchk/ngx-filesaver.git)
DeprecationWarning: 'getMutableClone' has been deprecated since v4.0.0. Use an appropriate `factory.update...` method instead, use `setCommentRange` or `setSourceMapRange`, and avoid setting `parent`.
√ Browser application bundle generation complete.
√ Browser application bundle generation complete.

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@fullcalendar\angular\__ivy_ngcc__\fesm2015\fullcalendar-angular.js depends on 'fast-deep-equal'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@fullcalendar\icalendar\main.js depends on 'ical.js'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@servoy\servoyextracomponents\fesm2020\servoy-servoyextracomponents.mjs depends on '@servoy/canvas-gauges'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@servoy\servoyextracomponents\fesm2020\servoy-servoyextracomponents.mjs depends on 'ngx-lightbox'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@servoy\servoyextracomponents\fesm2020\servoy-servoyextracomponents.mjs depends on 'rx-dom-html'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@uppy\core\lib\Uppy.js depends on 'lodash.throttle'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@uppy\core\lib\Uppy.js depends on 'namespace-emitter'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@uppy\dashboard\lib\components\Dashboard.js depends on 'classnames'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@uppy\dashboard\lib\utils\createSuperFocus.js depends on 'lodash.debounce'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\@uppy\webcam\lib\Webcam.js depends on 'is-mobile'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\node_modules\tus-js-client\lib.esm\upload.js depends on 'url-parse'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\projects\servoy-public\src\lib\format\formatting.service.ts depends on 'numbro'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies

Warning: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go\projects\servoydefault\src\lib\htmlarea\htmlarea.ts depends on 'tinymce'. CommonJS or AMD dependencies can cause optimization bailouts.
For more info see: https://angular.io/guide/build#configuring-commonjs-dependencies



./node_modules/@fullcalendar/common/main.css:4:0 - Error: Module parse failed: Unexpected token (4:0)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
| /* classes

./node_modules/@fullcalendar/daygrid/main.css:2:0 - Error: Module parse failed: Unexpected token (2:0)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
|
> :root {
|   --fc-daygrid-event-dot-width: 8px;
| }

./node_modules/@fullcalendar/list/main.css:2:0 - Error: Module parse failed: Unexpected token (2:0)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
|
> :root {
|   --fc-list-event-dot-width: 10px;
|   --fc-list-event-hover-bg-color: #f5f5f5;

./node_modules/@fullcalendar/resource-timeline/main.css:3:2 - Error: Module parse failed: Unexpected token (3:2)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
|
|
>   .fc .fc-resource-timeline-divider {
|     width: 3px; /* important to have width to shrink this cell. no cross-browser problems */
|     cursor: col-resize;

./node_modules/@fullcalendar/timegrid/main.css:6:0 - Error: Module parse failed: Unexpected token (6:0)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
| */
|
> .fc-v-event { /* allowed to be top-level */
|   display: block;
|   border: 1px solid #3788d8;

./node_modules/@fullcalendar/timeline/main.css:3:2 - Error: Module parse failed: Unexpected token (3:2)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
|
|
>   .fc .fc-timeline-body {
|     min-height: 100%;
|     position: relative;


Finished running 'run build_debug_nowatch ' time: 105s

Total time to check/install Titanium NG target folder: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go is 226s

d.wanscheid
 
Posts: 8
Joined: Tue Sep 20, 2022 12:05 pm

Re: Servoy 2022.09 release candidate 2

Postby lvostinar » Tue Sep 20, 2022 2:13 pm

d.wanscheid wrote:Yes, all modules, packages and services have version 2022.9.x. Some that don't have the version (e.g. Fullcalendar 2) I can't update, of course.


Yes, I see we missed that one, you need a new release(that we will do soon) or you can use the sources for that one.
Laurian Vostinar
Servoy
lvostinar
 
Posts: 1059
Joined: Tue Feb 19, 2008 10:53 am

Re: Servoy 2022.09 release candidate 2

Postby d.wanscheid » Tue Sep 20, 2022 3:23 pm

lvostinar wrote:Yes, I see we missed that one, you need a new release(that we will do soon) or you can use the sources for that one.


Just installed it from source... i get this error:

Code: Select all
install @servoy/fullcalendarcomponent2@2022.9.0
--legacy-peer-deps
In dir: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go
npm ERR! code E404
npm ERR! 404 Not Found - GET https://registry.npmjs.org/@servoy%2ffullcalendarcomponent2 - Not found
npm ERR! 404
npm ERR! 404  '@servoy/fullcalendarcomponent2@2022.9.0' is not in this registry.
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.
d.wanscheid
 
Posts: 8
Joined: Tue Sep 20, 2022 12:05 pm

Re: Servoy 2022.09 release candidate 2

Postby lvostinar » Wed Sep 21, 2022 8:53 am

d.wanscheid wrote:
lvostinar wrote:Yes, I see we missed that one, you need a new release(that we will do soon) or you can use the sources for that one.


Just installed it from source... i get this error:

Code: Select all
install @servoy/fullcalendarcomponent2@2022.9.0
--legacy-peer-deps
In dir: C:\workspaces\GIT\HVO2go TI\.metadata\.plugins\com.servoy.eclipse.ngclient.ui\target\HVO2go
npm ERR! code E404
npm ERR! 404 Not Found - GET https://registry.npmjs.org/@servoy%2ffullcalendarcomponent2 - Not found
npm ERR! 404
npm ERR! 404  '@servoy/fullcalendarcomponent2@2022.9.0' is not in this registry.
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.


We released now fullcalendarcomponent2 version 2022.9.0. About above error, not sure what you were trying to do. For doing a release yourself you have the steps here: https://wiki.servoy.com/display/DOCS/De ... +NGClient2 (Releasing a component paragraph). For using a package library from source, you have to import in Servoy Developer the library project (from your git folder) and link the project to be used as reference instead of released library.
Laurian Vostinar
Servoy
lvostinar
 
Posts: 1059
Joined: Tue Feb 19, 2008 10:53 am


Return to Latest Releases

Who is online

Users browsing this forum: No registered users and 1 guest