Servoy 2024.3 release candidate 3

Release notes for Servoy betas

Servoy 2024.3 release candidate 3

Postby jcompagner » Fri Mar 29, 2024 5:43 pm

We are pleased to announce the availability of Servoy 2024.3 release candidate 3 (release number 3942)

See whats new for the global changes and the case list

This release has a breaking change so do read the release notes.

For Windows the installer: exe
and for the MacOSX_86_64 we have an native dmg
and for the MacOSX_Aarch64 (M1) we have an native m1 dmg
for linux it is tar.gz

For windows we also still have just the zip

An installation (coming from the normal installer or from a platform specific archive) is shipping with a Java VM (Java 21.0.1)
So for the platform specific archives you don't need to install or have java on your system.

This release is build on Eclipse 2023.12 (4.30)


The developer can be updated by the https://download.servoy.com/developer/l ... ecandidate update site URL.
This is in our "latest" release stream (03,06,09,12) if you want to stick the LTS release then disable that releasecandidate url and stick to the URLs with "lts" in the name
If you update to this release you have to do a new install of 2023.03.5_LTS to go back to an the LTS release branch

This release will be promoted this year to an LTS, shortly after the 2024.6 release, so then it will be released as 2024.3.x_LTS which will be supported for 2 years.

This release will be the last release that support SmartClient, WebClient and NG1 (angularjs)

it could be that the update fails if you come from a much older release (like 2021.06 -> 2022.12) that you can get errors like:

Code: Select all
An error occurred while collecting items to be installed
session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,com.servoy.eclipse.core,2022.12.0.3840_rc.
Error reading signed content:C:\Users\jcomp\AppData\Local\Temp\signatureFile11879913363204093521.jar


Or that you can't install it completely (you can't pass the update dialog, because it says incompatibilities found)
This is because from 2022.12 on we depend on java 17. (so the developer that you run should already be on java 17)

You can fix both issues to first jump to an older version like a 2022.03.x release, you can do this by making this URL:

https://download.servoy.com/developer/latest/3743/

first the only update site in the preferences -> install/update -> sites, so add that URL and make sure that is the only one.

Then it updates to that release first, then you can enable the release candidate URL again.

Almost all the webpackages have updates because of the major Angular upgrade (to 17.2):

bootstrap-components, servoy-extra-components, bootstrap-extra-components and ng-grid and others have all a 2024.3 release.
The NGGrid 2024.3.x is mandatory to upgrade for Servoy 2024.3.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8839
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Return to Latest Releases

Who is online

Users browsing this forum: No registered users and 18 guests

cron