Repository problem

Release notes for Servoy betas

Repository problem

Postby patrick » Fri Dec 26, 2003 12:47 pm

Hello, I have my repository in a MS SQL database. After starting Servoy 2 for the first time I was asked, if I wanted to upgrade the repository. After saying yes, Servoy displays "reconnecting to repository" and nothing happens anymore. I can open the repository with Servoy 1.2, though.

I have then exported my solution, deleted the repository database, recreated a repository with Servoy 2 and then tried to re-import my solution. The result is more or less the same: Servoy imports and imports and imports - until I get tired of waiting and go back to Servoy 1.2.

Anyone else experiencing this problem? I'd really like to try version 2, so if anyone can help, I'd appreciate it.

Thanks.
patrick
 
Posts: 3703
Joined: Wed Jun 11, 2003 10:33 am
Location: Munich, Germany

Postby Jan Aleman » Fri Jan 02, 2004 5:02 pm

I'm unable to reproduce it on ms sql 2000.
Jan Aleman
Servoy
Jan Aleman
 
Posts: 2083
Joined: Wed Apr 23, 2003 9:49 pm
Location: Planet Earth

Postby patrick » Sat Jan 03, 2004 12:21 am

hmm. Tried almost all kinds of things. I am just reinstalling my system since it started to behave strangely in many ways, maybe that solves the problem.

Thanks for trying out! I'll get back to you if it doesn't work after re-installation :wink:
patrick
 
Posts: 3703
Joined: Wed Jun 11, 2003 10:33 am
Location: Munich, Germany

Postby patrick » Sat Jan 03, 2004 5:54 pm

Did a re-install of everything (Windows XP, SQL Server 2000 SP3, Servoy 1.2 and Servoy 2). Still, I can't get Servoy 2 to convert the repository. It starts, does everything as expected, does operate on some data (at least what I can see from hard disk operation) and never gets back to me ("Reconnecting to repository...").

What can we do to trace the problem? The command window doesn't show anything. As mentioned before, I also tried to export the solution in Servoy 1.2 and re-import that via Servoy 2. That also won't do.

Any ideas? :cry:

Thanks!
patrick
 
Posts: 3703
Joined: Wed Jun 11, 2003 10:33 am
Location: Munich, Germany

Postby patrick » Sat Jan 03, 2004 6:01 pm

Hi, some more news: I managed to import a smaller solution succesfully. I suppose it now might be helpful to see my solution file?
patrick
 
Posts: 3703
Joined: Wed Jun 11, 2003 10:33 am
Location: Munich, Germany

Postby jcompagner » Sun Jan 04, 2004 4:34 pm

Please send it over. Then we will look at it.
(describe in the email again what youre setup is!)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8833
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Postby jcompagner » Mon Jan 05, 2004 9:01 pm

Fixed in b6
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8833
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet


Return to Latest Releases

Who is online

Users browsing this forum: No registered users and 18 guests