Model Tool install problem in 7.4.6

Questions and answers on developing, deploying and using plugins and JavaBeans

Model Tool install problem in 7.4.6

Postby fuchstaenzer » Thu Mar 31, 2016 3:29 pm

Hi all,

first of all - apologies for not being an Eclipse expert ;-)

I'm currently trying to install the Model Tool by following the instructions from http://www.servoy-stuff.net/modeltool/installation.pdf
but constantly are failing miserably at step one -> Ecore Tools SDK

I tried the URLs below (amongst several others). They all fail because something else seems to be missing....

Any help really appreciated!
Joachim



http://download.eclipse.org/releases/indigo/
http://download.eclipse.org/releases/kepler/
http://download.eclipse.org/modeling/em ... 1306071421
http://download.eclipse.org/ecoretools/updates/




http://download.eclipse.org/releases/indigo/

Cannot complete the install because of a conflicting dependency.
Software being installed: Ecore Tools SDK 1.0.0.v20110608-1633 (org.eclipse.emf.ecoretools.sdk.feature.group 1.0.0.v20110608-1633)
Software currently installed: Servoy Developer 7.4.6.2043 (servoy 7.4.6.2043)
Only one of the following can be installed at once:
International Components for Unicode for Java (ICU4J) 50.1.1.v201304230130 (com.ibm.icu 50.1.1.v201304230130)
International Components for Unicode for Java (ICU4J) 4.4.2.v20110208 (com.ibm.icu 4.4.2.v20110208)
International Components for Unicode for Java (ICU4J) 4.4.2.v20110823 (com.ibm.icu 4.4.2.v20110823)
Cannot satisfy dependency:
From: Eclipse e4 Rich Client Platform 1.2.2.v20140206-1358 (org.eclipse.e4.rcp.feature.group 1.2.2.v20140206-1358)
To: com.ibm.icu [50.1.1.v201304230130]
Cannot satisfy dependency:
From: Ecore Tools Diagram 1.0.0.v20110601-1615 (org.eclipse.emf.ecoretools.diagram 1.0.0.v20110601-1615)
To: bundle org.eclipse.emf.validation [1.4.0,2.0.0)
Cannot satisfy dependency:
From: Ecore Tools 1.0.0.v20110608-1633 (org.eclipse.emf.ecoretools.feature.group 1.0.0.v20110608-1633)
To: org.eclipse.emf.ecoretools.diagram [1.0.0.v20110601-1615]
Cannot satisfy dependency:
From: Ecore Tools SDK 1.0.0.v20110608-1633 (org.eclipse.emf.ecoretools.sdk.feature.group 1.0.0.v20110608-1633)
To: org.eclipse.emf.ecoretools.feature.group [1.0.0.v20110608-1633]
Cannot satisfy dependency:
From: EMF Validation Framework Core 1.4.0.v20100428-2315 (org.eclipse.emf.validation 1.4.0.v20100428-2315)
To: package com.ibm.icu.lang [4.0.0,5.0.0)
Cannot satisfy dependency:
From: Eclipse RCP 4.3.2.v20140221-1700 (org.eclipse.rcp.feature.group 4.3.2.v20140221-1700)
To: org.eclipse.e4.rcp.feature.group [1.2.2.v20140206-1358]
Cannot satisfy dependency:
From: Servoy Developer 7.4.6.2043 (servoy 7.4.6.2043)
To: org.eclipse.rcp.feature.group [4.3.2.v20140221-1700]



http://download.eclipse.org/releases/kepler/

Unable to read repository at http://download.eclipse.org/releases/kepler.
Unable to read repository at http://download.eclipse.org/releases/kepler.
Unable to read repository at http://download.eclipse.org/releases/ke ... 1402280900.
http://download.eclipse.org/releases/ke ... 1402280900 is not a valid repository location.



http://download.eclipse.org/modeling/emft/ecoretools/updates/1.2/201306071421

Cannot complete the install because one or more required items could not be found.
Software being installed: Diagram Editor for Ecore (SDK) 1.2.0.201306071421 (org.eclipse.emf.ecoretools.sdk.feature.group 1.2.0.201306071421)
Missing requirement: Ecore Diagram Filtering 1.2.0.201306071421 (org.eclipse.emf.ecoretools.filters 1.2.0.201306071421) requires 'bundle org.eclipse.gmf.runtime.diagram.ui.properties 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Diagram Editor for Ecore 1.2.0.201306071421 (org.eclipse.emf.ecoretools.feature.group 1.2.0.201306071421)
To: org.eclipse.emf.ecoretools.filters [1.2.0.201306071421]
Cannot satisfy dependency:


http://download.eclipse.org/ecoretools/updates/

Cannot complete the install because one or more required items could not be found.
Software being installed: Ecore Tools SDK (Incubation) 0.10.0.v20100615-1639 (org.eclipse.emf.ecoretools.sdk.feature.group 0.10.0.v20100615-1639)
Missing requirement: Ecore Tools (Incubation) 0.10.0.v20100615-1639 (org.eclipse.emf.ecoretools 0.10.0.v20100615-1639) requires 'bundle org.eclipse.emf.ecore.edit [2.6.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: Ecore Tools (Incubation) 0.10.0.v20100615-1639 (org.eclipse.emf.ecoretools.feature.group 0.10.0.v20100615-1639)
To: org.eclipse.emf.ecoretools [0.10.0.v20100615-1639]
Cannot satisfy dependency:
From: Ecore Tools SDK (Incubation) 0
fuchstaenzer
 
Posts: 4
Joined: Wed Jan 29, 2014 9:12 pm

Re: Model Tool install problem in 7.4.6

Postby ptalbot » Fri Apr 01, 2016 12:49 am

I haven't tested in 7.4.6, but have successfully installed in 7.4.4 not that long ago, I would believe 7.4.6 should be working as well.
I'll give it a shot soon and will keep you posted.
Patrick Talbot
Freelance - Open Source - Servoy Valued Professional
https://www.servoyforge.net
Velocity rules! If you don't use it, you don't know what you're missing!
User avatar
ptalbot
 
Posts: 1654
Joined: Wed Mar 11, 2009 5:13 am
Location: Montreal, QC

Re: Model Tool install problem in 7.4.6

Postby fuchstaenzer » Tue Apr 05, 2016 5:19 pm

fyi:

after a fresh install of 7.4.6 I finally managed to install Ecore Tools SDK

When using this repo http://download.eclipse.org/graphiti/updates/milestones there's only 0.13.x versions available.
After choosing the latest one I was offered to "install remediation page" 0.9.1.x which finally worked
(after moving to a machine with a different antivirus thingi ;-)

Now will give Model Tool a try.

cheers
fuchstaenzer
 
Posts: 4
Joined: Wed Jan 29, 2014 9:12 pm


Return to Plugins and Beans

Who is online

Users browsing this forum: No registered users and 2 guests