BEWARE of Jaspersoft Studio 6.11 ( maybe 6.10 )

Questions and answers on developing, deploying and using plugins and JavaBeans

BEWARE of Jaspersoft Studio 6.11 ( maybe 6.10 )

Postby miltenb » Fri Dec 20, 2019 3:30 pm

L.S.,

I just updated to 6.11.0 and saw my reports not working any more on our server. I'll have to find out the plugin version we are using, I'll report that later on.

The new version introduces a new attribute 'textAdjust' in the textField tag: '<textField textAdjust="StretchHeight" isBlankWhenNull="true"> as in this example.
Opening this file in 6.9 results in errors you can fix...

HTH

Joost
miltenb
 
Posts: 18
Joined: Wed Oct 10, 2007 2:25 pm
Location: Utrecht, The Netherlands

Re: BEWARE of Jaspersoft Studio 6.11 ( maybe 6.10 )

Postby ststaggs.work » Tue Feb 04, 2020 6:21 pm

Hello. We were in a similar situation.

We were able to work around it by downloading jasperreports-6.11.0.jar, jasperreports-fonts-6.11.0.jar, and jasperreports-functions-6.11.0.jar from https://community.jaspersoft.com/projec ... y/releases and replacing the equivalent 6.4.1 jar files from the servoy_jasperreports folder in the Servoy installation's plugins folder with the above 6.11.0 files.

If anyone from Servoy happens upon this thread, would this warrant an update to the jasper plugin from servoyforge?
ststaggs.work
 
Posts: 1
Joined: Tue Feb 04, 2020 6:08 pm

Re: BEWARE of Jaspersoft Studio 6.11 ( maybe 6.10 )

Postby Gabi Boros » Fri Feb 14, 2020 4:05 pm

there is a case for updating to latest jasper lib, see https://support.servoy.com/browse/SVY-14719
Gabi Boros
Servoy
Gabi Boros
 
Posts: 373
Joined: Tue Jun 26, 2007 4:03 pm
Location: Timisoara, Romania


Return to Plugins and Beans

Who is online

Users browsing this forum: No registered users and 8 guests

cron