Servoy COM plugin and Java 14

Questions and answers on developing, deploying and using plugins and JavaBeans

Servoy COM plugin and Java 14

Postby lwjwillemsen » Fri Apr 17, 2020 2:43 pm

Hi,
I am getting an error in using this plugin on Java 14:

# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000180012ca1, pid=11196, tid=18272
#
# JRE version: OpenJDK Runtime Environment AdoptOpenJDK (14.0+36) (build 14+36)
# Java VM: OpenJDK 64-Bit Server VM AdoptOpenJDK (14+36, mixed mode, sharing, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C [jacob-1.16-M1-x64.dll+0x12ca1]

Could the jacob-dll files be updated to Jacob 1.19?
I guess and hope that would solve this issue...

Regards,
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 673
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Re: Servoy COM plugin and Java 14

Postby lwjwillemsen » Wed Apr 22, 2020 7:26 pm

Maybe anyone from the COM plugin product owners can comment on this?
Thanks in advance...
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 673
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Re: Servoy COM plugin and Java 14

Postby sbutler » Thu Apr 23, 2020 6:04 pm

Hi Lambert. The COM plugin is a wrapper around the open source Jacob COM libraries. So for things like this you would probably get better answers on their support forum at https://sourceforge.net/projects/jacob-project/support

I haven't personally tried that version of openjdk with Jacob, but I do see they have some updated versions of Jacob, 1.19 it looks like. If their support tells you an update is needed, let me know and we will add it to our list. The COM plugin currently uses 1.16-M1
Scott Butler
iTech Professionals, Inc.
SAN Partner

Servoy Consulting & Development
Servoy University- Training Videos
Servoy Components- Plugins, Beans, and Web Components
Servoy Guy- Tips & Resources
ServoyForge- Open Source Components
User avatar
sbutler
Servoy Expert
 
Posts: 728
Joined: Sun Jan 08, 2006 7:15 am
Location: Cincinnati, OH

Re: Servoy COM plugin and Java 14

Postby lwjwillemsen » Fri Apr 24, 2020 2:31 pm

Hi Scott, thanks for your reaction.
I am 'just' a thankful user of the COM plugin with no knowledge of the Jacob project.
I don't know if an update to 1.19 would solve the exception but I would be grateful if someone could investigate...
Besides that it's quite common in the plugin "business" to update dependencies from time to time to keep up with bug fixes, security, os, java, etc.

Regards,
Lambert Willemsen
Vision Development BV
lwjwillemsen
 
Posts: 673
Joined: Sat Mar 14, 2009 5:39 pm
Location: The Netherlands

Re: Servoy COM plugin and Java 14

Postby sbutler » Fri Apr 24, 2020 2:50 pm

The COM plugin is an open source project and free to use. To keep it that way, it requires involvement from users like you. If that doesn't sound like something you want to do, please consider financially supporting the plugin by purchasing some time from one of the developers. I created the plugin, but others have contributed to it, like Patrick Talbot. Feel free to reach out to Patrick or myself directly for information on how to get paid commercial support for the plugin.
Scott Butler
iTech Professionals, Inc.
SAN Partner

Servoy Consulting & Development
Servoy University- Training Videos
Servoy Components- Plugins, Beans, and Web Components
Servoy Guy- Tips & Resources
ServoyForge- Open Source Components
User avatar
sbutler
Servoy Expert
 
Posts: 728
Joined: Sun Jan 08, 2006 7:15 am
Location: Cincinnati, OH


Return to Plugins and Beans

Who is online

Users browsing this forum: No registered users and 2 guests