Servoy Developer 20203.1_LTS deployment problem

Questions and answers on developing, deploying and using plugins and JavaBeans

Servoy Developer 20203.1_LTS deployment problem

Postby huber » Tue Aug 11, 2020 2:13 pm

Hi

After upgrading the plugins as recommended by Patrick, see this thread:

Code: Select all
https://forum.servoy.com/viewtopic.php?p=121372#p121372


We get after deploying on a Windows Server 2019 Standard the following error when starting the deployed application:

but the commons-compress-1.20.jar – as all other jars – were successfully signed, as seen here:

Code: Select all
/Applications/Servoy.app/Contents/application_server/plugins/poi/commons-compress-1.20.jar start processing
/Applications/Servoy.app/Contents/application_server/plugins/poi/commons-compress-1.20.jar repacked
/Applications/Servoy.app/Contents/application_server/plugins/poi/commons-compress-1.20.jar first sign attempt
/Applications/Servoy.app/Contents/application_server/plugins/poi/commons-compress-1.20.jar repacked
/Applications/Servoy.app/Contents/application_server/plugins/poi/commons-compress-1.20.jar second sign attempt
/Applications/Servoy.app/Contents/application_server/plugins/poi/commons-compress-1.20.jar signed
Jar file size: 652Kb
Process time: 1110ms


We ran out of ideas about debugging the deployment error.

Best regards,
Attachments
Screenshot 2020-08-11 at 14.02.06.png
Screenshot 2020-08-11 at 14.02.06.png (276.21 KiB) Viewed 1337 times
Robert Huber
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
huber
 
Posts: 405
Joined: Mon May 14, 2012 11:31 pm

Re: Servoy Developer 20203.1_LTS deployment problem

Postby rieder » Wed Aug 12, 2020 8:30 am

Any ideas? We never had problems with successfully signed libraries so far. A hint would be appropriated a lot!

Thanks and regards
Birgit
Birgit Rieder
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
rieder
 
Posts: 141
Joined: Thu Jan 26, 2012 5:18 pm

Re: Servoy Developer 20203.1_LTS deployment problem

Postby jcompagner » Wed Aug 12, 2020 9:53 am

even if after signing you flush the client cache?

if you download that jar yourself (from the url given) and then do "jarsigner -verify commons-compress-1.20.jar" does it verify?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8460
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy Developer 20203.1_LTS deployment problem

Postby rieder » Wed Aug 12, 2020 10:11 am

Hi Johan

Thank you for the reply!

I did download the jar from the server. Since I do only have JRE installed on the test client, I did copy the file to my computer and did run the verify. Answer: "jar is unsigned"- However this is possible, we now know, where to focus on.

Best regards
Birgit
Birgit Rieder
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
rieder
 
Posts: 141
Joined: Thu Jan 26, 2012 5:18 pm

Re: Servoy Developer 20203.1_LTS deployment problem

Postby ROCLASI » Wed Aug 12, 2020 10:57 am

Hi Birgit,

Have you tried killing the server cache (<tomcathome>/work/Catalina/localhost/) ?
And just to rule out all the possibilities, perhaps for some odd reason the jar wasn't signed correctly. Can you verify the original jar (the one in your development environment) as well?
Robert Ivens
SAN Developer / Servoy Valued Professional / Servoy Certified Developer

ROCLASI Software Solutions / JBS Group, Partner
Twitter: @roclasi
--
ServoyForge - Building Open Source Software.
PostgreSQL - The world's most advanced open source database.
User avatar
ROCLASI
Servoy Expert
 
Posts: 5389
Joined: Thu Oct 02, 2003 9:49 am
Location: Netherlands/Belgium

Re: Servoy Developer 20203.1_LTS deployment problem

Postby rieder » Wed Aug 12, 2020 2:00 pm

Hello Robert

Thank you for the answer!
I just checked, yes, development jars (where the context (WAR) file is exported from) are verified.
We are about to look for a caching problem.

Best regards
Birgit
Birgit Rieder
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
rieder
 
Posts: 141
Joined: Thu Jan 26, 2012 5:18 pm

Re: Servoy Developer 20203.1_LTS deployment problem

Postby rieder » Wed Aug 12, 2020 4:20 pm

Hello Robert and Johan

We solved it by clearing Java Resources Cache.
Thank you again for helping us!

Best regards
Birgit
Birgit Rieder
7r AG, Switzerland
SAN Developer
http://www.seven-r.ch
User avatar
rieder
 
Posts: 141
Joined: Thu Jan 26, 2012 5:18 pm


Return to Plugins and Beans

Who is online

Users browsing this forum: No registered users and 6 guests