Servoy 2019.12.1

Servoy announcements

Servoy 2019.12.1

Postby jcompagner » Wed Jan 22, 2020 11:06 pm

We are pleased to announce the availability of Servoy 2019.12.1 (release number 3543)

This is a quick release for the SmartClient problems with the new Oracle Java 8_241.
There are a few more fixes also a release will be done shortly for the NGGrid.

This version is available through the the download site
We ship from now on by default only archive installers, so for windows a zip file and for osx/linux tar files.
That people can just extract and run. For OSX you need to make sure you follow a few steps (run firstuse.command first and then allow the app to run)

The full installers/archives are only for new installs, never use that to update/overwrite an existing install, existing installations should always be updated through the "check for updates".
This release can be updated by using the "latest" url: http://download.servoy.com/developer/latest/ (when you come from 2019.03 or higher)
If you install a clean install besides the current one which is 2019.06 or lower, be aware that the workspace will be upgraded and it is not recommended to use an upgraded workspace with an older release again.
This release is build on the same Eclipse base because of some issues, so the workspace is not upgraded if you come from 2019.09.

If check for updates says there are no updates, then it could be a caching problem of eclipse, please restart the developer once and try again.

We now ship a java with our installation (Java 13.0.1). So there doesn't need to be a java installed on the system anymore.
Also with a next update, we can update the java version with it so no need to keep it up to date yourself anymore.

The update site can't be used to upgrade from 84 to this release, a bug in the eclipse update mechanisme will result in a broken installation.
So a clean install needs to be done if you come from 84 (but you can reuse the existing workspace just fine)

This is a release in our quarterly release cycle, if you want to stay on the LTS path you need to stick to 2019.03.1 and enabled only the lts update site.

For more information for the 2019.12 release check: Whats new

and the full list of cases

If you do update then it could be that there is a left over driver in the drivers dir that has 0 bytes. Make sure you delete that one, and if you make war exports from this make sure you don't include this 0 byte driver jar. That will result in errors when deploying.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8461
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 2019.12.1

Postby rafig » Thu Jan 23, 2020 6:12 pm

Hi
firstly, congrats on the new release.
I was about to post this 'issue' in the previous thread, but then I thought I'd check to see if it happened with this release.
I downloaded the 'Mac' Jar installer and ran it like I always have in the past, let it do the new 'Default Install' in a new directory in my Applications folder, then let it launch.
It then asked about creating database (with or without samples), I chose with, but the Postgres server & databases DO NOT get installed or created.
When I looked in the application_server/postgres_db folder, it appeared as if the install script (.sh) was still in there along with the tar.gz file etc., so the expansion & install of PG had not happened, even though I asked it to do it. If I quit Developer & re-opened it, the same question would appear, I'd say 'install (samples)' but it still wouldn't happen.
I then fired up Terminal & tried to run it manually, like this
Code: Select all
Rafi:postgres_db rafig$ /Applications/Servoy_2019_12_bss/application_server/postgres_db/install_postgres.sh
rmdir: illegal option -- -
usage: rmdir [-p] directory ...
The files belonging to this database system will be owned by user "rafig".
This user must also own the server process.

The database cluster will be initialized with locale "en_GB.UTF-8".
The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory ../database ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
selecting dynamic shared memory implementation ... posix
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... ok
syncing data to disk ... ok

WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.

Success. You can now start the database server using:

    bin/pg_ctl -D ../database -l logfile start

waiting for server to start.... done
server started
waiting for server to shut down.... done
server stopped

BUT, when I now launch Developer, Postgres does not start & I get this in the log file
Code: Select all
2020-01-23 15:56:45,224 ERROR [pool-3-thread-1] com.servoy.j2db.util.Debug - Cannot run program "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server//postgres_db/bin/pg_ctl" (in directory "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server"): error=0, posix_spawn failed [ ]
java.io.IOException: Cannot run program "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server//postgres_db/bin/pg_ctl" (in directory "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server"): error=0, posix_spawn failed
   at java.lang.ProcessBuilder.start(Unknown Source) ~[?:?]
   at java.lang.ProcessBuilder.start(Unknown Source) ~[?:?]
   at java.lang.Runtime.exec(Unknown Source) ~[?:?]
   at com.servoy.j2db.server.main.Zl.run(Zl.java:3) [j2db_server_2019.12.1.3543.jar:?]
   at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:?]
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:?]
   at java.lang.Thread.run(Unknown Source) [?:?]
Caused by: java.io.IOException: error=0, posix_spawn failed
   at java.lang.ProcessImpl.forkAndExec(Native Method) ~[?:?]
   at java.lang.ProcessImpl.<init>(Unknown Source) ~[?:?]
   at java.lang.ProcessImpl.start(Unknown Source) ~[?:?]
   ... 7 more
2020-01-23 15:56:59,369 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server repository_server in 1 times [ ]
2020-01-23 15:56:59,371 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server bug_db in 1 times [ ]
2020-01-23 15:56:59,375 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server example_data in 1 times [ ]
2020-01-23 15:56:59,377 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server log_data in 1 times [ ]
2020-01-23 15:56:59,379 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server pdf_forms in 1 times [ ]
2020-01-23 15:56:59,381 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server udm in 1 times [ ]
2020-01-23 15:56:59,383 ERROR [Worker-3: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server user_data in 1 times [ ]
2020-01-23 15:57:31,996 ERROR [Framework stop] com.servoy.j2db.util.Debug - Cannot run program "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server//postgres_db/bin/pg_ctl" (in directory "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server"): error=0, posix_spawn failed [ ]
java.io.IOException: Cannot run program "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server//postgres_db/bin/pg_ctl" (in directory "/Applications/Servoy_2019_12_bss/Eclipse.app/Contents/Eclipse/../../../application_server"): error=0, posix_spawn failed
   at java.lang.ProcessBuilder.start(Unknown Source) ~[?:?]
   at java.lang.ProcessBuilder.start(Unknown Source) ~[?:?]
   at java.lang.Runtime.exec(Unknown Source) ~[?:?]
   at com.servoy.j2db.server.main.ApplicationServer.doNativeShutdown(ApplicationServer.java:494) [j2db_server_2019.12.1.3543.jar:?]
   at com.servoy.j2db.server.main.ApplicationServer.doNativeShutdown(ApplicationServer.java:733) [j2db_server_2019.12.1.3543.jar:?]
   at com.servoy.eclipse.core.Activator.stop(Activator.java:639) [com.servoy.eclipse.core_2019.12.1.3543.jar:?]
   at org.eclipse.osgi.internal.framework.BundleContextImpl$4.run(BundleContextImpl.java:899) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.internal.framework.BundleContextImpl$4.run(BundleContextImpl.java:1) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at java.security.AccessController.doPrivileged(Unknown Source) [?:?]
   at org.eclipse.osgi.internal.framework.BundleContextImpl.stop(BundleContextImpl.java:891) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.internal.framework.EquinoxBundle.stopWorker0(EquinoxBundle.java:1027) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.stopWorker(EquinoxBundle.java:370) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.Module.doStop(Module.java:653) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.Module.stop(Module.java:515) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.decStartLevel(ModuleContainer.java:1861) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1753) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.SystemModule.stopWorker(SystemModule.java:275) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule.stopWorker(EquinoxBundle.java:202) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.Module.doStop(Module.java:653) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.Module.stop(Module.java:515) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:207) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:220) [org.eclipse.osgi_3.14.0.v20190517-1309.jar:?]
   at java.lang.Thread.run(Unknown Source) [?:?]
Caused by: java.io.IOException: error=0, posix_spawn failed
   at java.lang.ProcessImpl.forkAndExec(Native Method) ~[?:?]
   at java.lang.ProcessImpl.<init>(Unknown Source) ~[?:?]
   at java.lang.ProcessImpl.start(Unknown Source) ~[?:?]
   ... 23 more

It's a bit frustrating as I was hoping to start off a new project with it, but luckily I can get by using a Mac app called 'postgres.app' that acts as a standalone Postgres DB Server.
I hope you can fix this, or tell me what is wrong (the 2019.09 install worked fine)
[I am currently on macOS Mojave 10.14.6, with Java 8 Update 231, but am attaching the Installation details, Error Log & Servoy log as a zip]
You do not have the required permissions to view the files attached to this post.
Servoy Certified Developer
Image
rafig
 
Posts: 617
Joined: Mon Dec 22, 2003 12:58 pm
Location: Watford, UK

Re: Servoy 2019.12.1

Postby rafig » Thu Jan 23, 2020 6:28 pm

Just to add to above, I tried both the default & the custom install, with making sure I set to install basic PG server on the custom install etc.
I also just tried a restart after updating to the newest Java & installing again (after un-installing)
Still no go...
Servoy Certified Developer
Image
rafig
 
Posts: 617
Joined: Mon Dec 22, 2003 12:58 pm
Location: Watford, UK

Re: Servoy 2019.12.1

Postby jcompagner » Thu Jan 23, 2020 7:15 pm

the download url on our site should be fixed
instead of the installer you should get a "tar.gz" file that you extract
and then don't forget to run "firstuse.command" else it won't work

Apple makes it harder and harder to install software and run it, even you as a user just know what you are doing.

We are investigating to sign and notarize a "pkg" installer that installs a signed app. Hopefully we have a thing working for 2020.03, problem is you can't do this on linux build servers, you need mac servers for this to do, which is highly annoying.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8461
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 2019.12.1

Postby rafig » Thu Jan 23, 2020 7:33 pm

jcompagner wrote:the download url on our site should be fixed
instead of the installer you should get a "tar.gz" file that you extract
and then don't forget to run "firstuse.command" else it won't work

Apple makes it harder and harder to install software and run it, even you as a user just know what you are doing.

We are investigating to sign and notarize a "pkg" installer that installs a signed app. Hopefully we have a thing working for 2020.03, problem is you can't do this on linux build servers, you need mac servers for this to do, which is highly annoying.

Thanks Johan, that fixed it all! (I was obviously just too quick & keen to install it ;-) )
It would be great if you could create an 'installer' that worked (I'm pretty sure Servoy can afford to buy a Mac Server ;-) )
Thanks
Rafi
Servoy Certified Developer
Image
rafig
 
Posts: 617
Joined: Mon Dec 22, 2003 12:58 pm
Location: Watford, UK

Re: Servoy 2019.12.1

Postby jcompagner » Fri Jan 24, 2020 12:29 pm

just that buying or leasing a "macinthecloud" is not really the problem the real problem is more the setup
We have a build server(i run locally on my windows laptop, or any of our R&D) that just runs scripts to run the build an make installers, then suddenly have a different system do do something else means moving a lot of bytes around to different servers..
Which is just plain annoying, Apple should just accept that stuff are also build on linux (or windows) and provide tooling for that...
But yeah its Apple.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8461
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 2019.12.1

Postby rafig » Fri Jan 24, 2020 12:33 pm

jcompagner wrote:But yeah its Apple.


;-)
Servoy Certified Developer
Image
rafig
 
Posts: 617
Joined: Mon Dec 22, 2003 12:58 pm
Location: Watford, UK

Re: Servoy 2019.12.1

Postby andre1506345542 » Tue Jan 28, 2020 10:00 am

Hi
If I try to upgrade from 2019.09 to 2019.12.1 I get the following errors (see attachment) and upgrading is aborting.
I use the Check for updates.

Please advice
Andre
You do not have the required permissions to view the files attached to this post.
andre1506345542
 
Posts: 39
Joined: Mon Sep 25, 2017 3:19 pm

Re: Servoy 2019.12.1

Postby jcompagner » Tue Jan 28, 2020 10:20 am

I think that's a caching problem somewhere (somewhere from your pc to the final server)

can you remove the update url " http://download.servoy.com/developer/latest/" once from the update sites (in the preferences)
then restart the developer and add it back in and try again?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8461
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Servoy 2019.12.1

Postby andre1506345542 » Tue Jan 28, 2020 11:48 am

Thanks Johan,
It did not work rightaway.
It was complaining about No Repository on http://www.servoy-stuff.net/downloads/developer/updates
After disabling this URL the update worked.
Best regards
Andre
andre1506345542
 
Posts: 39
Joined: Mon Sep 25, 2017 3:19 pm

Re: Servoy 2019.12.1

Postby jcompagner » Thu Jan 30, 2020 11:20 am

we lost some post because we needed to restore a backup
So if there are still problems with running beans on the smart client we need more info of all the java versions server and client side and which combination breaks stuff.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8461
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet


Return to Announcements

Who is online

Users browsing this forum: No registered users and 2 guests