plugin working in developer, but not in server

Questions, tips and tricks and techniques for scripting in Servoy

plugin working in developer, but not in server

Postby Hans Nieuwenhuis » Sat Feb 25, 2012 5:40 pm

Hi,

I already created a ticket at It2Be, but maybe the problem is more a "server setup" issue, I don't know ( I am not an application server specialist....)

I use the exchange plugin from It2Be for exchange2010, works excellent in servoy developer (5.2.11).
But when I run the same solution from servoy server ( same installation, so same database servers, properties file, database date, same verything...)
then I can not connect to the exchange server.
The connection between the plugin and the exchange server is ssl ( webservice ).

Should I configure something extra in servoy server ??

Regards,
Hans Nieuwenhuis
Betagraphics
http://www.deltics.nl
http://www.betagraphics.nl

Servoy Version 7.3.1
Java version 1.7.0.x
Database Oracle 11g
User avatar
Hans Nieuwenhuis
 
Posts: 1026
Joined: Thu Apr 12, 2007 12:36 pm
Location: Hengelo, The Netherlands

Re: plugin working in developer, but not in server

Postby Hans Nieuwenhuis » Fri Mar 02, 2012 9:45 am

Found the cause of this problem.

The server could not write back to the keystore.
The path for the keystore defined in the solutuion seems to work only in developer.

solution is to add
Code: Select all
-Djavax.net.ssl.trustStore=C:\keys\keystore2.jks
to the servoy_server.bat file

Regards,
Hans Nieuwenhuis
Betagraphics
http://www.deltics.nl
http://www.betagraphics.nl

Servoy Version 7.3.1
Java version 1.7.0.x
Database Oracle 11g
User avatar
Hans Nieuwenhuis
 
Posts: 1026
Joined: Thu Apr 12, 2007 12:36 pm
Location: Hengelo, The Netherlands


Return to Methods

Who is online

Users browsing this forum: No registered users and 2 guests

cron