Page 1 of 1

Issue with date time in cloud development

PostPosted: Wed Aug 10, 2022 1:13 pm
by patrick1645350822
Hi,

I just found something strange in my cloud develop environment.

When I look in my local environment I use date/time fields:
loc-grid.jpg
loc-grid.jpg (22.96 KiB) Viewed 935 times

loc-edit.png
loc-edit.png (46.55 KiB) Viewed 935 times


But when I look in my cloud development environment (of Servoy) I do not see the time?
dev-grid.jpg
dev-grid.jpg (24.5 KiB) Viewed 935 times

Re: Issue with date time in cloud development

PostPosted: Wed Aug 10, 2022 1:13 pm
by patrick1645350822
dev_edit.jpg
dev_edit.jpg (59.06 KiB) Viewed 934 times


Any ideas?

Re: Issue with date time in cloud development

PostPosted: Wed Aug 10, 2022 1:24 pm
by jcompagner
what kind of format did you set on those fields?
If you dont set anything that it fully depends on what is set by default in the system (or maybe admin page)

Re: Issue with date time in cloud development

PostPosted: Wed Aug 10, 2022 1:24 pm
by jcompagner
what kind of format did you set on those fields?
If you dont set anything that it fully depends on what is set by default in the system (or maybe admin page)

Re: Issue with date time in cloud development

PostPosted: Wed Aug 10, 2022 2:58 pm
by vhofstede
Hi Patrick!

I quickly checked your properties of the cloud environment and there is a property dateFormat. It is currently:
locale.dateformat=dd-MM-yyyy

The properties like this are set for the cloud through a file in your workspace in the jenkins-custom folder. This should contain the properties file where this line is in. You can change it here (or remove the line), commit it and then the dateFormat should be reflected after the next build.

Hope that clears it up