Client not launching

Questions, answers, tips and ideas on Servoy Client

Client not launching

Postby Harry Catharell » Wed Jun 02, 2010 2:24 pm

Client - OS X
Server - Servoy v3.5.10 build 524

Client has just informed me that servoy client will not now launch on powerbook on which it worked fine up to 10 days ago

Nothing has changed on powerbook

Powerbook is running on wifi connection and so is an iMac on same desk which opens client without problem

server log shows following error

Anybody shed any light on this please ?

Code: Select all
2010-06-02 13:11    SocketAccepter[0]    ERROR    com.servoy.j2db.util.Debug    SocketAcceptor failure for socket: 1f07d10[SSL_NULL_WITH_NULL_NULL: Socket[addr=/79.123.77.254,port=50013,localport=1099]]
javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
     at com.sun.net.ssl.internal.ssl.InputRecord.handleUnknownRecord(Unknown Source)
     at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)
     at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(Unknown Source)
     at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
     at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readDataRecord(Unknown Source)
     at com.sun.net.ssl.internal.ssl.AppInputStream.read(Unknown Source)
     at java.io.BufferedInputStream.fill(Unknown Source)
     at java.io.BufferedInputStream.read(Unknown Source)
     at com.servoy.j2db.util.rmi.compressing.l.a(Unknown Source)
     at com.servoy.j2db.util.rmi.compressing.l.read(Unknown Source)
     at java.io.DataInputStream.readInt(Unknown Source)
     at com.servoy.j2db.util.rmi.d$b.run(Unknown Source)
     at com.servoy.j2db.util.as.run(Unknown Source)
     at java.lang.Thread.run(Unknown Source)
2010-06-02 13:11    SocketAccepter[1]    ERROR    com.servoy.j2db.util.Debug    SocketAcceptor failure for socket: 1cf229f[SSL_NULL_WITH_NULL_NULL: Socket[addr=/79.123.77.254,port=50012,localport=1099]]
javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
     at com.sun.net.ssl.internal.ssl.InputRecord.handleUnknownRecord(Unknown Source)
     at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)
     at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(Unknown Source)
     at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
     at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readDataRecord(Unknown Source)
     at com.sun.net.ssl.internal.ssl.AppInputStream.read(Unknown Source)
     at java.io.BufferedInputStream.fill(Unknown Source)
     at java.io.BufferedInputStream.read(Unknown Source)
     at com.servoy.j2db.util.rmi.compressing.l.a(Unknown Source)
     at com.servoy.j2db.util.rmi.compressing.l.read(Unknown Source)
     at java.io.DataInputStream.readInt(Unknown Source)
     at com.servoy.j2db.util.rmi.d$b.run(Unknown Source)
     at com.servoy.j2db.util.as.run(Unknown Source)
     at java.lang.Thread.run(Unknown Source)


Cheers
Harry
Harry Catharell
 
Posts: 812
Joined: Fri Sep 26, 2003 10:23 am
Location: Milton Keynes, England

Re: Client not launching

Postby jcompagner » Wed Jun 02, 2010 2:27 pm

and it is correct that it should be an SSL connection?

Because that client connects to the server and reports that a plain text so a none ssl connection seems to be created and the client expect a ssl connection.

Are you sure that there isnt anything in between the client and the server? like a proxy or firewall that is suddenly blocking port 1099?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8250
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Client not launching

Postby Harry Catharell » Wed Jun 02, 2010 2:36 pm

the server has been in place and continuously up for nearly 200 days without issue

the server shows SSL is active but that it is using default testkeys

This setting has been there since server installed - I believe that it is the default install setting

the client has an iMac in the same place using the same network connection as the powerbook and it can connect without a problem

Cheers
Harry
Harry Catharell
 
Posts: 812
Joined: Fri Sep 26, 2003 10:23 am
Location: Milton Keynes, England

Re: Client not launching

Postby Harry Catharell » Wed Jun 02, 2010 4:58 pm

Hi,

Sorry to bump this so quickly

As is normal with clients, I have someone leaving for Russia tomorrow with the powerbook in tow and wishing to use it whilst away :-)

Should I be turning off SSL at the server here or is there some way to refresh the SSL message from the client ?

Cheers
Harry
Harry Catharell
 
Posts: 812
Joined: Fri Sep 26, 2003 10:23 am
Location: Milton Keynes, England

Re: Client not launching

Postby jcompagner » Wed Jun 02, 2010 5:28 pm

no the problem is that the client wants to connect with ssl but it doesnt get a ssl connection back
empty the cache en the servoy folder on that mac and try again.

Else what you could do is use telnet and telnet to that server on that rmi port that is used (1099)
and see what kind of connection you get (but this is very technical)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8250
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Client not launching

Postby Harry Catharell » Wed Jun 02, 2010 5:55 pm

Sorry but which servoy folder ?

I have previously gone through java preferences application and deleted the cache files for any servoy client in there

Or is there something else to look for ?

Harry
Harry Catharell
 
Posts: 812
Joined: Fri Sep 26, 2003 10:23 am
Location: Milton Keynes, England

Re: Client not launching

Postby jcompagner » Wed Jun 02, 2010 11:24 pm

in your home dir of the user
under windows c:\users\username
(dont know the exact dir on the mac)

there is a .servoy file (its starts with a . so it is not visible at default) Delete that dir.
If that doesnt fix it also then there is something in between the client and the server.. That doesnt talk SSL.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8250
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Client not launching

Postby Harry Catharell » Thu Jul 01, 2010 11:40 am

Tried everything that I can but client will still not launch
Finally got to site and I turned on Java console when launching the client and the following log was generated:
Code: Select all
Using JRE version 1.6.0_20-b02-279-10M3065 Java HotSpot(TM) 64-Bit Server VM
User home directory = /Users/xxxxx
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
0-5: set trace level to <n>
----------------------------------------------------
java.net.UnknownHostException: wpad
   at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
   at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:432)
   at java.net.Socket.connect(Socket.java:529)
   at java.net.Socket.connect(Socket.java:478)
   at sun.net.NetworkClient.doConnect(NetworkClient.java:163)
   at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
   at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
   at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
   at sun.net.www.http.HttpClient.New(HttpClient.java:306)
   at sun.net.www.http.HttpClient.New(HttpClient.java:323)
   at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:860)
   at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:839)
   at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:726)
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1049)
   at com.sun.deploy.net.proxy.AbstractAutoProxyHandler.getJSFileFromURL(AbstractAutoProxyHandler.java:296)
   at com.sun.deploy.net.proxy.AbstractAutoProxyHandler.init(AbstractAutoProxyHandler.java:154)
   at com.sun.deploy.net.proxy.DynamicProxyManager.reset(DynamicProxyManager.java:336)
   at com.sun.deploy.net.proxy.DeployProxySelector.reset(DeployProxySelector.java:60)
   at com.sun.javaws.Main.initializeExecutionEnvironment(Main.java:1153)
   at com.sun.javaws.Main.continueInSecureThread(Main.java:202)
   at com.sun.javaws.Main$1.run(Main.java:115)
   at java.lang.Thread.run(Thread.java:637)
Could not launch from cache. Will try online mode. [Some of required resources are not cached.]
Jun 30, 2010 6:19:57 PM com.servoy.j2db.util.Debug log
INFO: Starting Servoy from /Users/xxxxx
Jun 30, 2010 6:19:57 PM com.servoy.j2db.util.Debug log
INFO: Servoy 3.5.12 build-526 on Mac OS X using Java 1.6.0_20
Jun 30, 2010 6:19:58 PM com.servoy.j2db.util.Debug error
SEVERE: Throwable
java.net.SocketException: factory already defined
   at java.rmi.server.RMISocketFactory.setSocketFactory(RMISocketFactory.java:94)
   at com.servoy.j2db.J2DBClient.a(Unknown Source)
   at com.servoy.j2db.J2DBClient.v(Unknown Source)
   at com.servoy.j2db.J2DBClient.a(Unknown Source)
   at com.servoy.j2db.J2DBClient.main(Unknown Source)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at com.sun.javaws.Launcher.executeApplication(Launcher.java:1812)
   at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1750)
   at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1532)
   at com.sun.javaws.Launcher.run(Launcher.java:135)
   at java.lang.Thread.run(Thread.java:637)
Jun 30, 2010 6:19:58 PM com.servoy.j2db.util.Debug error
SEVERE: Already factory registered com.sun.deploy.net.protocol.rmi.DeployRMISocketFactory
Jun 30, 2010 6:19:59 PM com.servoy.j2db.util.Debug error
SEVERE: Error getting the service servoy.IRepository from host xxx.xxx.xxx.xxx:1099
java.rmi.ConnectIOException: non-JRMP server at remote endpoint
   at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:230)
   at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:184)
   at sun.rmi.server.UnicastRef.newCall(UnicastRef.java:322)
   at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
   at java.rmi.Naming.lookup(Naming.java:84)
   at com.servoy.j2db.J2DBClient.getServerService(Unknown Source)
   at com.servoy.j2db.J2DBClient.goto(Unknown Source)
   at com.servoy.j2db.ClientState.dataBaseInit(Unknown Source)
   at com.servoy.j2db.J2DBClient.dataBaseInit(Unknown Source)
   at com.servoy.j2db.J2DBClient.a(Unknown Source)
   at com.servoy.j2db.J2DBClient.main(Unknown Source)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at com.sun.javaws.Launcher.executeApplication(Launcher.java:1812)
   at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1750)
   at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1532)
   at com.sun.javaws.Launcher.run(Launcher.java:135)
   at java.lang.Thread.run(Thread.java:637)
Jun 30, 2010 6:19:59 PM com.servoy.j2db.util.Debug error
SEVERE: Error getting the service servoy.IDataServer from host xxx.xxx.xxx.xxx:1099
java.rmi.ConnectIOException: non-JRMP server at remote endpoint
   at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:230)
   at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:184)
   at sun.rmi.server.UnicastRef.newCall(UnicastRef.java:322)
   at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
   at java.rmi.Naming.lookup(Naming.java:84)
   at com.servoy.j2db.J2DBClient.getServerService(Unknown Source)
   at com.servoy.j2db.J2DBClient.e(Unknown Source)
   at com.servoy.j2db.ClientState.new(Unknown Source)
   at com.servoy.j2db.J2DBClient.new(Unknown Source)
   at com.servoy.j2db.J2DBClient.a(Unknown Source)
   at com.servoy.j2db.J2DBClient.main(Unknown Source)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at com.sun.javaws.Launcher.executeApplication(Launcher.java:1812)
   at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1750)
   at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1532)
   at com.sun.javaws.Launcher.run(Launcher.java:135)
   at java.lang.Thread.run(Thread.java:637)
Jun 30, 2010 6:20:03 PM com.servoy.j2db.util.Debug error
SEVERE: Fatal Exception
Jun 30, 2010 6:20:03 PM com.servoy.j2db.util.Debug error
SEVERE: Throwable
java.lang.NullPointerException
   at com.servoy.j2db.ClientState.a(Unknown Source)
   at com.servoy.j2db.J2DBClient.a(Unknown Source)
   at com.servoy.j2db.ClientState.new(Unknown Source)
   at com.servoy.j2db.J2DBClient.new(Unknown Source)
   at com.servoy.j2db.J2DBClient.a(Unknown Source)
   at com.servoy.j2db.J2DBClient.main(Unknown Source)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at com.sun.javaws.Launcher.executeApplication(Launcher.java:1812)
   at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1750)
   at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1532)
   at com.sun.javaws.Launcher.run(Launcher.java:135)
   at java.lang.Thread.run(Thread.java:637)


There are obvious errors in there and I wonder if they mean anything to anyone
The launch process gets to a point where the client window will open but the status bar remains showing 'Start Repository' and gets no further
I attached my MBP to the network and client launched first time so the problem is specific to this machine

Cheers
Harry
Harry Catharell
 
Posts: 812
Joined: Fri Sep 26, 2003 10:23 am
Location: Milton Keynes, England

Re: Client not launching

Postby Harjo » Thu Jul 01, 2010 11:44 am

java.net.UnknownHostException: wpad

means it tries to connect trough a proxy, so look if java is on: direct connection!

also check if under network settings, that the network is not trying to connect trough proxy
Schermafbeelding 2010-07-01 om 11.42.54.png
Schermafbeelding 2010-07-01 om 11.42.54.png (118.31 KiB) Viewed 4528 times
Harjo Kompagnie
Direct ICT / Servoy Hosting / ServoyCamp
Servoy Certified Developer
Servoy Valued Professional
SAN Developer
User avatar
Harjo
 
Posts: 4307
Joined: Fri Apr 25, 2003 11:42 pm
Location: DEN HAM OV, The Netherlands

Re: Client not launching

Postby Harry Catharell » Thu Jul 01, 2010 11:56 am

Thanks Harjo

I'll ask the client to check these settings

Cheers
Harry
Harry Catharell
 
Posts: 812
Joined: Fri Sep 26, 2003 10:23 am
Location: Milton Keynes, England

Re: Client not launching

Postby Robert Huber » Thu Jul 01, 2010 12:26 pm

Hi Harry

Just read your thread and I am not sure if your problem is the same as I have? Do you get a similar error message when trying to start the client with Web Start as I do?

Please see here:
viewtopic.php?f=8&t=14420&p=76257#p76257

Thanks and regards, Robert
Robert Huber
7r gmbh, Switzerland
SAN Developer
www.seven-r.ch
User avatar
Robert Huber
 
Posts: 1239
Joined: Tue Aug 23, 2005 6:52 pm
Location: Schaffhausen, Switzerland

Re: Client not launching

Postby jcompagner » Mon Jul 05, 2010 10:22 am

if you get this:

Jun 30, 2010 6:19:58 PM com.servoy.j2db.util.Debug error
SEVERE: Already factory registered com.sun.deploy.net.protocol.rmi.DeployRMISocketFactory


then there are 2 choices

1> go to the java preferences and make sure the checkbox "use direct connection" is selected.

2> use the tunnel, in 5.1 you can select http (default, the same as pre 5.1) or socket mode (which is new and pretty much the same as 2 way )
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8250
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet


Return to Servoy Client

Who is online

Users browsing this forum: No registered users and 1 guest