HTML_AREA broken? (servoy-1.1rc2, java-1.3.1, linux)

Questions, answers, tips and ideas on Servoy Client

HTML_AREA broken? (servoy-1.1rc2, java-1.3.1, linux)

Postby Neale » Wed Jun 18, 2003 10:51 am

With Servoy-1.1rc2 and java-1.3.1 on linux, HTML_AREA isn't workikng for me :-(

If I do a basic form with a large text field (e.g. 4000 chars) it's all fine as a TEXT_AREA but as a HTML_AREA something goes wildly wrong: the short story is that I can step through the records but nothing appears in the fields and there's a bunch of java errors scroll over the xterm from where servoy was started.

Before I go digging up more details: is this a known bug?

Thanks,
Neale.
Neale
 
Posts: 230
Joined: Thu May 15, 2003 6:29 am
Location: Australia

Postby jcompagner » Wed Jun 18, 2003 11:35 pm

please post a portion of the error you see (the top 10 lines)
User avatar
jcompagner
 
Posts: 8346
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Postby Neale » Thu Jun 19, 2003 12:30 am

This is what I get when starting Servoy then switching to the offending form...

Code: Select all
java.lang.NullPointerException
Exception occurred during event dispatching:
java.lang.NullPointerException
        at javax.swing.text.html.StyleSheet.getRule(StyleSheet.java:166)
        at javax.swing.text.html.StyleSheet$ViewAttributeSet.<init>(StyleSheet.java:2767)
        at javax.swing.text.html.StyleSheet.getViewAttributes(StyleSheet.java:285)
        at javax.swing.text.html.ParagraphView.setPropertiesFromAttributes(ParagraphView.java:85)
        at javax.swing.text.ParagraphView.<init>(ParagraphView.java:42)
        at javax.swing.text.html.ParagraphView.<init>(ParagraphView.java:40)
        at javax.swing.text.html.HTMLEditorKit$HTMLFactory.create(HTMLEditorKit.java:969)
        at javax.swing.text.View.updateChildren(View.java:995)
        at javax.swing.text.View.removeUpdate(View.java:683)
        at javax.swing.text.View.forwardUpdateToView(View.java:1096)
        at javax.swing.text.View.forwardUpdate(View.java:1069)
        at javax.swing.text.BoxView.forwardUpdate(BoxView.java:172)
        at javax.swing.text.View.removeUpdate(View.java:689)


Hmm... I wonder if my version of Java (1.3.1 on Linux) has problems/whatever in the HTMLEditorKit department?

Thanks,
Neale.
Neale
 
Posts: 230
Joined: Thu May 15, 2003 6:29 am
Location: Australia

Postby Jan Blok » Mon Jun 23, 2003 11:57 am

What content do you set? (how does the html look like?)
We cannot reproduce this problem...
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Postby Neale » Mon Jun 23, 2003 12:53 pm

Nothing too challenging....
Code: Select all
=> SELECT * FROM letter_texts;
letter_textsid | lt_ref |                                            lt_body                                           
----------------+--------+-----------------------------------------------------------------------------------------------
              1 | NTB1   | <paragraph>
  <head>

  </head>
  <body>
    <p>
      Foo 1
    </p>
  </body>
</paragraph>

              2 |        | <paragraph>
  <head>

  </head>
  <body>
    <p>
     
    </p>
  </body>
</paragraph>

(2 rows)


BTW, just to clarify, this problem is observed when running Servoy Developer in "client mode" (is that the correct terminology?).

Any thoughts on if this is likely to be specific to Java 1.3.1?

Thanks,
Neale.
Neale
 
Posts: 230
Joined: Thu May 15, 2003 6:29 am
Location: Australia

Postby Jan Blok » Mon Jun 23, 2003 4:58 pm

I still cannot reproduce the problem, when I fill a html_text area with:
<html>
<head>

</head>
<body>
<p>
Foo 1
</p>
</body>
</html>

It displayed correctly (I tried 1.3.1 and 1.4.1 on windows)
Note: if I use <paragraph> it does not render(display) the html but shows the source, so I changed those tags to <html> and </html>
Jan Blok
Servoy
Jan Blok
 
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam


Return to Servoy Client

Who is online

Users browsing this forum: No registered users and 2 guests

cron