Tomcat 8.5 with Servoy 2022.03.4_LTS

Questions and answers for all installation-related topics for Servoy products

Tomcat 8.5 with Servoy 2022.03.4_LTS

Postby pwasserman » Mon Jun 19, 2023 9:37 pm

Hi

When deploying a servoy WAR file in the ROOT folder under tomcat 8.5 b81. Tomcat reports an deployment error :

19-Jun-2023 14:30:36.842 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployWAR Deploying web application archive [D:\Slingshot\Philip\server\webapps\ROOT.war]

19-Jun-2023 14:30:54.300 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.

19-Jun-2023 14:30:54.388 SEVERE [localhost-startStop-1] org.apache.catalina.core.ContainerBase.addChildInternal ContainerBase.addChild: start:
org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[]]

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.apache.logging.log4j.util.PropertiesUtil

19-Jun-2023 14:30:54.389 SEVERE [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployWAR Error deploying web application archive [D:\Slingshot\Philip\server\webapps\ROOT.war]
java.lang.IllegalStateException: Error starting child

For some reason log4j files shipped with Servoy 2022.03.4_LTS as a problem with tomcat 8.5.

If I try to roll back the log4j jar files to an older version then Servoy has a problem.

Does anyone now how to get around or fix this problem.
pwasserman
 
Posts: 1
Joined: Mon Jun 19, 2023 9:22 pm

Re: Tomcat 8.5 with Servoy 2022.03.4_LTS

Postby jcompagner » Tue Jun 20, 2023 9:08 am

what does the localhost_xxx.log really say? that file under tomcat is a much more important log file then catalina.out

the class it complains about should just be in our log4j.jar
What is the java version that you use to startup tomcat? (but log4j only needs java 8 i think until now)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8846
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron