Locked out of my solution.

Discuss all problems you have with Servoy here. It might help to mention the Servoy version and Operating System version you are using

Locked out of my solution.

Postby DFehrenbach » Thu Dec 18, 2003 3:48 pm

previously posted under General category:

I just loaded R2.0 Beta4 and cannot close a splash screen in a dialog that I used to be able to close on R1.2 Final. The splash screen is displayed from a method set in Solution Settings. Since I can't close the splash screen, I can't get into the Design mode to change the startup solution settings.
To make matters worse, I can't go back to to Release 1.2 ( in my excitement to try out all the cool features in the new beta, I forgot to make a backup of the Servoy folder ), when I try to open the solution under R1.2 Servoy cant find any solutions in the repository because the repository is a newer level than Servoy.

What changed in the beta so that a screen shown in a dialog cannot be closed? Can the Solution settings be some how overridden?
Posts: 252
Joined: Sat Sep 13, 2003 6:48 pm
Location: Cleveland, OH

Postby IT2Be » Thu Dec 18, 2003 4:13 pm

I had a comparable issue with r1.2, at least I had to click the closbox twice.

I solved the issue by opening the splashscreen from a form.method attached to the onLoad event of the first form...

That solved my issue at least. Maybe it works for you too?
Marcel J.G. Trapman (IT2BE)
SAN partner - Freelance Java and Servoy
Servoy Components - IT2BE Plug-ins and Beans for Servoy
ServoyForge - Open Source Components for Servoy
User avatar
Servoy Expert
Posts: 4766
Joined: Tue Oct 14, 2003 7:09 pm
Location: Germany

Postby DFehrenbach » Thu Dec 18, 2003 4:43 pm

Thanks for the advice, but no, that doesn't work. The splash screen stubbornly stays on top, and since it is displayed as a dialog, I can't do anything about it. In fact, I can't even close Developer! I need to abort the application from Windows Task Manager.
Perhaps what is needed is some kind of key sequence that, when held down while the solution is loading, will override any methods that are fired from the solution settings "On Open" method- at least in Developer.
But untill or unless that is implemented - I can't work on my solution! Can anyone from Servoy help me - Please!
Posts: 252
Joined: Sat Sep 13, 2003 6:48 pm
Location: Cleveland, OH

Postby maarten » Thu Dec 18, 2003 4:56 pm

Can you send me your soution?
We'll have a look right away.

BTW: what database are you using?
Maarten Berkenbosch
User avatar
Posts: 797
Joined: Wed Apr 23, 2003 10:52 pm
Location: Amersfoort, Netherlands

Postby Jan Blok » Fri Dec 19, 2003 2:56 pm

Fixed, will be availeble in next beta
Jan Blok
Jan Blok
Posts: 2684
Joined: Mon Jun 23, 2003 11:15 am
Location: Amsterdam

Return to Discuss possible Issues and Bugs

Who is online

Users browsing this forum: No registered users and 2 guests