Unable to launch application after server restart

Questions, answers, tips and ideas on Servoy Client

Unable to launch application after server restart

Postby dpearce » Fri Mar 05, 2010 9:20 pm

I have a number of Windows operators who get repeated problems where Smart Client cannot launch.

If they clear their java Resources file and redownload then it works fine.

The problem is this seems to happen everytime I restart the servoy service on my server.

The solution is using 3.5.10.

Is this a known issue and is there anything that I or they can do to stop it happening. The odd thing is that on 90% of machines it is not a problem.

I am not updating plugins or doing anything other than restarting the servoy service.

Any ideas

David
dpearce
 
Posts: 469
Joined: Sun Dec 03, 2006 11:53 am

Re: Unable to launch application after server restart

Postby jcompagner » Mon Mar 08, 2010 5:13 pm

what is the error when you ask webstart cannot log dialog for its error?
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8270
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Unable to launch application after server restart

Postby dpearce » Wed Mar 10, 2010 2:47 pm

Sorry for the delay.

One user gets this message every time they re-run the desktop icon. they then have to download again and it only works once.

Code: Select all
uld not load file/URL specified: C:\Users\PC User\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\1aca1580-73a59d56

Exception
CouldNotLoadArgumentException[Could no load file/URL specified: C:\Users\PC User\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\1aca1580-73a59d56]
   at com.sun.javaws.Main.launchApp(Unknown Source)
   at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
   at com.sun.javaws.Main$1.run(Unknown Source)
   at java.lang.Thread.run(Uknown Source)


I have asked for the error form the other user who only gets the unable to load after i restart the server service. I think they may be different. This is 3.5.10 hosted on an os X 10.5.8 server.
dpearce
 
Posts: 469
Joined: Sun Dec 03, 2006 11:53 am

Re: Unable to launch application after server restart

Postby jcompagner » Wed Mar 10, 2010 2:53 pm

and is that file: "C:\Users\PC User\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\1aca1580-73a59d56" there?
what is the contents of that file? I guess it should be the jnlp file that you get when you open the link in the browser.

what is the url that you use to start the client? (does it have parameters?)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8270
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Unable to launch application after server restart

Postby dpearce » Tue Mar 16, 2010 5:55 pm

John,

I had this on one of our machines this morning. The directory was the a lot of .idx files. The file servoy was looking for wasnt there.

I just use the standard /servoy-clientservoy_client/Solution.jnlp

there are no parameters.

Could this be the Java cache being full and deleting these files. I have never had this before, but a lot more users are getting it both on my servoy 3.5 solution and on a different 5.1 solution, although hosted on the same server.

David
dpearce
 
Posts: 469
Joined: Sun Dec 03, 2006 11:53 am

Re: Unable to launch application after server restart

Postby jcompagner » Tue Mar 16, 2010 6:20 pm

This really looks like a Java Webstart problem.
We dont really control that shortcut creation. that is something that webstart handles for us.

Will have a look if i can figure out why this is.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8270
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Unable to launch application after server restart

Postby dpearce » Tue Mar 16, 2010 7:33 pm

Johan,

Its odd that it has seemed to start recently, it couldnt be the server side java i wouldnt have thought.

Is putting the downloaded JNLP file on the desktop a good workaround. I must say i dont really understand this stuff, it has always just worked before!

David
dpearce
 
Posts: 469
Joined: Sun Dec 03, 2006 11:53 am

Re: Unable to launch application after server restart

Postby jcompagner » Tue Mar 16, 2010 9:10 pm

what did change?
a java update? u18 did bring a lot of changes (not all that good)
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8270
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Unable to launch application after server restart

Postby dpearce » Tue Mar 16, 2010 9:15 pm

My Server is running:

java.vm.name=Java HotSpot(TM) Server VM
java.version=1.5.0_22
java.vm.info=mixed mode
java.vm.vendor=Apple Inc.

but i suspect this is an issue with the clients. I dont get this on Mac clients.

You may be right about the the update of Java! Myabe the solution is to store the jnlp file on the desktop or a web shortcut to the jnlp.

David
dpearce
 
Posts: 469
Joined: Sun Dec 03, 2006 11:53 am

Re: Unable to launch application after server restart

Postby ngervasi » Wed Mar 24, 2010 2:26 pm

A customer is having the same issue on WinXP, on MacOS they simply get an error saying "cannot connect to data service", here's the win exception:

Code: Select all
Eccezione wrapped:
java.io.FileNotFoundException: C:\Documents and Settings\luca-graziani.LAFORTEZZA\Dati applicazioni\Sun\Java\Deployment\cache\6.0\55\e6e18f7-305124d4 (Impossibile trovare il file specificato)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(Unknown Source)
        at java.io.FileInputStream.<init>(Unknown Source)
        at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
        at com.sun.javaws.Main.launchApp(Unknown Source)
        at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
        at com.sun.javaws.Main$1.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)


The server version is 4.1.5.
I have already created a case in the support system: 281374
ngervasi
 
Posts: 1475
Joined: Tue Dec 21, 2004 12:47 pm
Location: Arezzo, Italy

Re: Unable to launch application after server restart

Postby jcompagner » Wed Mar 24, 2010 2:36 pm

that exception is that the client doesnt start at all.
But what you describe is something that the client is starting but then cant find the server.

those are 2 different things.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8270
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Unable to launch application after server restart

Postby ngervasi » Wed Mar 24, 2010 2:44 pm

jcompagner wrote:that exception is that the client doesnt start at all.
But what you describe is something that the client is starting but then cant find the server.

those are 2 different things.


On WinXP it doesn't start at all and throws out the exception, on MacOS it starts but shows the "cannot find dataservice" error. I'm not sure if it happens only when we update the solution or also when we just restart the server.
ngervasi
 
Posts: 1475
Joined: Tue Dec 21, 2004 12:47 pm
Location: Arezzo, Italy

Re: Unable to launch application after server restart

Postby jcompagner » Wed Mar 24, 2010 2:51 pm

but for xp you have that error because you click on a created shortcut right?

that macosx error is more a wrong network configuration or something, it cant connect to the server.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8270
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Unable to launch application after server restart

Postby ngervasi » Wed Mar 24, 2010 4:06 pm

jcompagner wrote:but for xp you have that error because you click on a created shortcut right?

that macosx error is more a wrong network configuration or something, it cant connect to the server.


Yes, in both OSes they open the client by doublicking the shortcut.
On MacOS if they just reset the java cache, throw away the .servoy folder and redowonload the client it works fine so I'd say it's not a network issue.
I've added all the details to the support case.
ngervasi
 
Posts: 1475
Joined: Tue Dec 21, 2004 12:47 pm
Location: Arezzo, Italy


Return to Servoy Client

Who is online

Users browsing this forum: No registered users and 1 guest

cron