Smart Client disconnects and sort-of crashes

Questions, answers, tips and ideas on Servoy Client

Smart Client disconnects and sort-of crashes

Postby ManChicken » Wed Aug 03, 2011 12:40 am

I've been having an issue with the Servoy Smart Client on Windows 7 Pro x64, both with Servoy version 3.x and now 5.x (which I upgraded to hoping it was version 3 that was screwing up.)

The symptoms are that basically if I leave the Smart Client open on my solution for any length of time, it will eventually disconnect from the server in such a way that it doesn't actually realize it until I try to do something (update a record, change to a new form, etc) at which point I'll get a random error message depending on what I try to do.. if I go to another form I'll get a 'Could not display form' error, or if I try to make a new portal row on a record I'll get "class com.servoy.j2db.dataprocessing.RowManager$RowFireNotifyChange does not match trust level of ..." (and it trails off like that, cut off with the ...) In either case, the smart client then pretty much locks up and stops responding to user input but without actually crashing. Sometimes I can hit the Close button on the solution window and the window will either go white or display the little square Servoy logo in the middle, and if I hit it a second time it will close compeltely. However it then trashes the preferences file, making it 0 bytes, and the next time I launch all my prefs are gone (window size, position, toolbars on/off, etc.)

The odd thing is that when the client dies like this, prior to trying to close it if I login to the Servoy admin server and pull up the client list, it still shows my client as being connected.

And to make it even more fun, this only happens when I'm on the LAN, in the same building with the server! If I use the Smart Client at home on basically an identical setup (Win 7 Pro x64, save Java version, etc) just over the Internet, I can stay connected for days. And that's through a firewall (port 1099 open) whereas on the LAN it's a free-for-all with no restrictions at all.

Any ideas what this is all about or where to start looking? I've lowered the pingDelay to no avail, though it still makes no sense why it would be fine remotely and not in the same building.

Java 6 update 26 (32-bit) on Windows 7 Pro x64 as mentioned.
ManChicken
 
Posts: 34
Joined: Sun Dec 30, 2007 7:07 am

Re: Smart Client disconnects and sort-of crashes

Postby ManChicken » Wed Aug 03, 2011 7:58 pm

Just had it happen again but in a different way.

I left the Servoy client running in the background for some time and went back to it. Everything seemed to be running; I switched forms a few times, did a couple of searches, etc. So I pulled up the record I actually wanted and went to add some more portal rows. As soon as I hit my 'Add' button, I got:

"class "org.mozilla.javascript.NativeJavaArray" does not match trust level of other classes in the sa..."

I tried switching forms to one I know I hadn't gone to this session, and get "Can't setup form: dubs"... yet it drew the form, just with no records. It's like it's still talking to the server but is getting totally screwed up. Yet someone else has the same solution open and it's running fine, so it seems to be client-side and not server-side. There is nothing in the server log with a timestamp that corresponds to this event, at all. The last entries were from 3 hours ago, well before I even got to my workstation and launched the client.
ManChicken
 
Posts: 34
Joined: Sun Dec 30, 2007 7:07 am

Re: Smart Client disconnects and sort-of crashes

Postby jcompagner » Thu Aug 04, 2011 10:25 am

these errors are very weird, don't come from servoy but from webstart..

Somehow it thinks that the classes don't belong to each other, come from different loaders (which is not the case!)

what java version do you use?

Also with those disconnects we have improved that in the latest version of servoy, and also the tunnel (http&socket) version has a better detection of a disconnect, you could trye to use that
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8284
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Smart Client disconnects and sort-of crashes

Postby ManChicken » Thu Aug 04, 2011 6:29 pm

jcompagner wrote:what java version do you use?

On both the client and server side they're both Java 1.6.0_26-b03, though this has been happening for some time under previous versions though I couldn't say all which (still 1.6.0 series though.)

Also with those disconnects we have improved that in the latest version of servoy, and also the tunnel (http&socket) version has a better detection of a disconnect, you could trye to use that

I assume you're talking about version 6 - I'll try to update in the near future and see what happens.
ManChicken
 
Posts: 34
Joined: Sun Dec 30, 2007 7:07 am

Re: Smart Client disconnects and sort-of crashes

Postby jcompagner » Thu Aug 04, 2011 6:43 pm

many of those improvements are also in 5.2 at least until now
So you could try the tunnel mode in Http&Socket
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8284
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Smart Client disconnects and sort-of crashes

Postby ManChicken » Thu Aug 04, 2011 6:49 pm

Oh. I am running 5.2.9. I'll play with the tunnel mode and see if it does anything, thanks.
ManChicken
 
Posts: 34
Joined: Sun Dec 30, 2007 7:07 am

Re: Smart Client disconnects and sort-of crashes

Postby Thomas Parry » Fri Aug 05, 2011 12:31 am

For what it is worth, I have had similar error messages on a laptop: Win 7 pro x64 with 32 bit Java release 1.6_u26, Servoy version 5.2.9, using tunnel/http mode not tunnel http&socket. Postgres standalone DB on same machine.

Scenario: my laptop was connected to a wireless network at home running the servoy app. Then I shut the laptop case (did not shutdown the servoy app) and moved to a hall without any wireless connectivity. Opened the laptop, come out of hibernation and attempt to use the app where we left off. There we have the error message when attempting to save a changed record (any table any record it seems). Datasave is on auto.

My first thought was that it was a programming defect but when I shut down the servoy app then restarted it the lack of connectivity to a network did not appear to affect the startup of the app and it runs fine. Until I take back home and it automatically reconnects to the wireless LAN and I get the same error message. So I have to shut down the app and restart it.

I do not consider it an issue because the workaround is a restart of the app. But it is annoying nonetheless.
I do not have any user message indicating lack of connectivity.

Should I be concerned? Should I change to using a tunnel - http&socket?
Tom Parry
Prospect IT
Java/C++/Servoy/Jasper Reports/Simulation/Service Applications
http://www.prospect-saas.biz
Thomas Parry
 
Posts: 498
Joined: Thu Jan 10, 2008 8:48 pm
Location: Ottawa, Canada

Re: Smart Client disconnects and sort-of crashes

Postby jcompagner » Fri Aug 05, 2011 11:20 am

i dont get it, you say you moved to a hall where you didn't have any network connection
Then servoy can't do anything.. and you also shouldn't be able to restart servoy because it needs a server connection..

But i have our own crm application open all the time, and i move (suspend/hibernate) my laptop from home to the office and visa versa
That works just fine most of the time. There are still some certain combinations that it doesn't work and we are improving that constantly.

The best detection is in the tunnel in http mode. That should be able to detect a faulty connection the fastest.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8284
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Smart Client disconnects and sort-of crashes

Postby Thomas Parry » Mon Aug 08, 2011 2:22 pm

@Johan,
Note that the Servoy app server is on the laptop as well as the Postgres server = all in one. No need for any external network. Works fine if run the client jnlp and the network wireless is disconnected. If I suspend/hibernate with a network connection then move to the hall and open the laptop and come back to the application then it appears to be running but it will fail to save data.

So what I do now is to exit the app, disconnect the network, suspend/hibernate, go to the hall, start up the app again and it works fine.
It seems to want to have a network connection after resuming if it had one before.

Not a big issue, just wanted to know if there was anything to prompt user that Servoy app may not work as expected if the network connectivity has been lost.
Tom Parry
Prospect IT
Java/C++/Servoy/Jasper Reports/Simulation/Service Applications
http://www.prospect-saas.biz
Thomas Parry
 
Posts: 498
Joined: Thu Jan 10, 2008 8:48 pm
Location: Ottawa, Canada

Re: Smart Client disconnects and sort-of crashes

Postby jcompagner » Mon Aug 08, 2011 4:18 pm

ah but that could be a very weird case, because the server gets a new ip!
i guess that screws it up.
Johan Compagner
Servoy
User avatar
jcompagner
 
Posts: 8284
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Smart Client disconnects and sort-of crashes

Postby ManChicken » Tue Aug 16, 2011 12:57 am

Well, going back to my original query, it seems like maybe changing the server method to just 'socket' has solved things for me though I'm not sure I understand why.
ManChicken
 
Posts: 34
Joined: Sun Dec 30, 2007 7:07 am


Return to Servoy Client

Who is online

Users browsing this forum: No registered users and 0 guests