Servoy 8.3.1 and SQL2017 Developer Edition

Q&A regarding installation and issues getting started with Servoy

Servoy 8.3.1 and SQL2017 Developer Edition

Postby dean » Wed Jan 30, 2019 2:46 am

The standard MS SQL driver 4.2 just doesn't work and using the JAR for 8 and 10 still doesn't allow Servoy to access the database.
The error says that a TCP/IP connection can't be initiated over port 1433. Yet SQL Configuration shows TCP/IP active and the system's firewalls are turned off.
Excel and other third party applications can access the SQL server (we used AdventureWorks as a test DB) but Servoy just refuses.
Posts: 1
Joined: Wed Jan 30, 2019 2:42 am

Re: Servoy 8.3.1 and SQL2017 Developer Edition

Postby kwpsd » Wed Jan 30, 2019 7:38 pm

I have not tried connecting to SQL 2017 but will attempt to help.

What are your connection parameters? They should look like the below sample:


URL: jdbc:sqlserver://localhost:1433;DatabaseName=<your_database_name>;SelectMethod=cursor

User name: sa

Also, using MS-SMS, create a systems admin account (sa) and use it to connect Servoy to the SQL server. The other items you mentioned, most likely, use a Windows account to connect.
Kim W. Premuda
San Diego, CA USA
User avatar
Posts: 687
Joined: Sat Jul 28, 2007 6:59 pm
Location: San Diego, CA USA

Re: Servoy 8.3.1 and SQL2017 Developer Edition

Postby jcompagner » Tue Feb 05, 2019 11:58 am

you can always try to use the latest 7.x driver of MS: ... erver-2017

We updated the driver also for the next servoy release (just delete the old driver and extract the new one from that download)
Johan Compagner
User avatar
Posts: 8849
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Return to I'm just getting started

Who is online

Users browsing this forum: No registered users and 0 guests