Problem connecting databases - SOLVED

Q&A regarding installation and issues getting started with Servoy

Problem connecting databases - SOLVED

Postby cp » Mon Jul 08, 2019 11:23 am

2019-07-08 16:06:21.961 CEST [1223] FATAL: database files are incompatible with server
2019-07-08 16:06:21.961 CEST [1223] DETAIL: The data directory was initialized by PostgreSQL version 9.6, which is not compatible with this version 10.7.

Did we get a new version of psql?
Anyhow copying the RC2 postgresSql with the final version og 2019 06 made things work.

Since I'm not the most database savvy I truly hope someone can point me in the right direction.

So, I did a clean update to SVY 2019 06 final, and installed the SVY version of Postgressql. I copied my old file to point to the right data folder.

Subsequently I see the databases in SVY but they are not connected. I made sure that the DB service is started and that a valid role is used - still I cannot see my old database/tables - not even in PGAdmin.

Any ideas would be highly appreciated?


2019-07-08 02:59:35,130 ERROR [Worker-19: Loading servers/tables needed by current solution] persistence.Server - Final get connection failure for server repository_server in 1 times [ ]
Posts: 11
Joined: Wed Nov 14, 2018 2:43 pm

Re: Problem connecting databases - SOLVED

Postby jcompagner » Tue Jul 09, 2019 4:41 pm

what i don't get it seems to have a "database" directory that is made by an old postgresql

in 2019.06 (from the first RC on) we ship a postgresql that is 10.7 version..
So i don't get how you get there old database files (if you do a new install)
Johan Compagner
User avatar
Posts: 8851
Joined: Tue May 27, 2003 7:26 pm
Location: The Internet

Re: Problem connecting databases - SOLVED

Postby c85700 » Wed Dec 18, 2019 3:56 pm

I think problem in old version
Posts: 4
Joined: Wed Dec 18, 2019 3:53 pm

Return to I'm just getting started

Who is online

Users browsing this forum: No registered users and 0 guests